Update Gitea to 1.5.0

This commit is contained in:
Martchus 2018-08-27 22:18:56 +02:00
parent 9337a71ad6
commit 02e65c38f3
3 changed files with 27 additions and 28 deletions

View File

@ -1,4 +1,4 @@
From 645901c3414447a928006f3e873bd7bdbc2c8f52 Mon Sep 17 00:00:00 2001
From b5974b77f2852bd31a9505172010fd92f09cff24 Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Sun, 19 Mar 2017 18:03:36 +0100
Subject: [PATCH 1/2] Adjust config for Arch Linux package
@ -8,11 +8,11 @@ Subject: [PATCH 1/2] Adjust config for Arch Linux package
1 file changed, 8 insertions(+), 8 deletions(-)
diff --git a/custom/conf/app.ini.sample b/custom/conf/app.ini.sample
index 7dddd5525..2f74bab0d 100644
index 774a1df59..f46f803cd 100644
--- a/custom/conf/app.ini.sample
+++ b/custom/conf/app.ini.sample
@@ -5,12 +5,12 @@
; App name that shows on every page title
@@ -7,12 +7,12 @@
; App name that shows in every page title
APP_NAME = Gitea: Git with a cup of tea
; Change it if you run locally
-RUN_USER = git
@ -26,7 +26,7 @@ index 7dddd5525..2f74bab0d 100644
SCRIPT_TYPE = bash
; Default ANSI charset
ANSI_CHARSET =
@@ -169,13 +169,13 @@ DISABLE_ROUTER_LOG = false
@@ -172,13 +172,13 @@ DISABLE_ROUTER_LOG = false
; not forget to export the private key):
; $ openssl pkcs12 -in cert.pfx -out cert.pem -nokeys
; $ openssl pkcs12 -in cert.pfx -out key.pem -nocerts -nodes
@ -34,7 +34,7 @@ index 7dddd5525..2f74bab0d 100644
-KEY_FILE = custom/https/key.pem
+CERT_FILE = /var/lib/gitea/cert/cert.pem
+KEY_FILE = /var/lib/gitea/cert/key.pem
; Upper level of template and static file path
; Root directory containing templates and static files.
; default is the path where Gitea is executed
-STATIC_ROOT_PATH =
+STATIC_ROOT_PATH = /usr/share/gitea
@ -44,16 +44,16 @@ index 7dddd5525..2f74bab0d 100644
; Application level GZIP support
ENABLE_GZIP = false
; Landing page, can be "home", "explore", or "organizations"
@@ -205,7 +205,7 @@ PASSWD =
@@ -210,7 +210,7 @@ PASSWD =
; For "postgres" only, either "disable", "require" or "verify-full"
SSL_MODE = disable
; For "sqlite3" and "tidb", use absolute path when you start as service
; For "sqlite3" and "tidb", use absolute path when you start gitea as service
-PATH = data/gitea.db
+PATH = /var/lib/gitea/gitea.db
; For "sqlite3" only. Query timeout
SQLITE_TIMEOUT = 500
; For iterate buffer, default is 50
@@ -420,7 +420,7 @@ MAX_FILES = 5
@@ -435,7 +435,7 @@ MAX_FILES = 5
FORMAT =
[log]
@ -63,5 +63,5 @@ index 7dddd5525..2f74bab0d 100644
; Use comma to separate multiple modes, e.g. "console, file"
MODE = console
--
2.17.1
2.18.0

View File

@ -1,14 +1,14 @@
From 69c3aa5739288c15f69f7f42d7df06db77e5b498 Mon Sep 17 00:00:00 2001
From 341499f12a729c9eeaf3740d052c2cce05ccc855 Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Sun, 19 Mar 2017 18:04:48 +0100
Subject: [PATCH 2/2] Adjust service file for Arch Linux package
---
contrib/systemd/gitea.service | 10 +++++-----
1 file changed, 5 insertions(+), 5 deletions(-)
contrib/systemd/gitea.service | 8 ++++----
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/contrib/systemd/gitea.service b/contrib/systemd/gitea.service
index 7c09fa321..c2ee2380d 100644
index 387de14fa..53ed61490 100644
--- a/contrib/systemd/gitea.service
+++ b/contrib/systemd/gitea.service
@@ -16,12 +16,12 @@ After=network.target
@ -17,18 +17,17 @@ index 7c09fa321..c2ee2380d 100644
Type=simple
-User=git
-Group=git
-WorkingDirectory=/home/git/gitea
-ExecStart=/home/git/gitea/gitea web
+User=gitea
+Group=gitea
+WorkingDirectory=/var/lib/gitea
+ExecStart=/usr/bin/gitea web --config /etc/gitea/app.ini
WorkingDirectory=/var/lib/gitea/
-ExecStart=/usr/local/bin/gitea web -c /etc/gitea/app.ini
+ExecStart=/usr/bin/gitea web -c /etc/gitea/app.ini
Restart=always
-Environment=USER=git HOME=/home/git
-Environment=USER=git HOME=/home/git GITEA_WORK_DIR=/var/lib/gitea
+Environment=USER=gitea HOME=/var/lib/gitea GITEA_WORK_DIR=/var/lib/gitea
[Install]
WantedBy=multi-user.target
# If you want to bind Gitea to a port below 1024 uncomment
# the two values below
###
--
2.17.1
2.18.0

View File

@ -10,8 +10,8 @@ _confdir=custom/conf
_scriptsdir=contrib
pkgname=${_pkgname}
pkgver=1.4.2
pkgrel=3
pkgver=1.5.0
pkgrel=1
#epoch=
pkgdesc='Self Hosted Git Service written in Go'
arch=('i686' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
@ -31,9 +31,9 @@ backup=("etc/$_pkgname/app.ini")
source=("$_pkgname-$pkgver::https://github.com/$_orga/$_pkgname/archive/v${pkgver}.tar.gz"
'0001-Adjust-config-for-Arch-Linux-package.patch'
'0002-Adjust-service-file-for-Arch-Linux-package.patch')
sha512sums=('ab4cd43753afffec53a46c093bf92a9c31a633f9c8b5d730e8782eceee1e581cce673945005aaa6a94428d8acfcf2e6618f3abcc49f2ac5439aa8a4fb910b550'
'909021bf765f5c40ffab5e2d460b265fa4cd658f85728953cbe9a02694721ece9622a09438302a4b4c02d5ee5eca8cf27b99a874bf4e00a92cdd9f90f4cda47e'
'cad4f0ecf55cbee745c2b8da743206f639bf7f3384dd123c2746b7671213e322c55a4c51bb9b9af5f80b0e0a5b6128ec5f55f89788aa664b43cab5f6fe86ab19')
sha512sums=('06cbcadc138496abf500b8d219d0770c5f6b8af419f9c3733596ee7e20cb50235815433979b2b1daa0a6117e6eb84de9678667236549e018079c49b793f22d68'
'6c5d02d4b124a834b72283833d8f3fe7b16e21c2f45a1516e3ea28e9ba07d374fc98f2e3dbccc4e8e76cfd3fabf01ffefa36a56121b348a35255b13b134ad4c6'
'73263dc75dad98c2b01e5fe0a7a2b6b0b5f63077895d35da6501f04c4f86ee652929e952b7800872d0b41877accbd84c518e3c9c440ae85741ed106582c0bf49')
_goroot='/usr/lib/go'
prepare() {