Add version of plasma-sdk containing debug build of plasmoidviewer

* Required for using QML debugging when developing Plasmoids
* See https://github.com/Martchus/syncthingtray/blob/master/plasmoid/testing.md
This commit is contained in:
Martchus 2017-09-26 20:17:48 +02:00
parent 55043e5b7d
commit 146d9200e8
3 changed files with 125 additions and 0 deletions

View File

@ -0,0 +1,38 @@
From 40747056394893a77200e463562beaed1478f58b Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Tue, 26 Sep 2017 19:50:11 +0200
Subject: [PATCH] Enable QML debugging
---
plasmoidviewer/CMakeLists.txt | 11 +++++++++++
1 file changed, 11 insertions(+)
diff --git a/plasmoidviewer/CMakeLists.txt b/plasmoidviewer/CMakeLists.txt
index 1c0ff46..ad7708d 100644
--- a/plasmoidviewer/CMakeLists.txt
+++ b/plasmoidviewer/CMakeLists.txt
@@ -1,3 +1,9 @@
+# allow enabling debug build specificly for plasmoidviewer
+option(PLASMOIDVIEWER_DEBUG "enables debug build for plasmoidviewer" OFF)
+if(PLASMOIDVIEWER_DEBUG)
+ set(CMAKE_BUILD_TYPE "Debug")
+endif()
+
set(plasmoidviewer_SRCS
main.cpp
view.cpp
@@ -6,6 +12,11 @@ set(plasmoidviewer_SRCS
add_executable(plasmoidviewer ${plasmoidviewer_SRCS})
target_compile_definitions(plasmoidviewer PRIVATE -DPROJECT_VERSION="${PROJECT_VERSION}")
+# enable QML debugging for debug build
+if(CMAKE_BUILD_TYPE STREQUAL "Debug")
+ target_compile_definitions(plasmoidviewer PRIVATE -DQT_QML_DEBUG)
+endif()
+
target_link_libraries(plasmoidviewer
Qt5::Quick
Qt5::DBus
--
2.14.1

49
plasma-sdk/debug/PKGBUILD Normal file
View File

@ -0,0 +1,49 @@
# $Id$
# Maintainer of regular package: Antonio Rojas <arojas@archlinux.org>
# Version with debug build of plasmoidviewer: Martchus <martchus@gmx.net>
pkgname=plasma-sdk-debug
pkgver=5.10.5
pkgrel=1
pkgdesc="Applications useful for Plasma development (with debug build of plasmoidviewer)"
arch=(i686 x86_64)
url='https://www.kde.org/workspaces/plasmadesktop/'
license=(LGPL)
depends=(plasma-framework)
makedepends=(extra-cmake-modules kitemmodels python2 kdoctools ktexteditor)
optdepends=('kirigami2: for Look & Feel explorer')
conflicts=(${pkgname%-debug} ${pkgname%-debug}-git)
options=(!strip)
groups=(plasma)
source=("https://download.kde.org/stable/plasma/$pkgver/${pkgname%-debug}-$pkgver.tar.xz"{,.sig}
'0001-Enable-QML-debugging.patch')
sha256sums=('cb833632b3baa4c9952c0096924acf8b1a0b918d4d162eb136c46631026f5656'
'SKIP'
'asdf')
validpgpkeys=('2D1D5B0588357787DE9EE225EC94D18F7F05997E' # Jonathan Riddell
'348C8651206633FD983A8FC4DEACEA00075E1D76' # KDE Neon
'D07BD8662C56CB291B316EB2F5675605C74E02CF') # David Edmundson
prepare() {
mkdir -p build
cd ${pkgname%-debug}-$pkgver
patch -Np1 -i ../0001-Enable-QML-debugging.patch
}
build() {
cd build
cmake ../${pkgname%-debug}-$pkgver \
-DCMAKE_INSTALL_PREFIX=/usr \
-DKDE_INSTALL_LIBDIR=lib \
-DCMAKE_BUILD_TYPE=Release \
-DBUILD_TESTING=OFF \
-DPLASMOIDVIEWER_DEBUG:BOOL=ON
}
package() {
cd build
make DESTDIR="$pkgdir" install
find "$pkgdir/usr/bin" -not -iname 'plasmoidviewer' -exec strip --strip-all {} \;
find "$pkgdir/usr/lib" -iname '*.so' -exec strip --strip-unneeded {} \;
}

View File

@ -0,0 +1,38 @@
# $Id$
# Maintainer: Antonio Rojas <arojas@archlinux.org>
pkgname=plasma-sdk
pkgver=5.10.5
pkgrel=1
pkgdesc="Applications useful for Plasma development"
arch=(i686 x86_64)
url='https://www.kde.org/workspaces/plasmadesktop/'
license=(LGPL)
depends=(plasma-framework)
makedepends=(extra-cmake-modules kitemmodels python2 kdoctools ktexteditor)
optdepends=('kirigami2: for Look & Feel explorer')
groups=(plasma)
source=("https://download.kde.org/stable/plasma/$pkgver/$pkgname-$pkgver.tar.xz"{,.sig})
sha256sums=('cb833632b3baa4c9952c0096924acf8b1a0b918d4d162eb136c46631026f5656'
'SKIP')
validpgpkeys=('2D1D5B0588357787DE9EE225EC94D18F7F05997E' # Jonathan Riddell
'348C8651206633FD983A8FC4DEACEA00075E1D76' # KDE Neon
'D07BD8662C56CB291B316EB2F5675605C74E02CF') # David Edmundson
prepare() {
mkdir -p build
}
build() {
cd build
cmake ../$pkgname-$pkgver \
-DCMAKE_INSTALL_PREFIX=/usr \
-DKDE_INSTALL_LIBDIR=lib \
-DCMAKE_BUILD_TYPE=Release \
-DBUILD_TESTING=OFF
}
package() {
cd build
make DESTDIR="$pkgdir" install
}