added missing files (mingw-w64-freetype2)

This commit is contained in:
Martchus 2015-12-12 19:58:55 +01:00
parent 922cc96991
commit 2d820ff670
5 changed files with 120 additions and 1 deletions

View File

@ -0,0 +1,34 @@
From 27f765b5f41638de36de728e9018a1400b0be615 Mon Sep 17 00:00:00 2001
From: "Jan Alexander Steffens (heftig)" <jan.steffens@gmail.com>
Date: Tue, 23 Jun 2015 08:40:29 +0200
Subject: [PATCH 1/4] Enable table validation modules
---
modules.cfg | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/modules.cfg b/modules.cfg
index 2984e51..a5db21d 100644
--- a/modules.cfg
+++ b/modules.cfg
@@ -110,7 +110,7 @@ RASTER_MODULES += smooth
AUX_MODULES += cache
# TrueType GX/AAT table validation. Needs ftgxval.c below.
-# AUX_MODULES += gxvalid
+AUX_MODULES += gxvalid
# Support for streams compressed with gzip (files with suffix .gz).
#
@@ -129,7 +129,7 @@ AUX_MODULES += bzip2
# OpenType table validation. Needs ftotval.c below.
#
-# AUX_MODULES += otvalid
+AUX_MODULES += otvalid
# Auxiliary PostScript driver component to share common code.
#
--
2.6.0

View File

@ -0,0 +1,25 @@
From 27d96091b2bb0a825cbd62a332ef918f39c6126f Mon Sep 17 00:00:00 2001
From: "Jan Alexander Steffens (heftig)" <jan.steffens@gmail.com>
Date: Tue, 23 Jun 2015 08:43:07 +0200
Subject: [PATCH 2/4] Enable subpixel rendering
---
include/freetype/config/ftoption.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/include/freetype/config/ftoption.h b/include/freetype/config/ftoption.h
index 4970945..ab407e3 100644
--- a/include/freetype/config/ftoption.h
+++ b/include/freetype/config/ftoption.h
@@ -92,7 +92,7 @@ FT_BEGIN_HEADER
/* This is done to allow FreeType clients to run unmodified, forcing */
/* them to display normal gray-level anti-aliased glyphs. */
/* */
-/* #define FT_CONFIG_OPTION_SUBPIXEL_RENDERING */
+#define FT_CONFIG_OPTION_SUBPIXEL_RENDERING
/*************************************************************************/
--
2.6.0

View File

@ -0,0 +1,25 @@
From f96a1d21d787b173d6293330fbf782b977194aa7 Mon Sep 17 00:00:00 2001
From: "Jan Alexander Steffens (heftig)" <jan.steffens@gmail.com>
Date: Tue, 23 Jun 2015 08:43:57 +0200
Subject: [PATCH 3/4] Enable subpixel hinting
---
include/freetype/config/ftoption.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/include/freetype/config/ftoption.h b/include/freetype/config/ftoption.h
index ab407e3..a2eab6a 100644
--- a/include/freetype/config/ftoption.h
+++ b/include/freetype/config/ftoption.h
@@ -602,7 +602,7 @@ FT_BEGIN_HEADER
/* This option requires TT_CONFIG_OPTION_BYTECODE_INTERPRETER to be */
/* defined. */
/* */
-/* #define TT_CONFIG_OPTION_SUBPIXEL_HINTING */
+#define TT_CONFIG_OPTION_SUBPIXEL_HINTING
/*************************************************************************/
--
2.6.0

View File

@ -0,0 +1,31 @@
From bb5ece9c6773145c8342107bd32fcacbc4b212ab Mon Sep 17 00:00:00 2001
From: "Jan Alexander Steffens (heftig)" <jan.steffens@gmail.com>
Date: Tue, 23 Jun 2015 08:34:54 +0200
Subject: [PATCH 4/4] Mask subpixel hinting with an env var
---
src/truetype/ttobjs.c | 7 ++++---
1 file changed, 4 insertions(+), 3 deletions(-)
diff --git a/src/truetype/ttobjs.c b/src/truetype/ttobjs.c
index 6060d6f..3fa98e7 100644
--- a/src/truetype/ttobjs.c
+++ b/src/truetype/ttobjs.c
@@ -1302,10 +1302,11 @@
TT_Driver driver = (TT_Driver)ttdriver;
#ifdef TT_CONFIG_OPTION_SUBPIXEL_HINTING
- driver->interpreter_version = TT_INTERPRETER_VERSION_38;
-#else
- driver->interpreter_version = TT_INTERPRETER_VERSION_35;
+ if ( getenv( "FT2_SUBPIXEL_HINTING" ) )
+ driver->interpreter_version = TT_INTERPRETER_VERSION_38;
+ else
#endif
+ driver->interpreter_version = TT_INTERPRETER_VERSION_35;
#else /* !TT_USE_BYTECODE_INTERPRETER */
--
2.6.0

View File

@ -62,4 +62,8 @@ OTHER_FILES += \
bento4/default/PKGBUILD \
ubuntu-latex-fonts/git/PKGBUILD \
ubuntu-latex-fonts/git/ubuntu-latex-fonts.install \
freetype2/mingw-w64/PKGBUILD
freetype2/mingw-w64/PKGBUILD \
freetype2/mingw-w64/0001-Enable-table-validation-modules.patch \
freetype2/mingw-w64/0002-Enable-subpixel-rendering.patch \
freetype2/mingw-w64/0003-Enable-subpixel-hinting.patch \
freetype2/mingw-w64/0004-Mask-subpixel-hinting-with-an-env-var.patch