Update mingw-w64-mariadb-connector-c to 2.3.3

This commit is contained in:
Martchus 2017-06-05 01:47:57 +02:00
parent 98abd6df3b
commit 36375b8f7c
4 changed files with 13 additions and 13 deletions

View File

@ -1,4 +1,4 @@
From 9af2954796a6f705b0a4f5ce415ce7bdfa3ab5ce Mon Sep 17 00:00:00 2001 From c37b9b98838a0914ec1a7d9d629c888cd22761bd Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net> From: Martchus <martchus@gmx.net>
Date: Sat, 17 Sep 2016 16:41:12 +0200 Date: Sat, 17 Sep 2016 16:41:12 +0200
Subject: [PATCH 1/3] Fix libnames for mingw-w64 Subject: [PATCH 1/3] Fix libnames for mingw-w64
@ -85,5 +85,5 @@ index f07dc02..ea58fd4 100644
INSTALL(DIRECTORY ${CMAKE_SOURCE_DIR}/include/ INSTALL(DIRECTORY ${CMAKE_SOURCE_DIR}/include/
DESTINATION ${INCLUDE_INSTALL_DIR}/${SUFFIX_INSTALL_DIR}) DESTINATION ${INCLUDE_INSTALL_DIR}/${SUFFIX_INSTALL_DIR})
-- --
2.9.3 2.13.0

View File

@ -1,4 +1,4 @@
From 7cfcfdc3b258bbbe67e29997899c80c2c7bfe2bc Mon Sep 17 00:00:00 2001 From 61d9463469334dec02e49c37a5710d06278e4682 Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net> From: Martchus <martchus@gmx.net>
Date: Sat, 17 Sep 2016 16:44:14 +0200 Date: Sat, 17 Sep 2016 16:44:14 +0200
Subject: [PATCH 2/3] Fix _SIZE_T_DEFINED under mingw-w64 Subject: [PATCH 2/3] Fix _SIZE_T_DEFINED under mingw-w64
@ -8,7 +8,7 @@ Subject: [PATCH 2/3] Fix _SIZE_T_DEFINED under mingw-w64
1 file changed, 1 insertion(+), 1 deletion(-) 1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/include/my_global.h b/include/my_global.h diff --git a/include/my_global.h b/include/my_global.h
index 176404c..1905544 100644 index e596d45..82a9284 100644
--- a/include/my_global.h --- a/include/my_global.h
+++ b/include/my_global.h +++ b/include/my_global.h
@@ -450,7 +450,7 @@ typedef SOCKET_SIZE_TYPE size_socket; @@ -450,7 +450,7 @@ typedef SOCKET_SIZE_TYPE size_socket;
@ -21,5 +21,5 @@ index 176404c..1905544 100644
#define USE_MY_STAT_STRUCT /* For my_lib */ #define USE_MY_STAT_STRUCT /* For my_lib */
#ifdef _MSC_VER #ifdef _MSC_VER
-- --
2.9.3 2.13.0

View File

@ -1,4 +1,4 @@
From cc7d7a770c85fc208d4d727a3d9efafd8316db70 Mon Sep 17 00:00:00 2001 From cd68269a531ce4e600f3a99d1687219e0959af84 Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net> From: Martchus <martchus@gmx.net>
Date: Sat, 17 Sep 2016 16:51:15 +0200 Date: Sat, 17 Sep 2016 16:51:15 +0200
Subject: [PATCH 3/3] Use fopen rather than fopen_s for XP compatibility Subject: [PATCH 3/3] Use fopen rather than fopen_s for XP compatibility
@ -25,7 +25,7 @@ index cd4a0f1..abca4ae 100644
(void) fprintf(stderr, ERR_OPEN, cs->process, name); (void) fprintf(stderr, ERR_OPEN, cs->process, name);
perror(""); perror("");
diff --git a/libmariadb/my_fopen.c b/libmariadb/my_fopen.c diff --git a/libmariadb/my_fopen.c b/libmariadb/my_fopen.c
index 5c0fb40..ad2deb9 100644 index c99b753..a3b485d 100644
--- a/libmariadb/my_fopen.c --- a/libmariadb/my_fopen.c
+++ b/libmariadb/my_fopen.c +++ b/libmariadb/my_fopen.c
@@ -36,11 +36,7 @@ FILE *my_fopen(const char *FileName, int Flags, myf MyFlags) @@ -36,11 +36,7 @@ FILE *my_fopen(const char *FileName, int Flags, myf MyFlags)
@ -41,5 +41,5 @@ index 5c0fb40..ad2deb9 100644
/* /*
The test works if MY_NFILE < 128. The problem is that fileno() is char The test works if MY_NFILE < 128. The problem is that fileno() is char
-- --
2.9.3 2.13.0

View File

@ -7,7 +7,7 @@
# All patches are managed at https://github.com/Martchus/mariadb-connector-c # All patches are managed at https://github.com/Martchus/mariadb-connector-c
pkgname=mingw-w64-mariadb-connector-c pkgname=mingw-w64-mariadb-connector-c
pkgver=2.3.1 pkgver=2.3.3
pkgrel=1 pkgrel=1
pkgdesc='MariaDB Connector/C is used to connect applications developed in C/C++ to MariaDB and MySQL databases (mingw-w64)' pkgdesc='MariaDB Connector/C is used to connect applications developed in C/C++ to MariaDB and MySQL databases (mingw-w64)'
arch=('any') arch=('any')
@ -23,10 +23,10 @@ source=("https://downloads.mariadb.org/interstitial/connector-c-${pkgver}/mariad
'0001-Fix-libnames-for-mingw-w64.patch' '0001-Fix-libnames-for-mingw-w64.patch'
'0002-Fix-_SIZE_T_DEFINED-under-mingw-w64.patch' '0002-Fix-_SIZE_T_DEFINED-under-mingw-w64.patch'
'0003-Use-fopen-rather-than-fopen_s-for-XP-compatibility.patch') '0003-Use-fopen-rather-than-fopen_s-for-XP-compatibility.patch')
sha1sums=('7c12d46799e270a14ea414ea23a79aff48bf24e6' sha1sums=('6fbf541a4465cd729c7f790a3d9cd337e8dd2666'
'1409632ae308a84fcb02bbec67b7c25851f9a0cf' '12a2d0b8d521dc097cecc3ea32efcaee0e7f9781'
'f0d680703b019b7aaf7ca3b9580a5e39b8482ba4' 'f07a59cdd02ad89e60edcb18a1cdc3ccda93fc2b'
'dd7b5e0dc58178773c37ee846dad93e71af21554') '3aa503bb7ad9b84c21cdef94f3a55d96a7fa8811')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32' _architectures='i686-w64-mingw32 x86_64-w64-mingw32'