Update vlc-nightly

* Sync with regular package
* Fix update script
* Update to 4.0.0v20181007
This commit is contained in:
Martchus 2018-10-07 18:27:14 +02:00
parent b0b1cc38c0
commit 3e528b5f3c
3 changed files with 7 additions and 34 deletions

View File

@ -1,24 +0,0 @@
From 2b6384b93e82d4366b96d353804c872ed1137c55 Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Sat, 26 May 2018 15:12:05 +0200
Subject: [PATCH 3/3] Fix compilation with Qt 5.11
---
modules/gui/qt/components/simple_preferences.cpp | 1 +
1 file changed, 1 insertion(+)
diff --git a/modules/gui/qt/components/simple_preferences.cpp b/modules/gui/qt/components/simple_preferences.cpp
index a6efacdcf5..ade20a9847 100644
--- a/modules/gui/qt/components/simple_preferences.cpp
+++ b/modules/gui/qt/components/simple_preferences.cpp
@@ -33,6 +33,7 @@
#include <vlc_config_cat.h>
#include <vlc_configuration.h>
+#include <QButtonGroup>
#include <QString>
#include <QFont>
#include <QToolButton>
--
2.18.0

View File

@ -5,10 +5,10 @@
_appname_=vlc
pkgname=${_appname_}-nightly
pkgver=4.0.0v20180915
pkgver=4.0.0v20181007
_pkgver=4.0.0
_snapshot_=20180915
_snapver_=0232
_snapshot_=20181007
_snapver_=0231
_suffix_=dev
_nightly_=${_snapshot_}-${_snapver_}
pkgrel=1
@ -16,12 +16,12 @@ pkgdesc='Multi-platform MPEG, VCD/DVD, and DivX player - nightly snapshot'
url='https://www.videolan.org/vlc/'
arch=('x86_64')
license=('LGPL2.1' 'GPL2')
depends=('a52dec' 'libdvbpsi' 'libxpm' 'libdca' 'libproxy' 'libtiger' 'lua'
depends=('a52dec' 'libdvbpsi' 'libxpm' 'libdca' 'libproxy' 'lua' 'libidn'
'libmatroska' 'taglib' 'libmpcdec' 'ffmpeg' 'faad2' 'libupnp' 'libmad'
'libmpeg2' 'xcb-util-keysyms' 'libtar' 'libxinerama' 'libsecret'
'libarchive' 'qt5-base' 'qt5-x11extras' 'qt5-svg' 'freetype2'
'fribidi' 'harfbuzz' 'fontconfig' 'libxml2' 'gnutls' 'libplacebo'
'wayland-protocols')
'wayland-protocols' 'aribb24')
makedepends=('gst-plugins-base-libs' 'live-media' 'libnotify' 'libbluray'
'flac' 'libdc1394' 'libavc1394' 'libcaca' 'gtk3'
'librsvg' 'libgme' 'xosd' 'twolame' 'aalib' 'avahi' 'libsystemd'
@ -31,7 +31,7 @@ makedepends=('gst-plugins-base-libs' 'live-media' 'libnotify' 'libbluray'
'libvorbis' 'speex' 'opus' 'libtheora' 'libpng' 'libjpeg-turbo'
'libx265.so' 'libx264.so' 'zvbi' 'libass' 'libkate' 'libtiger'
'sdl_image' 'libpulse' 'alsa-lib' 'jack' 'libsamplerate' 'libsoxr'
'lirc' 'libgoom2' 'projectm' 'chromaprint' 'aribb24'
'lirc' 'libgoom2' 'projectm' 'chromaprint'
'fluidsynth' 'libfdk-aac' 'portaudio' 'sidplay2-libs' 'sndio')
optdepends=('avahi: service discovery using bonjour protocol'
@ -78,7 +78,6 @@ optdepends=('avahi: service discovery using bonjour protocol'
'x265: HEVC/H.265 encoder'
'zvbi: VBI/Teletext decoding'
'libass: Subtitle support'
'aribb24: ARIB subtitles'
'libkate: Kate codec'
'libtiger: Tiger rendering for Kate streams'
'sdl_image: SDL image support'
@ -113,7 +112,6 @@ source=("http://nightlies.videolan.org/build/source/vlc-${_pkgver}-${_nightly_}-
'update-vlc-plugin-cache.hook'
'0001-lua-Fix-build-using-lua-5.3.patch'
'0002-Fix-compatibility-with-OpenCV-3.4.1.patch'
'0003-Fix-compilation-with-Qt-5.11.patch'
'find-deps.py')
pkgver() {
@ -127,7 +125,6 @@ prepare() {
patch -Np1 -i "${srcdir}/0001-lua-Fix-build-using-lua-5.3.patch"
patch -Np1 -i "${srcdir}/0002-Fix-compatibility-with-OpenCV-3.4.1.patch"
patch -Np1 -i "${srcdir}/0003-Fix-compilation-with-Qt-5.11.patch"
sed -i -e 's:truetype/ttf-dejavu:TTF:g' modules/visualization/projectm.cpp
sed -i -e 's:truetype/freefont:TTF:g' modules/text_renderer/freetype/freetype.c
sed 's|whoami|echo builduser|g' -i configure

View File

@ -10,7 +10,7 @@ srcurl='http://nightlies.videolan.org/build/source/'
srclist=$(curl "$srcurl")
msg 'Find latest nightly'
fileregex='(<a\ +href=\")(vlc-[^\"]+)(\">)'
fileregex='(<a\ +href=\")(vlc-([^\"]+)-([^\"]+)-([^\"]+)-([^\"]+))(\">)'
if ! [[ $srclist =~ $fileregex ]]; then
echo 'No source found'
exit -1