Update mingw-w64-gnutls to 3.5.12

This commit is contained in:
Martchus 2017-05-23 15:07:23 +02:00
parent 826b0087dc
commit 42249f2629
3 changed files with 16 additions and 61 deletions

View File

@ -1,35 +1,34 @@
# Maintainer: Martchus <martchus@gmx.net>
pkgname=mingw-w64-gnutls
pkgver=3.4.17
pkgver=3.5.12
pkgrel=1
pkgdesc="A library which provides a secure layer over a reliable transport layer (mingw-w64)"
arch=(any)
url="http://www.gnu.org/software/gnutls"
license=("GPL3, LGPL2.1")
license=('GPL3', 'LGPL2.1')
makedepends=(mingw-w64-configure)
depends=(mingw-w64-crt mingw-w64-libtasn1 mingw-w64-readline mingw-w64-zlib mingw-w64-nettle mingw-w64-p11-kit)
depends=(mingw-w64-crt mingw-w64-libtasn1 mingw-w64-readline mingw-w64-zlib mingw-w64-nettle mingw-w64-p11-kit mingw-w64-libunistring)
options=(staticlibs !strip !buildflags)
optdepends=("mingw-w64-openssl: libgnutls-openssl")
source=(ftp://ftp.gnutls.org/gcrypt/gnutls/v3.4/gnutls-${pkgver}.tar.xz{,.sig}
source=(https://www.gnupg.org/ftp/gcrypt/gnutls/v3.5/${pkgname#mingw-w64-}-${pkgver}.tar.xz{,.sig}
'gnutls-3.2.7-rpath.patch'
'gnutls-3.1.11-nosrp.patch'
'gnutls-3.3.6-default-policy.patch'
'gnutls-fix-external-libtasn1-detection.patch')
md5sums=('03ea7575a43f58964635a5064cce4dc0'
'SKIP'
'291612225516234ede7e60f8b367dd8b'
'c3a2abfe08f47d9b07f770689b0c1b39'
'e0dba6bfe81b965a352f965b1398bcad'
'f90a0f01eb0f2a6b7afcc25a836eb67e')
validpgpkeys=('1F42418905D8206AA754CCDC29EE58B996865171')
sha256sums=('63cb39a5eaa029381df2e49a74cfb7be89fc4a592445191818ffe1e66bde57cb'
'SKIP'
'9e18e03c8f736f49a46b911920e87ea52e3bb2b35044b1fc5ac0e45fd528935a'
'8525da75852a516be0cb05df0a770daf19ce0583033260d6cac03a1e40fd2072')
validpgpkeys=('0424D4EE81A0E3D119C6F835EDA21E94B565716F'
'1F42418905D8206AA754CCDC29EE58B996865171')
# "Simon Josefsson <simon@josefsson.org>"
# "Nikos Mavrogiannopoulos <nmav@gnutls.org>
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
prepare() {
cd "${srcdir}/gnutls-${pkgver}"
patch -p0 -i ../gnutls-fix-external-libtasn1-detection.patch
patch -p1 -i ../gnutls-3.2.7-rpath.patch
patch -p1 -i ../gnutls-3.1.11-nosrp.patch
#patch -p1 -i ../gnutls-3.3.6-default-policy.patch
sed 's/gnutls_srp.c//g' -i lib/Makefile.in
sed 's/gnutls_srp.lo//g' -i lib/Makefile.in
rm -f lib/minitasn1/*.c lib/minitasn1/*.h
@ -57,8 +56,7 @@ package() {
for _arch in ${_architectures}; do
cd "${srcdir}/gnutls-${pkgver}/build-${_arch}"
make DESTDIR="$pkgdir" install
rm "$pkgdir"/usr/${_arch}/bin/*.exe
rm "$pkgdir"/usr/${_arch}/bin/*.def
${_arch}-strip --strip-all "$pkgdir"/usr/${_arch}/bin/*.exe
${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
${_arch}-strip -g "$pkgdir"/usr/${_arch}/lib/*.a
done

View File

@ -1,12 +0,0 @@
diff -up gnutls-3.1.10/tests/srp/mini-srp.c.noecc gnutls-3.1.10/tests/srp/mini-srp.c
--- gnutls-3.1.10/tests/srp/mini-srp.c.noecc 2013-03-21 21:42:28.000000000 +0100
+++ gnutls-3.1.10/tests/srp/mini-srp.c 2013-03-25 13:42:20.753422209 +0100
@@ -27,7 +27,7 @@
#include <stdio.h>
#include <stdlib.h>
-#if defined(_WIN32)
+#if defined(_WIN32) || !defined(ENABLE_SRP)
int main()
{

View File

@ -1,31 +0,0 @@
diff -ur gnutls-3.3.6.orig/lib/gnutls_priority.c gnutls-3.3.6/lib/gnutls_priority.c
--- gnutls-3.3.6.orig/lib/gnutls_priority.c 2014-07-22 23:43:41.000000000 +0200
+++ gnutls-3.3.6/lib/gnutls_priority.c 2014-07-23 10:13:30.456310043 +0200
@@ -1110,6 +1110,7 @@
int algo;
rmadd_func *fn;
bulk_rmadd_func *bulk_fn;
+ unsigned dset = 0;
if (err_pos)
*err_pos = priorities;
@@ -1129,10 +1130,16 @@
(*priority_cache)->max_empty_records = DEFAULT_MAX_EMPTY_RECORDS;
- if (priorities == NULL)
- priorities = "NORMAL";
+ if (priorities == NULL) {
+ priorities = "@SYSTEM";
+ dset = 1;
+ }
darg = resolve_priorities(priorities);
+ if (darg == NULL && dset == 1) {
+ priorities = "NORMAL";
+ darg = resolve_priorities(priorities);
+ }
if (darg == NULL) {
gnutls_assert();
goto error;
Only in gnutls-3.3.6/lib: gnutls_priority.c.orig