Update mingw-w64-openssl to 3.0.7

* Update outdated packages that need a rebuild
This commit is contained in:
Martchus 2022-11-05 16:50:36 +01:00
parent 8b121d66fb
commit 4d994f9505
13 changed files with 23 additions and 111 deletions

View File

@ -80,7 +80,7 @@ my %kde_fork_revisions = (
activeqt => [0, '80b43bfe4109820fb7feddb4a16e227a03bc1c4e'],
winextras => [0, '2a04b162451460ffc208c2c27acce16a18f763ce'],
'3d' => [6, '0ff905d194e273e04e95b72dbbfd4e58193ecbaa'],
base => [167, '98c727f273fc83c24550274bd2728e1aafbd213a'],
base => [168, '08be11284246455bce4455138ebe396d2d8732a1'],
charts => [0, '055c6d6e49c5ea369990e7078fd534392a0ba6b9'],
connectivity => [5, '6796953f92a1d3af30d0676e56ec5dfd82199611'],
datavis3d => [0, '8e1a57efa1ba3eabbf44098ce6ede3d130c57b5d'],

View File

@ -16,7 +16,7 @@
pkgname=<%= $package_name %>
_qtver=6.4.0
pkgver=${_qtver/-/}
pkgrel=1
pkgrel=2
arch=(any)
url='https://www.qt.io'
license=(GPL3 LGPL3 FDL custom)

View File

@ -8,7 +8,7 @@
pkgname=mingw-w64-mariadb-connector-c
pkgver=3.3.1
pkgrel=1
pkgrel=2
pkgdesc='MariaDB Connector/C is used to connect applications developed in C/C++ to MariaDB and MySQL databases (mingw-w64)'
arch=('any')
url='https://mariadb.com/kb/en/mariadb/about-mariadb-connector-c'

View File

@ -2,8 +2,9 @@
# Contributor: Schala Zeal < schalaalexiazeal at gmail dot com >
# Contributor: ant32 < antreimer at gmail dot com >
# Contributor: Filip Brcic < brcha at gna dot org >
# Contributor: Martchus < martchus at gmx dot net >
_pkgver=1.1.1s
_pkgver=3.0.7
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
pkgname=mingw-w64-openssl
@ -11,15 +12,15 @@ pkgver=${_pkgver/[a-z]/.${_pkgver//[0-9.]/}}
pkgrel=1
pkgdesc="The Open Source toolkit for Secure Sockets Layer and Transport Layer Security (mingw-w64)"
arch=('any')
url="https://www.openssl.org"
license=('BSD')
url='https://www.openssl.org'
license=('Apache')
depends=('mingw-w64-zlib')
makedepends=('mingw-w64-gcc'
'mingw-w64-environment'
'perl')
options=('!strip' 'staticlibs' '!buildflags' '!lto')
source=("https://www.openssl.org/source/openssl-${_pkgver}.tar.gz"{,.asc})
sha256sums=('c5ac01e760ee6ff0dab61d6b2bbd30146724d063eb322180c6f18a6f74e4b6aa'
sha256sums=('83049d042a260e696f62406ac5c08bf706fd84383f945cf21bd61e9ed95c396e'
'SKIP')
validpgpkeys=('8657ABB260F056B1E5190839D9C4D26D0E604491'
'7953AC1FBC3DC8B3B292393ED5E9E43F7DF9EE8C'
@ -49,14 +50,14 @@ build() {
no-ssl3-method \
zlib-dynamic \
"${CFLAGS}"
make
make LIBDIR=lib
done
}
package() {
for _arch in ${_architectures}; do
cd "${srcdir}/build-${_arch}"
make -j1 DESTDIR="${pkgdir}" install_sw
make -j1 DESTDIR="${pkgdir}" LIBDIR=lib install_sw
install -m644 ms/applink.c "${pkgdir}/usr/${_arch}/include/openssl/"
find "${pkgdir}/usr/${_arch}" -name '*.exe' -exec ${_arch}-strip {} \;
find "${pkgdir}/usr/${_arch}" -name '*.dll' -exec ${_arch}-strip --strip-unneeded {} \;

View File

@ -7,7 +7,7 @@ _reponame=passwordfile
pkgname=mingw-w64-passwordfile
_name=${pkgname#mingw-w64-}
pkgver=5.0.7
pkgrel=1
pkgrel=2
arch=('any')
pkgdesc='C++ library to read/write passwords from/to encrypted files using AES-256-CBC via OpenSSL (mingw-w64)'
license=('GPL')

View File

@ -2,7 +2,7 @@
# Contributor: ant32 <antreimer@gmail.com>
pkgname=mingw-w64-postgresql
pkgver=14.2
pkgver=15.0
pkgrel=1
pkgdesc='Sophisticated object-relational DBMS (mingw-w64)'
arch=('any')
@ -17,7 +17,7 @@ replaces=('mingw-w64-postgresql-libs')
source=("http://ftp.postgresql.org/pub/source/v${pkgver}/postgresql-${pkgver}.tar.bz2"
'0001-Use-.dll.a-as-extension-for-import-libraries.patch'
'0002-Use-pthread-library-from-MinGW.patch')
sha256sums=('2cf78b2e468912f8101d695db5340cf313c2e9f68a612fb71427524e8c9a977a'
sha256sums=('72ec74f4a7c16e684f43ea42e215497fcd4c55d028a68fb72e99e61ff40da4d6'
'6119ad2418ce9995acf13b0f095ffa521250bae18cd387083c04e92b6ff22814'
'55c636400087482f896530e80f07706fff6c5c5b5654955d71944f035940e6a5')

View File

@ -1,32 +0,0 @@
From 24ed2f3a3488bb3188110d0623cfc50e632dfca1 Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Thu, 27 Jan 2022 12:24:50 +0100
Subject: [PATCH 1/2] Avoid calling setChildProcessModifier() on Windows
---
plugins/qca-gnupg/gpgproc/sprocess.cpp | 2 ++
1 file changed, 2 insertions(+)
diff --git a/plugins/qca-gnupg/gpgproc/sprocess.cpp b/plugins/qca-gnupg/gpgproc/sprocess.cpp
index 4eba7ac7..a1bbe737 100644
--- a/plugins/qca-gnupg/gpgproc/sprocess.cpp
+++ b/plugins/qca-gnupg/gpgproc/sprocess.cpp
@@ -32,6 +32,7 @@ namespace gpgQCAPlugin {
SProcess::SProcess(QObject *parent)
: QProcess(parent)
{
+#ifdef Q_OS_UNIX
#if QT_VERSION >= QT_VERSION_CHECK(6, 0, 0)
setChildProcessModifier([this]() {
// set the pipes to be inheritable
@@ -39,6 +40,7 @@ SProcess::SProcess(QObject *parent)
::fcntl(pipeList[n], F_SETFD, (::fcntl(pipeList[n], F_GETFD) & ~FD_CLOEXEC));
});
#endif
+#endif
}
SProcess::~SProcess()
--
2.35.0

View File

@ -1,48 +0,0 @@
From fec80e0fae55dfbe99211fbe51f3b1650d5c84b4 Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Thu, 27 Jan 2022 13:40:30 +0100
Subject: [PATCH 2/2] Fix types in socket notifier to fix x86_64 Windows build
---
src/qca_safeobj.cpp | 2 +-
src/qca_safeobj.h | 4 ++--
2 files changed, 3 insertions(+), 3 deletions(-)
diff --git a/src/qca_safeobj.cpp b/src/qca_safeobj.cpp
index 7133990f..b2ad3888 100644
--- a/src/qca_safeobj.cpp
+++ b/src/qca_safeobj.cpp
@@ -34,7 +34,7 @@ inline void releaseAndDeleteLater(QObject *owner, QObject *obj)
obj->deleteLater();
}
-SafeSocketNotifier::SafeSocketNotifier(int socket, QSocketNotifier::Type type, QObject *parent)
+SafeSocketNotifier::SafeSocketNotifier(qintptr socket, QSocketNotifier::Type type, QObject *parent)
: QObject(parent)
{
sn = new QSocketNotifier(socket, type, this);
diff --git a/src/qca_safeobj.h b/src/qca_safeobj.h
index ad819958..87b66594 100644
--- a/src/qca_safeobj.h
+++ b/src/qca_safeobj.h
@@ -33,7 +33,7 @@ class SafeSocketNotifier : public QObject
{
Q_OBJECT
public:
- SafeSocketNotifier(int socket, QSocketNotifier::Type type, QObject *parent = nullptr);
+ SafeSocketNotifier(qintptr socket, QSocketNotifier::Type type, QObject *parent = nullptr);
~SafeSocketNotifier() override;
@@ -57,7 +57,7 @@ public Q_SLOTS:
}
Q_SIGNALS:
- void activated(int socket);
+ void activated(QSocketDescriptor socket);
private:
QSocketNotifier *sn;
--
2.35.0

View File

@ -6,7 +6,7 @@
pkgbase=mingw-w64-qca-qt5
pkgname=(mingw-w64-qca-qt5 mingw-w64-qca-qt6)
pkgver=2.3.4
pkgver=2.3.5
pkgrel=1
pkgdesc='Qt Cryptographic Architecture (mingw-w64)'
arch=('any')
@ -14,22 +14,13 @@ url='https://userbase.kde.org/QCA'
license=(LGPL)
makedepends=('mingw-w64-cmake' 'mingw-w64-qt5-base' 'mingw-w64-qt6-5compat' 'qt6-base' 'ninja')
options=('!strip' '!buildflags' 'staticlibs')
source=(https://download.kde.org/stable/qca/$pkgver/qca-$pkgver.tar.xz{,.sig}
0001-Avoid-calling-setChildProcessModifier-on-Windows.patch
0002-Fix-types-in-socket-notifier-to-fix-x86_64-Windows-b.patch)
sha256sums=('6b695881a7e3fd95f73aaee6eaeab96f6ad17e515e9c2b3d4b3272d7862ff5c4'
'SKIP' 'SKIP')
source=(https://download.kde.org/stable/qca/$pkgver/qca-$pkgver.tar.xz{,.sig})
sha256sums=('91f7d916ab3692bf5991f0a553bf8153161bfdda14bd005d480a2b4e384362e8'
'SKIP')
validpgpkeys=(CB9387521E1EE0127DA804843FDBB55084CC5D84) # Harald Sitter <sitter@kde.org>
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
prepare() {
cd qca-$pkgver
for p in "$srcdir"/*.patch ; do
patch -p1 -i "$p"
done
}
build() {
for _arch in ${_architectures}; do
${_arch}-cmake -G Ninja -B build-qt5-${_arch} -S qca-$pkgver \

View File

@ -17,10 +17,10 @@
_qt_module=qtbase
pkgname=mingw-w64-qt5-base-static
pkgver=5.15.7+kde+r167
pkgver=5.15.7+kde+r168
pkgrel=1
_basever=${pkgver%%+*}
_commit=98c727f273fc83c24550274bd2728e1aafbd213a
_commit=08be11284246455bce4455138ebe396d2d8732a1
pkgdesc='A cross-platform application and UI framework, native OpenGL backend (mingw-w64)'
arch=('any')
url='https://www.qt.io/'

View File

@ -17,10 +17,10 @@
_qt_module=qtbase
pkgname=mingw-w64-qt5-base
pkgver=5.15.7+kde+r167
pkgver=5.15.7+kde+r168
pkgrel=1
_basever=${pkgver%%+*}
_commit=98c727f273fc83c24550274bd2728e1aafbd213a
_commit=08be11284246455bce4455138ebe396d2d8732a1
pkgdesc='A cross-platform application and UI framework, native OpenGL backend (mingw-w64)'
arch=('i686' 'x86_64')
url='https://www.qt.io/'

View File

@ -13,7 +13,7 @@
pkgname=mingw-w64-qt6-base-static
_qtver=6.4.0
pkgver=${_qtver/-/}
pkgrel=1
pkgrel=2
arch=(any)
url='https://www.qt.io'
license=(GPL3 LGPL3 FDL custom)

View File

@ -13,7 +13,7 @@
pkgname=mingw-w64-qt6-base
_qtver=6.4.0
pkgver=${_qtver/-/}
pkgrel=1
pkgrel=2
arch=(any)
url='https://www.qt.io'
license=(GPL3 LGPL3 FDL custom)