added pkgconfig fix (from AUR)

This commit is contained in:
Martchus 2016-01-04 20:59:07 +01:00
parent fede978f2b
commit 4fc3ec473f
2 changed files with 20 additions and 5 deletions

View File

@ -4,10 +4,11 @@
# Contributor: ice-man <icemanf@gmail.com>
# Contributor: sergeantspoon <sergeantspoon@archlinux.us>
# Contributor: Alexey Pavlov <alexpux@gmail.com>
# Contributor: Martchus <martchus@gmx.net>
pkgname=mingw-w64-libssh
pkgver=0.7.2
pkgrel=2
pkgrel=4
pkgdesc="Library for accessing ssh client services through C libraries (mingw-w64)"
url="http://www.libssh.org/"
license=('LGPL')
@ -27,7 +28,7 @@ md5sums=('5d7d468937649a6dfc6186edfff083db'
'SKIP'
'fc03637960f420837ad506892b444986'
'7be13e00d27ce77f862012ee0654019b'
'500031299c94117c62526601ec966f1e'
'8362595ebf2d566f0c6dec7c0c65219d'
'd608bd0626ef16ca7f1ac2446e8f411c')
validpgpkeys=('8DFF53E18F2ABC8D8F3C92237EE0FC4DCC014E3D') # Andreas Schneider <asn@cryptomilk.org>
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
@ -72,5 +73,8 @@ package(){
cd "${srcdir}"/build-${_arch}
make DESTDIR="${pkgdir}" install
${_arch}-strip --strip-unneeded "${pkgdir}"/usr/${_arch}/bin/*.dll
${_arch}-strip -g "${pkgdir}"/usr/${_arch}/lib/*.a
done
}

View File

@ -1,15 +1,26 @@
diff -ru libssh-0.7.2/CMakeLists.txt patched/CMakeLists.txt
--- libssh-0.7.2/CMakeLists.txt 2015-09-16 08:44:35.000000000 +0200
+++ patched/CMakeLists.txt 2015-11-12 16:00:58.999198281 +0100
@@ -84,7 +84,7 @@
+++ patched/CMakeLists.txt 2015-12-26 16:06:48.989612824 +0100
@@ -84,8 +84,8 @@
add_subdirectory(src)
# pkg-config file
-if (UNIX)
-configure_file(libssh.pc.cmake ${CMAKE_CURRENT_BINARY_DIR}/libssh.pc)
+if (UNIX OR MINGW)
configure_file(libssh.pc.cmake ${CMAKE_CURRENT_BINARY_DIR}/libssh.pc)
+configure_file(libssh.pc.cmake ${CMAKE_CURRENT_BINARY_DIR}/libssh.pc @ONLY)
install(
FILES
${CMAKE_CURRENT_BINARY_DIR}/libssh.pc
@@ -97,7 +97,7 @@
)
if (LIBSSH_THREADS)
- configure_file(libssh_threads.pc.cmake ${CMAKE_CURRENT_BINARY_DIR}/libssh_threads.pc)
+ configure_file(libssh_threads.pc.cmake ${CMAKE_CURRENT_BINARY_DIR}/libssh_threads.pc @ONLY)
install(
FILES
${CMAKE_CURRENT_BINARY_DIR}/libssh.pc
@@ -108,7 +108,7 @@
pkgconfig
)