Update vlc-nightly to 4.0.0v20180311

* Sync with regular vlc package
* Fix compatibility with OpenCV 3.4.1
This commit is contained in:
Martchus 2018-03-11 20:40:42 +01:00
parent db002e0112
commit 620080af97
4 changed files with 259 additions and 98 deletions

View File

@ -0,0 +1,75 @@
From 5897545a4149c68e3996cfbe1e13894f03aaa307 Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Sun, 11 Mar 2018 20:23:42 +0100
Subject: [PATCH 2/2] Fix compatibility with OpenCV 3.4.1
---
modules/video_filter/Makefile.am | 2 +-
modules/video_filter/{opencv_wrapper.c => opencv_wrapper.cpp} | 6 +++---
po/POTFILES.in | 2 +-
3 files changed, 5 insertions(+), 5 deletions(-)
rename modules/video_filter/{opencv_wrapper.c => opencv_wrapper.cpp} (98%)
diff --git a/modules/video_filter/Makefile.am b/modules/video_filter/Makefile.am
index af190d16e3..d1703a7ed3 100644
--- a/modules/video_filter/Makefile.am
+++ b/modules/video_filter/Makefile.am
@@ -147,7 +147,7 @@ endif
libdeinterlace_plugin_la_LIBADD = libdeinterlace_common.la
video_filter_LTLIBRARIES += libdeinterlace_plugin.la
-libopencv_wrapper_plugin_la_SOURCES = video_filter/opencv_wrapper.c
+libopencv_wrapper_plugin_la_SOURCES = video_filter/opencv_wrapper.cpp
libopencv_wrapper_plugin_la_CPPFLAGS = $(AM_CPPFLAGS) $(OPENCV_CFLAGS)
libopencv_wrapper_plugin_la_LIBADD = $(OPENCV_LIBS)
libopencv_wrapper_plugin_la_LDFLAGS = $(AM_LDFLAGS) -rpath '$(video_filterdir)'
diff --git a/modules/video_filter/opencv_wrapper.c b/modules/video_filter/opencv_wrapper.cpp
similarity index 98%
rename from modules/video_filter/opencv_wrapper.c
rename to modules/video_filter/opencv_wrapper.cpp
index 525e55db1b..1e4f19c871 100644
--- a/modules/video_filter/opencv_wrapper.c
+++ b/modules/video_filter/opencv_wrapper.cpp
@@ -154,7 +154,7 @@ static int Create( vlc_object_t *p_this )
char *psz_chroma, *psz_output;
/* Allocate structure */
- p_filter->p_sys = malloc( sizeof( filter_sys_t ) );
+ p_filter->p_sys = reinterpret_cast<filter_sys_t*>( malloc( sizeof( filter_sys_t ) ) );
if( p_filter->p_sys == NULL )
return VLC_ENOMEM;
@@ -167,7 +167,7 @@ static int Create( vlc_object_t *p_this )
* We don't need to set up video formats for this filter as it not
* actually using a picture_t.
*/
- p_filter->p_sys->p_opencv = vlc_object_create( p_filter, sizeof(filter_t) );
+ p_filter->p_sys->p_opencv = reinterpret_cast<filter_t*>( vlc_object_create( p_filter, sizeof(filter_t) ) );
if( !p_filter->p_sys->p_opencv ) {
free( p_filter->p_sys );
return VLC_ENOMEM;
@@ -315,7 +315,7 @@ static void VlcPictureToIplImage( filter_t* p_filter, picture_t* p_in )
{
int planes = p_in->i_planes; //num input video planes
// input video size
- CvSize sz = cvSize(abs(p_in->format.i_width), abs(p_in->format.i_height));
+ CvSize sz = cvSize(abs(static_cast<int>(p_in->format.i_width)), abs(static_cast<int>(p_in->format.i_height)));
video_format_t fmt_out;
filter_sys_t* p_sys = p_filter->p_sys;
diff --git a/po/POTFILES.in b/po/POTFILES.in
index 528249a98c..78d2128373 100644
--- a/po/POTFILES.in
+++ b/po/POTFILES.in
@@ -1145,7 +1145,7 @@ modules/video_filter/motionblur.c
modules/video_filter/motiondetect.c
modules/video_filter/oldmovie.c
modules/video_filter/opencv_example.cpp
-modules/video_filter/opencv_wrapper.c
+modules/video_filter/opencv_wrapper.cpp
modules/video_filter/posterize.c
modules/video_filter/postproc.c
modules/video_filter/psychedelic.c
--
2.16.2

View File

@ -5,10 +5,10 @@
_appname_=vlc
pkgname=${_appname_}-nightly
pkgver=4.0.0v20180228
pkgver=4.0.0v20180311
_pkgver=4.0.0
_snapshot_=20180228
_snapver_=0238
_snapshot_=20180311
_snapver_=0236
_suffix_=dev
_nightly_=${_snapshot_}-${_snapver_}
pkgrel=1
@ -16,56 +16,93 @@ pkgdesc='Multi-platform MPEG, VCD/DVD, and DivX player - nightly snapshot'
url='https://www.videolan.org/vlc/'
arch=('x86_64')
license=('LGPL2.1' 'GPL2')
_undetected_depends=()
depends=('a52dec' 'libdvbpsi' 'libxpm' 'libdca' 'libproxy' 'sdl_image' 'libdvdnav'
'libtiger' 'lua' 'libmatroska' 'zvbi' 'taglib' 'libmpcdec' 'ffmpeg'
'faad2' 'libupnp' 'libshout' 'libmad' 'libmpeg2' 'xcb-util-keysyms'
'libtar' 'libxinerama' 'wayland-protocols' 'libsecret' 'libarchive'
'qt5-base' 'qt5-x11extras' 'qt5-svg' "${_detected_depends[@]}")
makedepends=('live-media' 'libnotify' 'libbluray' 'flac' 'kdelibs' 'libdc1394'
'libavc1394' 'lirc' 'libcaca' 'gtk3' 'librsvg' 'portaudio'
'libgme' 'xosd' 'projectm' 'twolame' 'aalib' 'libmtp' 'libdvdcss'
'smbclient' 'libgoom2' 'vcdimager' 'opus' 'libssh2' 'mesa' 'protobuf'
'opencv' 'libnfs' 'mpg123' 'schroedinger' 'gst-plugins-base-libs'
'sidplay2-libs' 'libfdk-aac' 'daala-git' 'sndio')
optdepends=('avahi: for service discovery using bonjour protocol'
depends=('a52dec' 'libdvbpsi' 'libxpm' 'libdca' 'libproxy' 'libtiger' 'lua'
'libmatroska' 'taglib' 'libmpcdec' 'ffmpeg' 'faad2' 'libupnp' 'libmad'
'libmpeg2' 'xcb-util-keysyms' 'libtar' 'libxinerama' 'libsecret'
'libarchive' 'qt5-base' 'qt5-x11extras' 'qt5-svg' 'freetype2'
'fribidi' 'harfbuzz' 'fontconfig' 'libxml2' 'gnutls' 'libplacebo'
'wayland-protocols')
makedepends=('gst-plugins-base-libs' 'live-media' 'libnotify' 'libbluray'
'flac' 'kdelibs' 'libdc1394' 'libavc1394' 'libcaca' 'gtk3'
'librsvg' 'libgme' 'xosd' 'twolame' 'aalib' 'avahi' 'libsystemd'
'libmtp' 'libmicrodns' 'libdvdcss' 'smbclient'
'vcdimager' 'libssh2' 'mesa' 'protobuf' 'opencv' 'libnfs' 'mpg123'
'libdvdread' 'libdvdnav' 'libogg' 'libshout' 'libmodplug' 'libvpx'
'libvorbis' 'speex' 'opus' 'libtheora' 'libpng'
'libjpeg-turbo' 'libx265.so' 'libx264.so' 'zvbi' 'libass'
'libkate' 'libtiger' 'sdl_image' 'libpulse' 'alsa-lib' 'jack'
'libsamplerate' 'libsoxr' 'lirc' 'libgoom2' 'projectm'
'chromaprint'
'libfdk-aac' 'portaudio' 'sidplay2-libs' 'daala-git' 'sndio')
optdepends=('avahi: service discovery using bonjour protocol'
'gst-plugins-base-libs: for libgst plugins'
'libdvdcss: decoding encrypted DVDs'
'libavc1394: devices using the 1394ta AV/C'
'libdc1394: IEEE 1394 access plugin'
'kdelibs: KDE Solid hardware integration'
'kwallet: kwallet keystore'
'libva-vdpau-driver: vdpau backend nvidia'
'libva-intel-driver: video backend intel'
'libbluray: Blu-Ray video input'
'flac: Free Lossless Audio Codec plugin'
'twolame: TwoLAME mpeg2 encoder plugin'
'libgme: Game Music Emu plugin'
'vcdimager: navigate VCD with libvcdinfo'
'libmtp: MTP devices discovery'
'libsystemd: udev services discovery'
'smbclient: SMB access plugin'
'libcdio: audio CD playback'
'ttf-freefont: subtitle font '
'ttf-dejavu: subtitle font'
'libssh2: sftp access'
'opencv: opencv video'
'libnfs: NFS access'
'mpg123: mpg123 codec'
'protobuf: chromecast streaming'
'libmicrodns: mDNS services discovery (chromecast etc)'
'lua-socket: http interface'
'live-media: RTSP input'
'libdvdread: DVD input module'
'libdvdnav: DVD with navigation input module'
'libogg: Ogg and OggSpots codec'
'libshout: shoutcast/icecast output plugin'
'libmodplug: MOD output plugin'
'libvpx: VP8 and VP9 codec'
'libvorbis: Vorbis decoder/encoder'
'speex: Speex codec'
'opus: opus codec'
'libtheora: theora codec'
'libpng: PNG support'
'libjpeg-turbo: JPEG support'
'librsvg: SVG plugin'
'libx264: H264 encoding'
'x265: HEVC/H.265 encoder'
'zvbi: VBI/Teletext decoding'
'libass: Subtitle support'
'libkate: Kate codec'
'libtiger: Tiger rendering for Kate streams'
'sdl_image: SDL image support'
'aalib: ASCII art video output'
'libcaca: colored ASCII art video output'
'libpulse: PulseAudio audio output'
'alsa-lib: ALSA audio output'
'jack: jack audio server'
'libsamplerate: audio Resampler'
'libsoxr: SoX audio Resampler'
'chromaprint: Chromaprint audio fingerprinter'
'lirc: lirc control'
'libgoom2: Goom visualization'
'projectm: ProjectM visualisation'
'ncurses: ncurses interface'
'libnotify: notification plugin'
'gtk3: notification plugin'
'ncurses: for ncurses interface support'
'gst-plugins-base-libs: for libgst plugins'
'libdvdcss: for decoding encrypted DVDs'
'lirc: lirc control plugin'
'libavc1394: for devices using the 1394ta AV/C'
'libdc1394: for IEEE 1394 plugin'
'kdelibs: KDE Solid hardware integration'
'libva-vdpau-driver: vdpau back-end for nvidia'
'libva-intel-driver: back-end for intel cards'
'libbluray: for Blu-Ray support'
'flac: for Free Lossless Audio Codec plugin'
'libfdk-aac: FDK AAC codec'
'portaudio: portaudio support'
'twolame: for TwoLAME mpeg2 encoder plugin'
'projectm: for ProjectM visualisation plugin'
'libcaca: for colored ASCII art video output'
'libgme: for libgme plugin'
'librsvg: for SVG plugin'
'libgoom2: for libgoom plugin'
'vcdimager: navigate VCD with libvcdinfo'
'aalib: for ASCII art plugin'
'libmtp: for MTP devices support'
'smbclient: for SMB access plugin'
'libcdio: for audio CD playback support'
'ttf-freefont: for subtitle font'
'ttf-dejavu: for subtitle font'
'opus: for opus support'
'libssh2: for sftp support'
'opencv: opencv video support'
'libnfs: NFS access support'
'mpg123: mpg123 codec support'
'schroedinger: schroedinger codec support'
'protobuf: chromecast support'
'lua-socket: for http interface'
'sidplay2-libs: for C64 sid demuxer'
'libfdk-aac: for FDK-AAC Audio encoder'
'daala-git: for Daala video support'
'sndio: for OpenBSD sndio audio output')
conflicts=("${_appname_}-plugin" "${_appname_}")
@ -74,8 +111,8 @@ replaces=("${_appname_}-plugin")
options=('!emptydirs')
source=("http://nightlies.videolan.org/build/source/vlc-${_pkgver}-${_nightly_}-${_suffix_}.tar.xz"
'update-vlc-plugin-cache.hook'
'lua53_compat.patch'
'fribidi_compat.patch'
'0001-lua-fix-build-using-lua-5.3.patch'
'0002-Fix-compatibility-with-OpenCV-3.4.1.patch'
'find-deps.py')
pkgver() {
@ -87,8 +124,8 @@ prepare() {
./bootstrap
patch -Np1 -i "${srcdir}/lua53_compat.patch"
patch -Np1 -i "${srcdir}/fribidi_compat.patch"
patch -Np1 -i "${srcdir}/0001-lua-fix-build-using-lua-5.3.patch"
patch -Np1 -i "${srcdir}/0002-Fix-compatibility-with-OpenCV-3.4.1.patch"
sed -i -e 's:truetype/ttf-dejavu:TTF:g' modules/visualization/projectm.cpp
sed -i -e 's:truetype/freefont:TTF:g' modules/text_renderer/freetype/freetype.c
sed 's|whoami|echo builduser|g' -i configure
@ -105,28 +142,100 @@ build() {
export LUA_LIBS="`pkg-config --libs lua`"
export RCC=/usr/bin/rcc-qt5
./configure \
--prefix=/usr \
--sysconfdir=/etc \
--libexecdir=/usr/lib \
--disable-rpath \
--enable-aa \
--enable-archive \
--enable-bluray \
--enable-daala \
--enable-faad \
--enable-fdkaac \
--enable-lirc \
--enable-ncurses \
--enable-nls \
--enable-opus \
--enable-realrtsp \
--enable-sftp \
--enable-upnp \
--enable-vcdx \
--enable-wayland
./compile
./configure --prefix=/usr \
--sysconfdir=/etc \
--disable-rpath \
--enable-nls \
--enable-archive \
--enable-live555 \
--enable-dc1394 \
--enable-dv1394 \
--enable-dvdread \
--enable-dvdnav \
--enable-bluray \
--enable-opencv \
--enable-smbclient \
--enable-sftp \
--enable-nfs \
--enable-realrtsp \
--enable-dvbpsi \
--enable-gme \
--enable-ogg \
--enable-shout \
--enable-matroska \
--enable-mod \
--enable-mpc \
--enable-mad \
--enable-mpg123 \
--enable-gst-decode \
--enable-avcodec \
--enable-libva \
--enable-avformat \
--enable-postproc \
--enable-faad \
--enable-vpx \
--enable-twolame \
--enable-a52 \
--enable-dca \
--enable-flac \
--enable-libmpeg2 \
--enable-vorbis \
--enable-speex \
--enable-opus \
--enable-oggspots \
--disable-schroedinger \
--enable-png \
--enable-jpeg \
--enable-x264 \
--enable-x265 \
--enable-zvbi \
--enable-libass \
--enable-kate \
--enable-tiger \
--enable-vdpau \
--enable-wayland \
--enable-sdl-image \
--enable-freetype \
--enable-fribidi \
--enable-harfbuzz \
--enable-fontconfig \
--enable-svg \
--enable-svgdec \
--enable-aa \
--enable-caca \
--enable-pulse \
--enable-alsa \
--enable-jack \
--enable-samplerate \
--enable-soxr \
--enable-chromaprint \
--enable-chromecast \
--enable-qt \
--enable-skins2 \
--enable-libtar \
--enable-ncurses \
--enable-lirc \
--enable-goom \
--enable-projectm \
--enable-avahi \
--enable-mtp \
--enable-upnp \
--enable-microdns \
--enable-libxml2 \
--disable-libgcrypt \
--enable-gnutls \
--enable-taglib \
--enable-secret \
--enable-kwallet \
--disable-update-check \
--enable-notify \
--enable-libplacebo \
--enable-vlc \
\
--libexecdir=/usr/lib \
--enable-daala \
--enable-fdkaac
make V=1
}
package() {
@ -149,8 +258,8 @@ package() {
# depends=("${_detected_depends[@]}" "${_undetected_depends[@]}")
}
sha256sums=('29bf008daa301b204c90fda129d95440f374224d3fecb956c052a945c8d636f2'
sha256sums=('822e8b447522d9ce67f46fca84cd3cb55109d4088efac2a5eb2b72150e4ef4d1'
'c6f60c50375ae688755557dbfc5bd4a90a8998f8cf4d356c10d872a1a0b44f3a'
'75ad8802bad1a79754e40fd107f5a6922c54f7467dadef8b439b49d410c8f7d2'
'a5273ca82c95a3b70573f9b71ad4fd49d970e78fc5a3cc7970648474d00df5d5'
'4e5c7582b2c1090e598710a6afa6062348f4e87b3909c3d9f12f12e08e0eea6c'
'90b0e34d5772d2307ba07a1c2aa715db7488389003cfe6d3570b2a9c63061db7')

View File

@ -1,23 +0,0 @@
From 645effb2077e3aa9de70d30e14afc3e395ade2c6 Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Sat, 24 Feb 2018 01:35:46 +0100
Subject: [PATCH] text_renderer: freetype: allow using recent fribidi
---
modules/text_renderer/freetype/text_layout.c | 3 +++
1 file changed, 3 insertions(+)
diff --git a/modules/text_renderer/freetype/text_layout.c b/modules/text_renderer/freetype/text_layout.c
index 13efd567b46..6e554d4cbe1 100644
--- a/modules/text_renderer/freetype/text_layout.c
+++ b/modules/text_renderer/freetype/text_layout.c
@@ -54,6 +54,9 @@
#if defined(HAVE_FRIBIDI)
# define FRIBIDI_NO_DEPRECATED 1
# include <fribidi.h>
+# ifndef fribidi_get_par_embedding_levels
+# include <fribidi-deprecated.h>
+# endif
#endif
/* Complex Scripts */