Fix install path of KIO plugin if syncthingtray-qt6

This commit is contained in:
Martchus 2023-11-22 00:48:57 +01:00
parent d7bd9145c3
commit 71edcb87fe
2 changed files with 35 additions and 3 deletions

View File

@ -0,0 +1,25 @@
From d1a1c80ed5e2f5ab6a822b07ef3e9e4fd79a5a7d Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Wed, 22 Nov 2023 00:39:46 +0100
Subject: [PATCH] Fix install path of KIO plugin
---
fileitemactionplugin/CMakeLists.txt | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/fileitemactionplugin/CMakeLists.txt b/fileitemactionplugin/CMakeLists.txt
index a154430..60af659 100644
--- a/fileitemactionplugin/CMakeLists.txt
+++ b/fileitemactionplugin/CMakeLists.txt
@@ -38,7 +38,7 @@ set(KIO_MODULE_TARGETS "${KF_PACKAGE_PREFIX}::KIOCore" "${KF_PACKAGE_PREFIX}::KI
"${KF_PACKAGE_PREFIX}::KIOWidgets")
if (KF_MAJOR_VERSION GREATER_EQUAL 6)
list(APPEND KIO_MODULE_TARGETS)
- set(META_PLUGIN_CATEGORY kf${KF_VERSION}/kfileitemaction)
+ set(META_PLUGIN_CATEGORY kf${KF_MAJOR_VERSION}/kfileitemaction)
else ()
list(APPEND KIO_MODULE_TARGETS "${KF_PACKAGE_PREFIX}::KIONTLM")
endif ()
--
2.43.0

View File

@ -27,7 +27,7 @@ _cfg=qt6
pkgname=syncthingtray-$_cfg
_name=${pkgname%-$_cfg}
pkgver=1.4.9
pkgrel=1
pkgrel=2
arch=('i686' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
pkgdesc='Tray application for Syncthing (using Qt 6)'
license=('GPL')
@ -45,13 +45,20 @@ checkdepends=('cppunit' 'syncthing' 'iproute2' 'appstream')
[[ $_enable_kio_plugin ]] && makedepends+=('kio')
[[ $_enable_plasmoid ]] && makedepends+=('plasma-framework' 'extra-cmake-modules')
url="https://github.com/Martchus/${_reponame}"
source=("${_name}-${pkgver}.tar.gz::https://github.com/Martchus/${_reponame}/archive/v${pkgver}.tar.gz")
sha256sums=('f9003bbe185d355f9cac18862077fa2cc4e809f7f416d9b1dd5ef6474c926742')
source=("${_name}-${pkgver}.tar.gz::https://github.com/Martchus/${_reponame}/archive/v${pkgver}.tar.gz"
0001-Fix-install-path-of-KIO-plugin.patch)
sha256sums=('f9003bbe185d355f9cac18862077fa2cc4e809f7f416d9b1dd5ef6474c926742'
SKIP)
ephemeral_port() {
comm -23 <(seq 49152 65535) <(ss -tan | awk '{print $4}' | cut -d':' -f2 | grep "[0-9]\{1,5\}" | sort | uniq) | shuf | head -n 1
}
prepare() {
cd "$srcdir/${PROJECT_DIR_NAME:-$_reponame-$pkgver}"
patch -p1 -i ../0001-Fix-install-path-of-KIO-plugin.patch
}
build() {
cd "$srcdir/${PROJECT_DIR_NAME:-$_reponame-$pkgver}"