Replace plasma-sdk-debug with plasmoidviewer-debug

This commit is contained in:
Martchus 2018-07-08 20:57:12 +02:00
parent 5c923500f1
commit 9370055a3f
3 changed files with 54 additions and 52 deletions

View File

@ -1,49 +0,0 @@
# $Id$
# Maintainer of regular package: Antonio Rojas <arojas@archlinux.org>
# Version with debug build of plasmoidviewer: Martchus <martchus@gmx.net>
pkgname=plasma-sdk-debug
pkgver=5.10.5
pkgrel=1
pkgdesc="Applications useful for Plasma development (with debug build of plasmoidviewer)"
arch=(i686 x86_64)
url='https://www.kde.org/workspaces/plasmadesktop/'
license=(LGPL)
depends=(plasma-framework)
makedepends=(extra-cmake-modules kitemmodels python2 kdoctools ktexteditor)
optdepends=('kirigami2: for Look & Feel explorer')
conflicts=(${pkgname%-debug} ${pkgname%-debug}-git)
options=(!strip)
groups=(plasma)
source=("https://download.kde.org/stable/plasma/$pkgver/${pkgname%-debug}-$pkgver.tar.xz"{,.sig}
'0001-Enable-QML-debugging.patch')
sha256sums=('cb833632b3baa4c9952c0096924acf8b1a0b918d4d162eb136c46631026f5656'
'SKIP'
'asdf')
validpgpkeys=('2D1D5B0588357787DE9EE225EC94D18F7F05997E' # Jonathan Riddell
'348C8651206633FD983A8FC4DEACEA00075E1D76' # KDE Neon
'D07BD8662C56CB291B316EB2F5675605C74E02CF') # David Edmundson
prepare() {
mkdir -p build
cd ${pkgname%-debug}-$pkgver
patch -Np1 -i ../0001-Enable-QML-debugging.patch
}
build() {
cd build
cmake ../${pkgname%-debug}-$pkgver \
-DCMAKE_INSTALL_PREFIX=/usr \
-DKDE_INSTALL_LIBDIR=lib \
-DCMAKE_BUILD_TYPE=Release \
-DBUILD_TESTING=OFF \
-DPLASMOIDVIEWER_DEBUG:BOOL=ON
}
package() {
cd build
make DESTDIR="$pkgdir" install
find "$pkgdir/usr/bin" -not -iname 'plasmoidviewer' -exec strip --strip-all {} \;
find "$pkgdir/usr/lib" -iname '*.so' -exec strip --strip-unneeded {} \;
}

View File

@ -1,4 +1,4 @@
From 40747056394893a77200e463562beaed1478f58b Mon Sep 17 00:00:00 2001
From 1c54cb0164a7f59b06366d25b07597bbb6cb1b5d Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Tue, 26 Sep 2017 19:50:11 +0200
Subject: [PATCH] Enable QML debugging
@ -8,7 +8,7 @@ Subject: [PATCH] Enable QML debugging
1 file changed, 11 insertions(+)
diff --git a/plasmoidviewer/CMakeLists.txt b/plasmoidviewer/CMakeLists.txt
index 1c0ff46..ad7708d 100644
index d8f20ee..91848f0 100644
--- a/plasmoidviewer/CMakeLists.txt
+++ b/plasmoidviewer/CMakeLists.txt
@@ -1,3 +1,9 @@
@ -34,5 +34,5 @@ index 1c0ff46..ad7708d 100644
Qt5::Quick
Qt5::DBus
--
2.14.1
2.18.0

View File

@ -0,0 +1,51 @@
# $Id$
# Maintainer of regular package: Antonio Rojas <arojas@archlinux.org>
# Version with debug build of plasmoidviewer: Martchus <martchus@gmx.net>
pkgname=plasmoidviewer-debug
_pkgname=plasma-sdk
pkgver=5.13.2
pkgrel=1
pkgdesc='Debug build of plasmoidviewer allowing to debug QML code'
arch=(x86_64)
url='https://www.kde.org/workspaces/plasmadesktop/'
license=(LGPL)
depends=(plasma-framework)
makedepends=(extra-cmake-modules kitemmodels python2 kdoctools ktexteditor)
options=(!strip)
groups=(plasma)
source=("https://download.kde.org/stable/plasma/$pkgver/${_pkgname}-$pkgver.tar.xz" # {,.sig}
'0001-Enable-QML-debugging.patch')
sha256sums=('63c326ef853beec6043bd1e7e02d1588dc081bb7450489db7c37ec23864537fc'
'1c612d2cb08e9435e265120a2f94b13a62833344abea7eb2dd7c03a93ba6ed56')
validpgpkeys=('2D1D5B0588357787DE9EE225EC94D18F7F05997E' # Jonathan Riddell
'0AAC775BB6437A8D9AF7A3ACFE0784117FBCE11D' # Bhushan Shah <bshah@kde.org>
'D07BD8662C56CB291B316EB2F5675605C74E02CF' # David Edmundson
'1FA881591C26B276D7A5518EEAAF29B42A678C20') # Marco Martin <notmart@gmail.com>
prepare() {
mkdir -p build
cd ${_pkgname}-$pkgver
patch -Np1 -i ../0001-Enable-QML-debugging.patch
}
build() {
cd build
cmake ../${_pkgname}-$pkgver \
-DCMAKE_INSTALL_PREFIX=/usr \
-DKDE_INSTALL_LIBDIR=lib \
-DCMAKE_BUILD_TYPE=Release \
-DBUILD_TESTING=OFF \
-DPLASMOIDVIEWER_DEBUG:BOOL=ON
}
package() {
cd build
make DESTDIR="$pkgdir" install
mv "$pkgdir/usr/bin/plasmoidviewer" "$srcdir/$pkgname"
rm -r "$pkgdir/"*
mkdir -p "$pkgdir/usr/bin"
mv "$srcdir/$pkgname" "$pkgdir/usr/bin/$pkgname"
}