qt5-webkit-pthread.patch

This commit is contained in:
Martchus 2016-04-09 03:22:46 +02:00
parent d2933bc27f
commit b0fd5d8f50
2 changed files with 42 additions and 4 deletions

View File

@ -8,7 +8,7 @@
_qt_module=qtwebkit
pkgname=mingw-w64-qt5-webkit
pkgver=5.6.0
pkgrel=1
pkgrel=2
arch=(any)
pkgdesc="Classes for a WebKit2 based implementation and a new QML API (mingw-w64)"
depends=('mingw-w64-qt5-declarative'
@ -39,7 +39,8 @@ source=("https://download.qt.io/community_releases/${pkgver:0:3}/${pkgver}/${_pk
qtwebkit-dont-use-bundled-angle-libraries.patch
qtwebkit-opensource-src-5.0.1-debuginfo.patch
revert-qt4-unicode-removal.patch
webkit-commit-151422.patch)
webkit-commit-151422.patch
qt5-webkit-pthread.patch)
md5sums=('b68565d18db63ee4db998bb8e37608a5'
'ce7d257e2b5b94fe3affd98f52d99d09'
'ac574de962545d6a9e975b4db63c3e09'
@ -49,14 +50,19 @@ md5sums=('b68565d18db63ee4db998bb8e37608a5'
'f452210683386f9c28f04d7dea0ecfc7'
'6aba6468efafb64943887079e258b799'
'4e374836f26853b4d82be0e87aa584a5'
'c36fe581e0f3b61cef19415782b257ca')
'c36fe581e0f3b61cef19415782b257ca'
'f65286024f65ca87837171272fc8975d')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
prepare() {
cd "${srcdir}/${_pkgfqn}"
# note: all patches are from http://pkgs.fedoraproject.org/git/rpms/mingw-qt5-qtwebkit.git
# see description inside the patch file
patch -p1 -i ../qt5-webkit-pthread.patch
# note: most patches are originally from http://pkgs.fedoraproject.org/git/rpms/mingw-qt5-qtwebkit.git
# however, I needed to update most of them in order to update to 5.6.0 and to use the latest ANGLE
# The ICU libraries used for cross-compilation are named exactly the same as their native Linux counterpart
patch -p1 -b -i ../qt5-qtwebkit-use-correct-icu-libs.patch

View File

@ -0,0 +1,32 @@
From 5f359baacdf92fabcece83f0a2b30f74c7c02a3c Mon Sep 17 00:00:00 2001
From: Allan Sandfeld Jensen <allan.jensen@theqtcompany.com>
Date: Mon, 22 Feb 2016 10:57:32 +0100
Subject: [PATCH] Fix linking with libpthread
WebKit use libpthread directly but is depending on other qt modules
causing it to be linked against, which might break unless -lpthread
is last. Instead just add it explicitly after the static libraries.
Change-Id: I2b95cff2c96373f8dce6f95052c4fccbe1982b33
Reviewed-by: Simon Hausmann <simon.hausmann@theqtcompany.com>
(cherry picked from commit 5dd4bb67cfce812fd7686e43616e2069f354a7df)
Reviewed-by: Allan Sandfeld Jensen <allan.jensen@theqtcompany.com>
---
Tools/qmake/mkspecs/features/default_post.prf | 1 +
1 file changed, 1 insertion(+)
diff --git a/Tools/qmake/mkspecs/features/default_post.prf b/Tools/qmake/mkspecs/features/default_post.prf
index 67276b7..39bb3f7 100644
--- a/Tools/qmake/mkspecs/features/default_post.prf
+++ b/Tools/qmake/mkspecs/features/default_post.prf
@@ -201,6 +201,7 @@ needToLink() {
linkAgainstLibrary($$library, $$eval(WEBKIT.$${library_identifier}.root_source_dir))
LIBS += $$eval(WEBKIT.$${library_identifier}.dependent_libs)
}
+ posix:!darwin: LIBS += -lpthread
}
creating_module {
--
2.7.1