Update static-compat and mingw-w64 packages

This commit is contained in:
Martchus 2023-02-11 19:03:00 +01:00
parent 61276996b7
commit ba53dca910
28 changed files with 216 additions and 110 deletions

View File

@ -25,7 +25,7 @@ prepare() {
cd dbus
# Allow us to enable checks without them being fatal
patch -Np1 -i ../no-fatal-warnings.diff
git apply -3 ../no-fatal-warnings.diff
NOCONFIGURE=1 ./autogen.sh
}

View File

@ -13,7 +13,7 @@ echo "variant version: $variantver"
regular_file=$official_packages/$package/trunk/PKGBUILD
source "$regular_file"
regularver=$pkgver
echo "variant version: $regularver"
echo "regular version: $regularver"
if [[ $variantver == "$regularver" ]]; then
echo "nothing to do, versions are the same"
@ -41,5 +41,5 @@ if [[ ! $basecomit ]]; then
fi
cd "$package/$variant"
git -C "$official_packages" diff "$basecomit..master" -- "$package/trunk/PKGBUILD" > regular.diff
git -C "$official_packages" diff "$basecomit..origin/master" -- "$package/trunk/PKGBUILD" > regular.diff
patch -p3 -i regular.diff

View File

@ -3,7 +3,7 @@
_pkgname=fontconfig
pkgname=static-compat-$_pkgname
pkgver=2.14.1
pkgver=2.14.2
pkgrel=1
epoch=2
pkgdesc="Library for configuring and customizing font access"
@ -14,7 +14,7 @@ depends=(static-compat-expat static-compat-freetype2)
makedepends=(static-compat-meson git autoconf-archive gperf python-lxml python-six docbook-utils)
checkdepends=(unzip)
options=(!emptydirs !docs staticlibs)
_commit=c45e09df1ef235d653d56aef05012f6a3cc57979 # tags/2.14.1^0
_commit=7861a719616b4b132b9cac089c6c64f47832edb1 # tags/2.14.2^0
source=("git+https://gitlab.freedesktop.org/fontconfig/fontconfig.git#commit=$_commit")
b2sums=('SKIP')
@ -38,7 +38,10 @@ build() {
printf '#!/usr/bin/bash\nexec /usr/bin/pkg-config --static "$@"\n' > pkg-config
chmod +x pkg-config
static-compat-meson $_pkgname build -Ddoc=disabled
static-compat-meson $_pkgname build \
-D default-hinting=slight \
-D default-sub-pixel-rendering=rgb \
-D doc=disabled
meson compile -C build
}

View File

@ -0,0 +1 @@
../mingw-w64/0005-builds-meson-parse_modules_cfg.py-Handle-gxvalid-and.patch

View File

@ -4,8 +4,8 @@
# you also find the URL of a binary repository.
pkgname=mingw-w64-freetype2-bootstrap
pkgver=2.12.1
pkgrel=3
pkgver=2.13.0
pkgrel=1
pkgdesc='Font rasterization library (mingw-w64)'
arch=('any')
url='https://www.freetype.org/'
@ -17,13 +17,15 @@ source=(https://download-mirror.savannah.gnu.org/releases/freetype/freetype-$pkg
0001-Enable-table-validation-modules.patch
0002-Enable-subpixel-rendering.patch
0003-Enable-infinality-subpixel-hinting.patch
0004-Enable-long-PCF-family-names.patch)
sha256sums=('4766f20157cc4cf0cd292f80bf917f92d1c439b243ac3018debf6b9140c41a7f'
0004-Enable-long-PCF-family-names.patch
0005-builds-meson-parse_modules_cfg.py-Handle-gxvalid-and.patch)
sha256sums=('5ee23abd047636c24b2d43c6625dcafc66661d1aca64dec9e0d05df29592624c'
'SKIP'
'12c869eeba212c74d07d3d7815848b047ecb5282d5463dffb3bb6d219315d4da'
'2497dcb3650271db9bb7ad4f3379b5b3c6a19f5ca5388dd9ba7d42b5c15c8c4f'
'caa0bc7d3dfa3b4c6b9beecda6141405dafe540f99a655dc83d1704fa232ac20'
'8bf978cd1abd73f54c53f7d214c368b1fd8921cd9800d2cc84427c662ffbbdcb')
'd279a9d4b2c146722dbc03f9a33009846efe8bbbe3ada52beb4a1aa4d4dfaa38'
'f2e8a16126723458b413e58da267fb30332d0b42fef972f951e3e9fc081fa492'
'8e61d12ebdbbcb764a38d4798ee728074bac0aa20978d538b6e7045a63949ab8'
'cc364cc0ca21b8b30f29d90ab394d82f3303ca7d9813d866e6bf14f9bccd9564'
'08cf087d7d612b4228e24d74df95cf1f397f7c41054c42837c63c1f33ffaee09')
validpgpkeys=(E30674707856409FF1948010BE6C3AAC63AD8E3F) # Werner Lemberg <wl@gnu.org>
if [[ $pkgname = 'mingw-w64-freetype2-bootstrap' ]]; then
@ -46,6 +48,7 @@ prepare() {
patch -Np1 -i ../0002-Enable-subpixel-rendering.patch
patch -Np1 -i ../0003-Enable-infinality-subpixel-hinting.patch
patch -Np1 -i ../0004-Enable-long-PCF-family-names.patch
patch -Np1 -i ../0005-builds-meson-parse_modules_cfg.py-Handle-gxvalid-and.patch
}
build() {

View File

@ -8,7 +8,7 @@ Subject: [PATCH] Enable table validation modules
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/modules.cfg b/modules.cfg
index aded92e5e922..f133c65b27e2 100644
index 5b6c9b5a5c1d..b4933bea7654 100644
--- a/modules.cfg
+++ b/modules.cfg
@@ -117,26 +117,26 @@ AUX_MODULES += cache

View File

@ -8,7 +8,7 @@ Subject: [PATCH] Enable subpixel rendering
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/include/freetype/config/ftoption.h b/include/freetype/config/ftoption.h
index c5bde243b127..77d6efb2e5f2 100644
index 9e03e1783be9..6f853d403862 100644
--- a/include/freetype/config/ftoption.h
+++ b/include/freetype/config/ftoption.h
@@ -123,7 +123,7 @@ FT_BEGIN_HEADER

View File

@ -8,7 +8,7 @@ Subject: [PATCH] Enable infinality subpixel hinting
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/include/freetype/config/ftoption.h b/include/freetype/config/ftoption.h
index 77d6efb2e5f2..c33c51eeb2e7 100644
index 6f853d403862..fc36a6db1e63 100644
--- a/include/freetype/config/ftoption.h
+++ b/include/freetype/config/ftoption.h
@@ -706,8 +706,8 @@ FT_BEGIN_HEADER

View File

@ -8,10 +8,10 @@ Subject: [PATCH] Enable long PCF family names
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/include/freetype/config/ftoption.h b/include/freetype/config/ftoption.h
index c33c51eeb2e7..c33ddb4bf60c 100644
index fc36a6db1e63..04e8ed0a85ac 100644
--- a/include/freetype/config/ftoption.h
+++ b/include/freetype/config/ftoption.h
@@ -895,7 +895,7 @@ FT_BEGIN_HEADER
@@ -913,7 +913,7 @@ FT_BEGIN_HEADER
* If this option is activated, it can be controlled with the
* `no-long-family-names` property of the 'pcf' driver module.
*/

View File

@ -0,0 +1,30 @@
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
From: "Jan Alexander Steffens (heftig)" <heftig@archlinux.org>
Date: Thu, 9 Feb 2023 19:22:47 +0000
Subject: [PATCH] * builds/meson/parse_modules_cfg.py: Handle gxvalid and
otvalid
These need a name mapping similar to what was done for other modules,
or linking will fail.
---
builds/meson/parse_modules_cfg.py | 6 +++++-
1 file changed, 5 insertions(+), 1 deletion(-)
diff --git a/builds/meson/parse_modules_cfg.py b/builds/meson/parse_modules_cfg.py
index 6030bb2098df..d48129fe72e1 100644
--- a/builds/meson/parse_modules_cfg.py
+++ b/builds/meson/parse_modules_cfg.py
@@ -97,8 +97,12 @@ def generate_ftmodule(lists):
for module in lists["AUX_MODULES"]:
if module in ("psaux", "psnames", "otvalid", "gxvalid"):
+ name = {
+ "gxvalid": "gxv",
+ "otvalid": "otv",
+ }.get(module, module)
result += (
- "FT_USE_MODULE( FT_Module_Class, %s_module_class )\n" % module
+ "FT_USE_MODULE( FT_Module_Class, %s_module_class )\n" % name
)
result += "/* EOF */\n"

View File

@ -4,8 +4,8 @@
# you also find the URL of a binary repository.
pkgname=mingw-w64-freetype2
pkgver=2.12.1
pkgrel=3
pkgver=2.13.0
pkgrel=1
pkgdesc='Font rasterization library (mingw-w64)'
arch=('any')
url='https://www.freetype.org/'
@ -17,13 +17,15 @@ source=(https://download-mirror.savannah.gnu.org/releases/freetype/freetype-$pkg
0001-Enable-table-validation-modules.patch
0002-Enable-subpixel-rendering.patch
0003-Enable-infinality-subpixel-hinting.patch
0004-Enable-long-PCF-family-names.patch)
sha256sums=('4766f20157cc4cf0cd292f80bf917f92d1c439b243ac3018debf6b9140c41a7f'
0004-Enable-long-PCF-family-names.patch
0005-builds-meson-parse_modules_cfg.py-Handle-gxvalid-and.patch)
sha256sums=('5ee23abd047636c24b2d43c6625dcafc66661d1aca64dec9e0d05df29592624c'
'SKIP'
'12c869eeba212c74d07d3d7815848b047ecb5282d5463dffb3bb6d219315d4da'
'2497dcb3650271db9bb7ad4f3379b5b3c6a19f5ca5388dd9ba7d42b5c15c8c4f'
'caa0bc7d3dfa3b4c6b9beecda6141405dafe540f99a655dc83d1704fa232ac20'
'8bf978cd1abd73f54c53f7d214c368b1fd8921cd9800d2cc84427c662ffbbdcb')
'd279a9d4b2c146722dbc03f9a33009846efe8bbbe3ada52beb4a1aa4d4dfaa38'
'f2e8a16126723458b413e58da267fb30332d0b42fef972f951e3e9fc081fa492'
'8e61d12ebdbbcb764a38d4798ee728074bac0aa20978d538b6e7045a63949ab8'
'cc364cc0ca21b8b30f29d90ab394d82f3303ca7d9813d866e6bf14f9bccd9564'
'08cf087d7d612b4228e24d74df95cf1f397f7c41054c42837c63c1f33ffaee09')
validpgpkeys=(E30674707856409FF1948010BE6C3AAC63AD8E3F) # Werner Lemberg <wl@gnu.org>
if [[ $pkgname = 'mingw-w64-freetype2-bootstrap' ]]; then
@ -46,6 +48,7 @@ prepare() {
patch -Np1 -i ../0002-Enable-subpixel-rendering.patch
patch -Np1 -i ../0003-Enable-infinality-subpixel-hinting.patch
patch -Np1 -i ../0004-Enable-long-PCF-family-names.patch
patch -Np1 -i ../0005-builds-meson-parse_modules_cfg.py-Handle-gxvalid-and.patch
}
build() {

View File

@ -0,0 +1,30 @@
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
From: "Jan Alexander Steffens (heftig)" <heftig@archlinux.org>
Date: Thu, 9 Feb 2023 19:22:47 +0000
Subject: [PATCH] * builds/meson/parse_modules_cfg.py: Handle gxvalid and
otvalid
These need a name mapping similar to what was done for other modules,
or linking will fail.
---
builds/meson/parse_modules_cfg.py | 6 +++++-
1 file changed, 5 insertions(+), 1 deletion(-)
diff --git a/builds/meson/parse_modules_cfg.py b/builds/meson/parse_modules_cfg.py
index 6030bb2098df..d48129fe72e1 100644
--- a/builds/meson/parse_modules_cfg.py
+++ b/builds/meson/parse_modules_cfg.py
@@ -97,8 +97,12 @@ def generate_ftmodule(lists):
for module in lists["AUX_MODULES"]:
if module in ("psaux", "psnames", "otvalid", "gxvalid"):
+ name = {
+ "gxvalid": "gxv",
+ "otvalid": "otv",
+ }.get(module, module)
result += (
- "FT_USE_MODULE( FT_Module_Class, %s_module_class )\n" % module
+ "FT_USE_MODULE( FT_Module_Class, %s_module_class )\n" % name
)
result += "/* EOF */\n"

View File

@ -3,7 +3,7 @@
_pkgname=freetype2
pkgname=static-compat-$_pkgname
pkgver=2.12.1
pkgver=2.13.0
pkgrel=1
pkgdesc="Font rasterization library"
url="https://www.freetype.org/"
@ -11,19 +11,32 @@ arch=(x86_64)
license=(GPL)
# adding harfbuzz for improved OpenType features auto-hinting
# introduces a cycle dep to harfbuzz depending on freetype wanted by upstream
depends=(static-compat-zlib static-compat-bzip2 static-compat-libpng static-compat-brotli static-compat-harfbuzz)
makedepends=(static-compat-libx11 static-compat-meson)
depends=(
static-compat-brotli
static-compat-bzip2
static-compat-harfbuzz
static-compat-libpng
static-compat-zlib
)
makedepends=(
static-compat-libx11
static-compat-meson
)
options=(staticlibs)
source=(https://download-mirror.savannah.gnu.org/releases/freetype/freetype-$pkgver.tar.xz
0001-Enable-table-validation-modules.patch
0002-Enable-subpixel-rendering.patch
0003-Enable-infinality-subpixel-hinting.patch
0004-Enable-long-PCF-family-names.patch)
sha256sums=('4766f20157cc4cf0cd292f80bf917f92d1c439b243ac3018debf6b9140c41a7f'
'12c869eeba212c74d07d3d7815848b047ecb5282d5463dffb3bb6d219315d4da'
'2497dcb3650271db9bb7ad4f3379b5b3c6a19f5ca5388dd9ba7d42b5c15c8c4f'
'caa0bc7d3dfa3b4c6b9beecda6141405dafe540f99a655dc83d1704fa232ac20'
'8bf978cd1abd73f54c53f7d214c368b1fd8921cd9800d2cc84427c662ffbbdcb')
source=(
https://download-mirror.savannah.gnu.org/releases/freetype/freetype-$pkgver.tar.xz
0001-Enable-table-validation-modules.patch
0002-Enable-subpixel-rendering.patch
0003-Enable-infinality-subpixel-hinting.patch
0004-Enable-long-PCF-family-names.patch
0005-builds-meson-parse_modules_cfg.py-Handle-gxvalid-and.patch
)
sha256sums=('5ee23abd047636c24b2d43c6625dcafc66661d1aca64dec9e0d05df29592624c'
'd279a9d4b2c146722dbc03f9a33009846efe8bbbe3ada52beb4a1aa4d4dfaa38'
'f2e8a16126723458b413e58da267fb30332d0b42fef972f951e3e9fc081fa492'
'8e61d12ebdbbcb764a38d4798ee728074bac0aa20978d538b6e7045a63949ab8'
'cc364cc0ca21b8b30f29d90ab394d82f3303ca7d9813d866e6bf14f9bccd9564'
'08cf087d7d612b4228e24d74df95cf1f397f7c41054c42837c63c1f33ffaee09')
validpgpkeys=(E30674707856409FF1948010BE6C3AAC63AD8E3F) # Werner Lemberg <wl@gnu.org>
prepare() {
@ -32,6 +45,7 @@ prepare() {
patch -Np1 -i ../0002-Enable-subpixel-rendering.patch
patch -Np1 -i ../0003-Enable-infinality-subpixel-hinting.patch
patch -Np1 -i ../0004-Enable-long-PCF-family-names.patch
patch -Np1 -i ../0005-builds-meson-parse_modules_cfg.py-Handle-gxvalid-and.patch
# meson sucks
sed -i 's|static: false|static: true|g' meson.build
@ -57,4 +71,4 @@ package() {
rm -rf "${pkgdir}"/usr/static/share/
}
# vim:set ts=2 sw=2 et:
# vim:set sw=2 sts=-1 et:

View File

@ -3,7 +3,7 @@
_pkgname=glib2
pkgname=static-compat-$_pkgname
pkgver=2.74.3
pkgver=2.74.5
pkgrel=1
pkgdesc="Low level core library"
url="https://wiki.gnome.org/Projects/GLib"
@ -13,10 +13,12 @@ depends=(static-compat-pcre2 static-compat-libffi static-compat-util-linux stati
makedepends=(gettext shared-mime-info python libelf git static-compat-meson)
checkdepends=(desktop-file-utils)
options=(!strip !emptydirs staticlibs)
_commit=a8ad6347a404962c3b83aca1bf50610a76618c0f # tags/2.74.3^0
_commit=39a71aff372ed491a24ca84409d9f93bc7c5d6d4 # tags/2.74.5^0
source=("git+https://gitlab.gnome.org/GNOME/glib.git#commit=$_commit"
"git+https://gitlab.gnome.org/GNOME/gvdb.git"
0001-glib-compile-schemas-Remove-noisy-deprecation-warnin.patch)
b2sums=('SKIP'
'SKIP'
'4d5cb5ad1222a5e8d06e79736170cd694a6277e0da71ffd55560d74cf5c3273551d302a35bd2ff43f09070d61c1de147bb312428fce98347d232ac3d44406511')
pkgver() {
@ -27,8 +29,15 @@ pkgver() {
prepare() {
cd glib
# Fix build (missing include)
git cherry-pick -n 03cb4261e00cf505790f4fd4e69f97b2ef4fcccd
# Suppress noise from glib-compile-schemas.hook
git apply -3 ../0001-glib-compile-schemas-Remove-noisy-deprecation-warnin.patch
git submodule init
git submodule set-url subprojects/gvdb "$srcdir/gvdb"
git -c protocol.file.allow=always submodule update
}
build() {

View File

@ -5,7 +5,7 @@
_pkgname=libcap
pkgname=static-compat-$_pkgname
pkgver=2.66
pkgver=2.67
pkgrel=1
pkgdesc="POSIX 1003.1e capabilities"
arch=(x86_64)
@ -15,9 +15,9 @@ depends=(glibc-static-compat)
makedepends=(static-compat-environment)
options=(staticlibs)
source=("https://kernel.org/pub/linux/libs/security/linux-privs/${_pkgname}2/${_pkgname}-$pkgver.tar."{xz,sign})
sha512sums=('ac005b622f6e065f30ce282a5c87240e7b9da75366ee537aa4835bc501b44bc242c10a4ba4dc070e2415fc7f635d1c3c4e45fbeeaf962cf7973dda82bf6377f0'
sha512sums=('2e52c5a571cc1565e6829b0889f63216af10dfd9a86485f8ae7d0fcf4cc0db96aa21eb2ddea29e8dadf41a1194e91fb5961fe84ba07beb2ce950b6131be099d4'
'SKIP')
b2sums=('e79bf10c6a3dbffe96dc97aad0bed67caa0b3805d9dcaff1e4a8a833396ee5c6da4f7f0d321b254e99a00073bc39021b9f3a4b350d93094d0df4d74889b3ca56'
b2sums=('bd9be22e439397a3c1726093cfee2410df93773b3139d50a1cdc10daecb666ddb9b64daded6e0ec9f2fd6defd16ea156dbd66bd55360ea266131f31ea0f0e989'
'SKIP')
validpgpkeys=(38A644698C69787344E954CE29EE848AE2CCF3F4) # Andrew G. Morgan <morgan@kernel.org>

View File

@ -2,7 +2,7 @@
_pkgname=libinput
pkgname=static-compat-$_pkgname
pkgver=1.22.0
pkgver=1.22.1
pkgrel=1
pkgdesc="Input device management and event handling library"
url="https://gitlab.freedesktop.org/libinput"
@ -13,7 +13,7 @@ depends=('static-compat-mtdev' 'static-compat-systemd-libs' 'static-compat-libev
makedepends=('static-compat-meson' 'static-compat-wayland') # 'check' 'doxygen' 'graphviz' 'python-sphinx' 'python-recommonmark'
options=(staticlibs !emptydirs)
source=(https://gitlab.freedesktop.org/libinput/libinput/-/archive/$pkgver/$_pkgname-$pkgver.tar.bz2)
sha256sums=('b9204a860b4f6f9b2587c484f67a21fbdedd01a97db1f983b0b51cb7bdd428aa')
sha256sums=('e13f6f118cfbbdc0b6e0edd5e3504abd96a8d0e33dc67cba31c6942c449f77af')
#validpgpkeys=('3C2C43D9447D5938EF4551EBE23B7E70B467F0BF') # Peter Hutterer (Who-T) <office@who-t.net>
prepare() {

View File

@ -5,41 +5,49 @@
_pkgname=libjpeg-turbo
pkgname=static-compat-$_pkgname
pkgver=2.1.4
pkgver=2.1.5
pkgrel=1
pkgdesc="JPEG image codec with accelerated baseline compression and decompression"
arch=(x86_64)
url="https://libjpeg-turbo.org/"
license=(BSD)
depends=(glibc-static-compat)
makedepends=(static-compat-cmake nasm)
makedepends=(static-compat-cmake nasm ninja)
options=(staticlibs)
source=(https://sourceforge.net/projects/$_pkgname/files/$pkgver/$_pkgname-$pkgver.tar.gz{,.sig})
sha512sums=('511f065767c022da06b6c36299686fa44f83441646f7e33b766c6cfab03f91b0e6bfa456962184071dadaed4057ba9a29cba685383f3eb86a4370a1a53731a70'
'SKIP')
b2sums=('80ffd77d58a37eae0bdc1868d994f34ea52c13e2624c720b1d0b6ec4d6d14b16911163ccd4009c8d6eda214f31e1fff78bb7eb4739ae6589d0fd8c7008c0e972'
'SKIP')
source=(https://sourceforge.net/projects/$_pkgname/files/$pkgver/$_pkgname-$pkgver.tar.gz{,.sig}
$_name-initialize-simd_support.patch::https://github.com/libjpeg-turbo/libjpeg-turbo/commit/4e028ecd63aa.patch)
sha512sums=('ceab6d1c3c46d2816b06402e3b912e950d887fc8a6fb32fa6876f4aaa663b4769d8f4c50e1b967addf6704d0760ca14ed723d55e0312d7ca69e7f2a91484c0dc'
'SKIP'
'9275268b5e138ee76a7245aded05917a16c05951441d53bd1b6e65a306a75dc0d0c672c7aa5d52edce7ec197a7fba5658ffe7db0a406d83a88d55819338a5023')
b2sums=('c65de2717ddc33447064412738b2db94a92693faad18f29f14c5c368d9eb4c617fe447a6f9428d9a101458dec0c65abc527e20632571eaa727d98cd5435241d4'
'SKIP'
'9bbad32e30289951a95ebef4ce36a0045d69f50a73a72a4f4820257acabfb6e6a9234538bfcc76441885c2fccf01d44008f7795c3b85921b23cbb1e4a0c05228')
validpgpkeys=('0338C8D8D9FDA62CF9C421BD7EC2DBB6F4DBF434') # The libjpeg-turbo Project (Signing key for official binaries) <information@libjpeg-turbo.org>
build() {
source static-compat-environment
static-compat-cmake -DCMAKE_INSTALL_LIBDIR="$static_compat_prefix"/lib \
-DWITH_JAVA=OFF\
-DWITH_JPEG8=ON \
-W no-dev \
-B build \
-S $_pkgname-$pkgver
make VERBOSE=1 -C build
local cmake_options=(
-B build
-DCMAKE_INSTALL_LIBDIR="$static_compat_prefix"/lib
-DWITH_JAVA=OFF
-DWITH_JPEG8=ON
-G Ninja
-S $_pkgname-$pkgver
-W no-dev
)
static-compat-cmake "${cmake_options[@]}"
cmake --build build -v
}
check() {
source static-compat-environment
make test -C build
ctest --test-dir build --output-on-failure --stop-on-failure -j$(nproc)
}
package() {
source static-compat-environment
make VERBOSE=1 DESTDIR="$pkgdir" docdir="$static_compat_prefix"/share/doc/$_pkgname exampledir="$static_compat_prefix"/share/doc/$_pkgname install -C build
export docdir="$static_compat_prefix"/share/doc/$_pkgname exampledir="$static_compat_prefix"/share/doc/$_pkgname
DESTDIR="$pkgdir" cmake --install build -v
install -d "$pkgdir/usr/share/licenses/$pkgname"
ln -s ../../doc/$_pkgname/LICENSE.md "$pkgdir/usr/share/licenses/$pkgname"

View File

@ -1,9 +1,10 @@
# Contributor: Andreas Radke <andyrtr@archlinux.org>
# Contributor: Jan de Groot <jgc@archlinux.org>
_pkgname=libsm
pkgname=static-compat-$_pkgname
pkgver=1.2.3
pkgrel=2
pkgver=1.2.4
pkgrel=1
pkgdesc="X11 Session Management library"
arch=('x86_64')
license=('custom')
@ -11,8 +12,10 @@ url="https://xorg.freedesktop.org/"
depends=('static-compat-libice' 'static-compat-util-linux')
makedepends=('xorg-util-macros' 'static-compat-xtrans' 'static-compat-xorgproto' 'static-compat-configure')
options=(!emptydirs staticlibs)
source=(${url}/releases/individual/lib/libSM-${pkgver}.tar.bz2)
sha512sums=('74c42e27029db78475e62025b4711dbac5e22d2f8e8a24be98a1c31b03c0fc4afe859928f851800ea0b76854f12147900dc4f27bbfd3d8ea45daaaf24b70a903')
source=(${url}/releases/individual/lib/libSM-${pkgver}.tar.xz{,.sig})
sha512sums=('7f1d41b7b6c5dd456c49ccad7740c3ba9791a2793fa50fd94814a4164ce2e20c4a0a0ad42a87708e494ed5c23f611be6d3ccd9ef1e9add6d46ac545e2b0f6f86'
'SKIP')
validpgpkeys=('4A193C06D35E7C670FA4EF0BA2FB9E081F2D130E') # Alan Coopersmith <alanc@freedesktop.org>
build() {
source static-compat-environment

View File

@ -3,7 +3,7 @@
_pkgname=libwacom
pkgname=static-compat-$_pkgname
pkgver=2.5.0
pkgver=2.6.0
pkgrel=1
pkgdesc="Library to identify Wacom tablets and their features"
arch=('x86_64')
@ -13,12 +13,12 @@ depends=('static-compat-glib2' 'static-compat-systemd-libs' 'static-compat-libgu
makedepends=('static-compat-libxml2' 'static-compat-meson')
checkdepends=('python-pytest' 'python-libevdev' 'python-pyudev')
options=('staticlibs')
#validpgpkeys=('3C2C43D9447D5938EF4551EBE23B7E70B467F0BF')
validpgpkeys=('594ABBA066118C7A02D10A80A8AF906D9307FBAD') # "Joshua Dickens <Joshua@Joshua-Dickens.com>"
source=(https://github.com/linuxwacom/libwacom/releases/download/${_pkgname}-${pkgver}/${_pkgname}-${pkgver}.tar.xz{,.sig})
# https://github.com/linuxwacom/libwacom/releases
sha256sums=('40b69a4c38bbcbc80b1231bc115551107ebbc0ba14d2ad1c3e54355dcd876816'
'SKIP')
sha256sums=('2376cca99475235b75053a2cfbc7ed40fd8763d5a516941a664870ff1f3aa98f'
'SKIP')
validpgpkeys=('3C2C43D9447D5938EF4551EBE23B7E70B467F0BF') # "Peter Hutterer (Who-T) <office@who-t.net>"
#validpgpkeys=('594ABBA066118C7A02D10A80A8AF906D9307FBAD') # "Joshua Dickens <Joshua@Joshua-Dickens.com>"
prepare() {
sed -i 's|shared_library|library|g' $_pkgname-$pkgver/meson.build

View File

@ -4,7 +4,7 @@
_pkgname=libxkbcommon
pkgname=static-compat-$_pkgname
pkgver=1.4.1
pkgver=1.5.0
pkgrel=1
pkgdesc="Keymap handling library for toolkits and window systems"
url="https://xkbcommon.org/"
@ -14,7 +14,7 @@ depends=(static-compat-libxcb xkeyboard-config static-compat-libxml2 static-comp
makedepends=(xkeyboard-config wayland-protocols doxygen git static-compat-meson)
checkdepends=(xorg-server-xvfb libgl)
options=(!emptydirs !docs staticlibs)
_commit=57af9cb71f19f37394399b549f7cb7b0d9fe3988 # tags/xkbcommon-1.4.1^0
_commit=cecaa01df18925eb66c6a81f6e4b7167421d45f2 # tags/xkbcommon-1.5.0^0
source=("git+https://github.com/xkbcommon/libxkbcommon#commit=$_commit")
sha256sums=('SKIP')

View File

@ -5,8 +5,8 @@
_pkgname=ncurses
pkgname=static-compat-$_pkgname
pkgver=6.3
pkgrel=2
pkgver=6.4
pkgrel=1
pkgdesc='System V Release 4.0 curses emulation library'
arch=(x86_64)
url='https://invisible-island.net/ncurses/ncurses.html'
@ -19,11 +19,11 @@ source=(
"${_pkgname}-6.3-libs.patch"
"${_pkgname}-6.3-pkgconfig.patch"
)
sha512sums=('5373f228cba6b7869210384a607a2d7faecfcbfef6dbfcd7c513f4e84fbd8bcad53ac7db2e7e84b95582248c1039dcfc7c4db205a618f7da22a166db482f0105'
sha512sums=('1c2efff87a82a57e57b0c60023c87bae93f6718114c8f9dc010d4c21119a2f7576d0225dab5f0a227c2cfc6fb6bdbd62728e407f35fce5bf351bb50cf9e0fd34'
'SKIP'
'adb02b838c40f1e58a1b31c26d5cd0f2a1c43f3b6d68e839981764c0f6c905a9eb51dd36ff018628fdeb20747cc7467727d57135408ab4848259384077a52b28'
'2d2c0ec3c880e638ab4aa3dbff5e28e4cd233153e24816bd87e077f848aa3edd5114cd0f2a7f6e8869dd1861a2746e512886c18264ff1676927dcc320c5ef958')
b2sums=('b2c174ac48d587b4d3aa054f04e4ec8bffd8a657a4aff5f090104965c741901e600712c8f8e5e98f3b8a26bc558996a1e14a746f113854832853b855e9d406c3'
b2sums=('47fd9c2d27f44fa9942552881a471e5067465dbace40bf68b28998dded0556127a1d8662b96de4de4fd76c1c8b98bdae796036553ab4b05ca9f160839d841ba3'
'SKIP'
'31bb10e82dd018a75e57252052650d9f0f5eb5e7e887118c2ea40032b11f59ec6aa4d9bae804c615cbecdf3382f3434e0c9e9e8440fdefe66a507be020b8965c'
'fb6cf606cf3db7f6b306272696a63bce83d52cfa91e850f9a7bdb9d3d8455a26943529a9cf79731dddc7f763c27211a9afab9c4c31dbb6d12fd720eb390eb0a3')
@ -40,23 +40,24 @@ prepare() {
}
build() {
source static-compat-environment
cd $_pkgname-$pkgver
static-compat-configure \
--enable-widec \
--enable-pc-files \
--with-cxx-binding \
--with-versioned-syms \
local configure_options=(
--enable-widec
--enable-pc-files
--with-cxx-binding
--with-versioned-syms
--with-xterm-kbs=del
--without-ada
)
cd $_pkgname-$pkgver
source static-compat-environment
static-compat-configure "${configure_options[@]}"
make
}
package() {
source static-compat-environment
make DESTDIR="$pkgdir" install -C $_pkgname-$pkgver
mv "$pkgdir/$static_compat_prefix/lib/pkgconfig:$static_compat_prefix/share/pkgconfig" "$pkgdir/$static_compat_prefix/lib/pkgconfig"
rm -r "$pkgdir/$static_compat_prefix/lib/pkgconfig:"
rm -r "$pkgdir/$static_compat_prefix/share/man"
install -vDm 644 $_pkgname-$pkgver/COPYING -t "$pkgdir/usr/share/licenses/$pkgname/"
}

View File

@ -4,7 +4,7 @@
# Contributor: Filip Brcic < brcha at gna dot org >
# Contributor: Martchus < martchus at gmx dot net >
_pkgver=3.0.7
_pkgver=3.0.8
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
pkgname=mingw-w64-openssl
@ -20,7 +20,7 @@ makedepends=('mingw-w64-gcc'
'perl')
options=('!strip' 'staticlibs' '!buildflags' '!lto')
source=("https://www.openssl.org/source/openssl-${_pkgver}.tar.gz"{,.asc})
sha256sums=('83049d042a260e696f62406ac5c08bf706fd84383f945cf21bd61e9ed95c396e'
sha256sums=('6c13d2bf38fdf31eac3ce2a347073673f5d63263398f1f69d0df4a41253e4b3e'
'SKIP')
validpgpkeys=('8657ABB260F056B1E5190839D9C4D26D0E604491'
'7953AC1FBC3DC8B3B292393ED5E9E43F7DF9EE8C'

View File

@ -2,7 +2,7 @@
_pkgname=openssl
pkgname=static-compat-$_pkgname
_ver=3.0.7
_ver=3.0.8
# use a pacman compatible version scheme
pkgver=${_ver/[a-z]/.${_ver//[0-9.]/}}
pkgrel=1
@ -16,7 +16,7 @@ optdepends=('ca-certificates')
options=(!emptydirs staticlibs)
source=("https://www.openssl.org/source/${_pkgname}-${_ver}.tar.gz"{,.asc}
'ca-dir.patch')
sha256sums=('83049d042a260e696f62406ac5c08bf706fd84383f945cf21bd61e9ed95c396e'
sha256sums=('6c13d2bf38fdf31eac3ce2a347073673f5d63263398f1f69d0df4a41253e4b3e'
'SKIP'
'0a32d9ca68e8d985ce0bfef6a4c20b46675e06178cc2d0bf6d91bd6865d648b7')
validpgpkeys=('8657ABB260F056B1E5190839D9C4D26D0E604491'

View File

@ -7,8 +7,8 @@
_pkgname=pcre2
pkgname=static-compat-$_pkgname
pkgver=10.40
pkgrel=1
pkgver=10.42
pkgrel=2
pkgdesc='A library that implements Perl 5-style regular expressions. 2nd version'
arch=('x86_64')
url='https://www.pcre.org/'
@ -17,7 +17,7 @@ depends=('gcc-libs-static-compat')
makedepends=('static-compat-configure')
options=(!emptydirs staticlibs)
source=("https://github.com/PhilipHazel/${_pkgname}/releases/download/${_pkgname}-$pkgver/${_pkgname}-$pkgver.tar.bz2"{,.sig})
sha512sums=('00e7b48a6554b9127cb6fe24c5cacf72783416a9754ec88f62f73c52f46ed72c86c1869e62c91a31b2ff2cbafbbedabca44b3f1eb7670bc92f49d8401c7374e8'
sha512sums=('72fbde87fecec3aa4b47225dd919ea1d55e97f2cbcf02aba26e5a0d3b1ffb58c25a80a9ef069eb99f9cf4e41ba9604ad06a7ec159870e1e875d86820e12256d3'
'SKIP')
validpgpkeys=('45F68D54BBE23FB3039B46E59766E084FB0F43D8') # Philip Hazel

View File

@ -3,10 +3,10 @@
_pkgname=sqlite
pkgname=static-compat-$_pkgname
_srcver=3400000
_srcver=3400100
_docver=${_srcver}
#_docver=3330000
pkgver=3.40.0
pkgver=3.40.1
pkgrel=1
pkgdesc="A C library that implements an SQL database engine"
arch=('x86_64')
@ -19,10 +19,9 @@ source=(https://www.sqlite.org/2022/sqlite-src-${_srcver}.zip
license.txt)
options=('!emptydirs' 'staticlibs')
# upstream now switched to sha3sums - currently not suppoerted by makepkg
sha256sums=('48550828142051293e179ffc6a8520f6fbfd82e1cdca78b93792f766cc89b8e2'
sha256sums=('5064126aa50db20c35578b612b56c3129425c0506ed4d1610efa4a0f01bdf8d0'
'55746d93b0df4b349c4aa4f09535746dac3530f9fd6de241c9f38e2c92e8ee97'
'4e57d9ac979f1c9872e69799c2597eeef4c6ce7224f3ede0bf9dc8d217b1e65d'
)
'4e57d9ac979f1c9872e69799c2597eeef4c6ce7224f3ede0bf9dc8d217b1e65d')
prepare() {
cd sqlite-src-$_srcver

View File

@ -2,7 +2,7 @@
pkgname=static-compat-vulkan-headers
_pkgname=Vulkan-Headers
pkgver=1.3.235
pkgver=1.3.206
pkgrel=1
epoch=1
pkgdesc="Vulkan header files"
@ -12,7 +12,7 @@ license=('APACHE')
makedepends=(static-compat-cmake git)
provides=("static-compat-vulkan-hpp=${pkgver}")
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/KhronosGroup/Vulkan-Headers/archive/v${pkgver}.tar.gz")
sha256sums=('fca90d27e60816b5d72a700c241206c57e7d909e8ab4adfc340f5a5e9a019448')
sha256sums=('0cd46249eabb7cd8eab6ffc1b16d30a3a14e6e1e01d3d735b22dad33ee3efcf7')
build() {
source static-compat-environment

View File

@ -4,8 +4,8 @@
_pkgname=xcb-util
pkgname=static-compat-$_pkgname
pkgver=0.4.0
pkgrel=3
pkgver=0.4.1
pkgrel=1
pkgdesc="Utility libraries for XC Binding"
arch=('x86_64')
url="https://xcb.freedesktop.org"
@ -13,8 +13,10 @@ license=('custom')
depends=('static-compat-libxcb>=1.7')
makedepends=('gperf' 'xorg-util-macros' 'static-compat-xorgproto' 'static-compat-configure')
options=(staticlibs)
source=("https://xcb.freedesktop.org/dist/${_pkgname}-${pkgver}.tar.bz2")
sha512sums=('e60aaa6f582eacd05896c5fd7c8417938318a1288146f3a5b339f77eed24e211c6099963f8813daa621c94173d2934228936b491c0ed79b09a8a67d835867d0e')
source=(https://xcb.freedesktop.org/dist/${_pkgname}-${pkgver}.tar.xz{,.sig})
sha512sums=('da67f2f017d2a1788dcf35f28d6956e171303a622a1dd085cd3d69fdb2ed77965d83c557cc926ebf9b32e905eb2cbb5921987250192d78a2f5edc4d437ed7d2b'
'SKIP')
validpgpkeys=('4A193C06D35E7C670FA4EF0BA2FB9E081F2D130E') # Alan Coopersmith <alanc@freedesktop.org>
build() {
source static-compat-environment

View File

@ -3,7 +3,7 @@
_pkgname=xz
pkgname=static-compat-$_pkgname
pkgver=5.4.0
pkgver=5.4.1
pkgrel=1
pkgdesc='Library and command line tools for XZ and LZMA compressed files'
arch=('x86_64')
@ -14,9 +14,9 @@ makedepends=('static-compat-configure')
options=(!emptydirs staticlibs)
validpgpkeys=('3690C240CE51B4670D30AD1C38EE757D69184620') # Lasse Collin <lasse.collin@tukaani.org>
source=("https://tukaani.org/${_pkgname}/${_pkgname}-${pkgver}.tar.gz"{,.sig})
sha256sums=('7471ef5991f690268a8f2be019acec2e0564b7b233ca40035f339fe9a07f830b'
sha256sums=('e4b0f81582efa155ccf27bb88275254a429d44968e488fc94b806f2a61cd3e22'
'SKIP')
sha512sums=('29b2cd25bb5b234b329ffe9547692d2c29be393db9d8d4ce70a66dfdaebd54433e79a89d80c57e58cd4559c3c68b9845507d5fedf3eec1c528a81e3d9ddbd811'
sha512sums=('5cff8383a68fb88ecbb3770ec48af0ad5582e08de9dccd339e0b685aaa53447e59d6425caa3f63b54a674e5d78c20520876db547d156e6658ad4841660cba85b'
'SKIP')
build() {