Update mingw-w64-jsasper to 4.1.1

This commit is contained in:
Martchus 2023-12-28 19:15:28 +01:00
parent 65959d6eda
commit cb48d7af1f
4 changed files with 17 additions and 67 deletions

View File

@ -1,7 +1,7 @@
From 4f15088f82a2a001f064cee1ef9cfe23d281e957 Mon Sep 17 00:00:00 2001
From e5ddfa21a008708e12eedadbb1d7b0b377fd2680 Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Tue, 14 Jun 2022 23:12:32 +0200
Subject: [PATCH 1/3] Fix exports
Subject: [PATCH 1/2] Fix exports
---
src/libjasper/jp2/jp2_cod.h | 10 +++++-----
@ -35,5 +35,5 @@ index 81d3b7e..4f22fa3 100644
#endif
--
2.36.1
2.43.0

View File

@ -1,7 +1,7 @@
From f783c72a35b0cbf8d04b9d9472e267c72c52e1ff Mon Sep 17 00:00:00 2001
From ea00c0d8c5a78a86724c2da2c86cc204f745009c Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Tue, 14 Jun 2022 23:13:06 +0200
Subject: [PATCH 2/3] Fix building for mingw-w64 target
Subject: [PATCH 2/2] Fix building for mingw-w64 target
---
CMakeLists.txt | 2 ++
@ -9,10 +9,10 @@ Subject: [PATCH 2/3] Fix building for mingw-w64 target
2 files changed, 10 insertions(+)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 52ad5a8..72257ec 100644
index eaaef9a..1ed6723 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -723,10 +723,12 @@ message("JAS_INCLUDE_HEIC_CODEC: ${JAS_INCLUDE_HEIC_CODEC}")
@@ -789,10 +789,12 @@ message("JAS_INCLUDE_HEIC_CODEC: ${JAS_INCLUDE_HEIC_CODEC}")
# Check for the Math library.
################################################################################
@ -45,5 +45,5 @@ index c0b19b3..9fab05f 100644
target_compile_definitions(libjasper PRIVATE _CRT_SECURE_NO_WARNINGS)
target_compile_definitions(libjasper PRIVATE _CRT_SECURE_NO_DEPRECATE)
--
2.36.1
2.43.0

View File

@ -1,46 +0,0 @@
From 5e697686ff137496f5ede4b1ee21d67ea682186a Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Tue, 14 Jun 2022 23:14:10 +0200
Subject: [PATCH 3/3] Fix filename buffer overflow
---
src/libjasper/include/jasper/jas_stream.h | 9 ++++++++-
1 file changed, 8 insertions(+), 1 deletion(-)
diff --git a/src/libjasper/include/jasper/jas_stream.h b/src/libjasper/include/jasper/jas_stream.h
index d8938d1..61a6e66 100644
--- a/src/libjasper/include/jasper/jas_stream.h
+++ b/src/libjasper/include/jasper/jas_stream.h
@@ -77,6 +77,7 @@
#include <jasper/jas_config.h> /* IWYU pragma: export */
#include <stdio.h>
+#include <limits.h>
#if defined(JAS_HAVE_FCNTL_H)
#include <fcntl.h>
#endif
@@ -100,6 +101,12 @@ extern "C" {
#define O_BINARY 0
#endif
+#ifdef PATH_MAX
+#define JAS_PATH_MAX PATH_MAX
+#else
+#define JAS_PATH_MAX 4096
+#endif
+
/*
* Stream open flags.
*/
@@ -258,7 +265,7 @@ typedef struct {
typedef struct {
int fd;
int flags;
- char pathname[L_tmpnam + 1];
+ char pathname[JAS_PATH_MAX + 1];
} jas_stream_fileobj_t;
/* Delete underlying file object upon stream close. */
--
2.36.1

View File

@ -2,7 +2,7 @@
# Contributor: drakkan <nicola.murino at gmail dot com>
pkgname=mingw-w64-jasper
pkgver=4.0.0
pkgver=4.1.1
pkgrel=1
pkgdesc="A software-based implementation of the codec specified in the emerging JPEG-2000 Part-1 standard (mingw-w64)"
arch=(any)
@ -13,12 +13,10 @@ depends=('mingw-w64-libjpeg-turbo')
options=(staticlibs !strip !buildflags)
source=(${pkgname}-${pkgver}.tar.gz::https://github.com/mdadams/jasper/archive/version-${pkgver}.tar.gz
0001-Fix-exports.patch
0002-Fix-building-for-mingw-w64-target.patch
0003-Fix-filename-buffer-overflow.patch)
sha512sums=('dc03434870e85b1fdbdf41a3e07ce5a8044c8d225717d3d7a5969d45e3bd716bfb2abc4b4e0b8cec2f4071a7520c5d3e48939dba0cabe6d192eacd593de0c563'
'0eb2588a54e154ca93977088a63b7261bed605047e51ae0e9d537b0abbb5846a94f47f3e5df7cfd753d12c80273b922c74a752578938d3ba4da81f3b756b0ffb'
'bd61f586bc910fd698d5f3e66a7892a63ee85eabc6c2802672d607d1b7b3fda6e412973f5bcc7b47db2c80b3c627f679dd45cbe2d13b08f8520314d4d29e2468'
'31d900b6c160205151cbfac9f36fa0e5243dc87b0b8eab159cfa0b6935d87dd08119a52a0f853e6c2f3f754ca6c0030ec229379deb68ba16befd5f99983112ad')
0002-Fix-building-for-mingw-w64-target.patch)
sha512sums=('a15c196d7e448fb3c8b6512793d4b430e58ba6adf343b46392cac0880ae8c385cd75b43dd566c4a25baab983089cb95c00ae538dc0b84282cc98f2a9ce398d43'
'ffa3b51509c626ba7e93375161c2d8d80fe27b54601a1f66bd93032f7c5d2125d8f3d7f8a48701ee9c7422c79035f769f8dd032242475d3628bbf2da27cdcf00'
'643020a9f930d4bff0ea73f24c0801910b9bf34e5cc2feb9adbaf4b74965dd38739b957153393468f7d1d87c88232364ae5d3087e17c99b0f7c194febc825355')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
@ -26,11 +24,9 @@ prepare() {
cd "$srcdir/jasper-version-$pkgver"
patch -p1 -i "${srcdir}"/0001-Fix-exports.patch
patch -p1 -i "${srcdir}"/0002-Fix-building-for-mingw-w64-target.patch
patch -p1 -i "${srcdir}"/0003-Fix-filename-buffer-overflow.patch
}
build() {
cd "$srcdir/jasper-version-$pkgver"
local options=(
-DCMAKE_INSTALL_LIBDIR=lib
-DCMAKE_BUILD_TYPE=Release
@ -43,11 +39,11 @@ build() {
)
for _arch in ${_architectures}; do
mkdir -p build-${_arch}-static && pushd build-${_arch}-static
${_arch}-cmake ${options[@]} -DJAS_ENABLE_SHARED=OFF ..
${_arch}-cmake ${options[@]} -DJAS_ENABLE_SHARED=OFF "$srcdir/jasper-version-$pkgver"
make
popd
mkdir -p build-${_arch} && pushd build-${_arch}
${_arch}-cmake ${options[@]} -DJAS_ENABLE_SHARED=ON ..
${_arch}-cmake ${options[@]} -DJAS_ENABLE_SHARED=ON "$srcdir/jasper-version-$pkgver"
make
popd
done
@ -55,9 +51,9 @@ build() {
package() {
for _arch in ${_architectures}; do
cd "${srcdir}/jasper-version-${pkgver}/build-${_arch}-static"
cd "${srcdir}/build-${_arch}-static"
make DESTDIR="$pkgdir" install
cd "${srcdir}/jasper-version-${pkgver}/build-${_arch}"
cd "${srcdir}/build-${_arch}"
make DESTDIR="$pkgdir" install
rm -r "$pkgdir/usr/${_arch}/share"
${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll