Add tageditor-cli for a minimal CLI-only build of Tag Editor

This commit is contained in:
Martchus 2020-04-16 18:50:34 +02:00
parent 24fde84312
commit dd91635bee
2 changed files with 55 additions and 34 deletions

55
tageditor/cli/PKGBUILD Normal file
View File

@ -0,0 +1,55 @@
# Maintainer: Martchus <martchus@gmx.net>
# All my PKGBUILDs are managed at https://github.com/Martchus/PKGBUILDs where
# you also find the URL of a binary repository.
# A minimal version of tageditor which has only the CLI enabled and no JSON export
# by default.
# whether the experimental JSON export is enabled: ON or OFF
_json_export=${TAGEDITOR_JSON_EXPORT:-OFF}
_reponame=tageditor
pkgname=tageditor-cli
pkgver=3.3.6
pkgrel=1
arch=('i686' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
pkgdesc='A tag editor with command-line interface supporting MP4/M4A/AAC (iTunes), ID3, Vorbis, Opus, FLAC and Matroska (GUI disabled)'
license=('GPL')
depends=('c++utilities' 'tagparser')
makedepends=('cmake')
conflicts=("${pkgname%-cli}")
provides=("${pkgname%-cli}")
[[ $_json_export == ON ]] && makedepends+=('reflective-rapidjson')
checkdepends=('cppunit')
url="https://github.com/Martchus/${_reponame}"
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/Martchus/${_reponame}/archive/v${pkgver}.tar.gz")
sha256sums=('23cd6e03732757ef4e0d4a5fc6f2257a37b2eaa127da87a8be6a9bff5ec379b6')
build() {
cd "$srcdir/${PROJECT_DIR_NAME:-$_reponame-$pkgver}"
cmake \
-DCMAKE_BUILD_TYPE:STRING='Release' \
-DCMAKE_INSTALL_PREFIX:PATH='/usr' \
-DBUILD_SHARED_LIBS:BOOL=ON \
-DWIDGETS_GUI=OFF \
-DQUICK_GUI=OFF \
-DENABLE_JSON_EXPORT="${_json_export}" \
-DREFLECTION_GENERATOR_EXECUTABLE:FILEPATH='/usr/bin/reflective_rapidjson_generator' \
.
make
}
check() {
cd "$srcdir/${PROJECT_DIR_NAME:-$_reponame-$pkgver}"
if [[ $TEST_FILE_PATH ]]; then
make check
else
msg2 'Skipping execution of testsuite because the environment variable TEST_FILE_PATH is not set.'
fi
}
package() {
cd "$srcdir/${PROJECT_DIR_NAME:-$_reponame-$pkgver}"
make DESTDIR="${pkgdir}" install
}

View File

@ -1,34 +0,0 @@
From 8ad22faae56fb7df4d4f085799230f98ed441066 Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Sun, 30 Dec 2018 22:54:06 +0100
Subject: [PATCH] Fix building tests under 32-bit Linux
---
tests/cli.cpp | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/tests/cli.cpp b/tests/cli.cpp
index 43729c3..e1b5cb2 100644
--- a/tests/cli.cpp
+++ b/tests/cli.cpp
@@ -866,7 +866,7 @@ void CliTests::testExtraction()
MediaFileInfo extractedInfo("/tmp/extracted.jpeg");
extractedInfo.open(true);
extractedInfo.parseContainerFormat(diag);
- CPPUNIT_ASSERT_EQUAL(22771_st, extractedInfo.size());
+ CPPUNIT_ASSERT_EQUAL(static_cast<uint64>(22771), extractedInfo.size());
CPPUNIT_ASSERT(ContainerFormat::Jpeg == extractedInfo.containerFormat());
extractedInfo.invalidate();
@@ -879,7 +879,7 @@ void CliTests::testExtraction()
TESTUTILS_ASSERT_EXEC(args3);
extractedInfo.open(true);
extractedInfo.parseContainerFormat(diag);
- CPPUNIT_ASSERT_EQUAL(22771_st, extractedInfo.size());
+ CPPUNIT_ASSERT_EQUAL(static_cast<uint64>(22771), extractedInfo.size());
CPPUNIT_ASSERT(ContainerFormat::Jpeg == extractedInfo.containerFormat());
CPPUNIT_ASSERT_EQUAL(0, remove("/tmp/extracted.jpeg"));
CPPUNIT_ASSERT_EQUAL(0, remove(mp4File2.data()));
--
2.20.1