Update pistache-git to 204.b66415a

This commit is contained in:
Martchus 2018-01-29 16:11:26 +01:00
parent 836f9fb622
commit ddd4880c32
2 changed files with 3 additions and 73 deletions

View File

@ -1,62 +0,0 @@
From ef1474e0c587bb528532932c1db7e244755e5d49 Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Thu, 23 Mar 2017 20:50:21 +0100
Subject: [PATCH] Export targets
---
CMakeLists.txt | 2 +-
src/CMakeLists.txt | 20 ++++++++++++++++++++
src/PistacheConfig.cmake.in | 3 +++
3 files changed, 24 insertions(+), 1 deletion(-)
create mode 100644 src/PistacheConfig.cmake.in
diff --git a/CMakeLists.txt b/CMakeLists.txt
index de5716d..25e3d7c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,4 +1,4 @@
-cmake_minimum_required (VERSION 2.8.7)
+cmake_minimum_required (VERSION 3.0.2)
project (pistache)
include(CheckCXXCompilerFlag)
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 639ed0d..06cdb78 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -40,3 +40,23 @@ install(
DIRECTORY "${PROJECT_SOURCE_DIR}/include/pistache"
DESTINATION ${include_install_dir}
FILES_MATCHING PATTERN "*.*h")
+install(TARGETS pistache
+ EXPORT PistacheTargets
+ DESTINATION lib)
+install(EXPORT PistacheTargets
+ DESTINATION "lib/cmake/pistache"
+ EXPORT_LINK_INTERFACE_LIBRARIES
+ COMPONENT cmake-config
+)
+
+include(CMakePackageConfigHelpers)
+configure_package_config_file(
+ "PistacheConfig.cmake.in"
+ "${CMAKE_CURRENT_BINARY_DIR}/PistacheConfig.cmake"
+ INSTALL_DESTINATION "lib/cmake/pistache"
+)
+install(
+ FILES "${CMAKE_CURRENT_BINARY_DIR}/PistacheConfig.cmake"
+ DESTINATION "lib/cmake/pistache"
+ COMPONENT cmake-config
+)
diff --git a/src/PistacheConfig.cmake.in b/src/PistacheConfig.cmake.in
new file mode 100644
index 0000000..e8e92f0
--- /dev/null
+++ b/src/PistacheConfig.cmake.in
@@ -0,0 +1,3 @@
+@PACKAGE_INIT@
+
+include("${CMAKE_CURRENT_LIST_DIR}/PistacheTargets.cmake")
--
2.13.2

View File

@ -5,7 +5,7 @@
pkgname=pistache-git
_name=${pkgname%-git}
pkgver=189.9827cda
pkgver=204.b66415a
pkgrel=1
arch=('i686' 'x86_64')
pkgdesc='Modern and elegant HTTP and REST framework for C++'
@ -15,22 +15,14 @@ makedepends=('cmake' 'git')
provides=("${_name}")
conflicts=("${_name}")
url="https://github.com/oktal/${_name}"
source=("${_name}::git://github.com/oktal/${_name}.git"
'0001-Export-targets.patch')
sha256sums=('SKIP'
'68140dc3747b36e3287913cdb4e4ae1a2cc85d69e28560dee3937f6143e0cc5f')
source=("${_name}::git://github.com/oktal/${_name}.git")
sha256sums=('SKIP')
pkgver() {
cd "${srcdir}/${_name}"
echo "$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
}
prepare() {
cd "${srcdir}/${_name}"
patch -p1 -i "${srcdir}/0001-Export-targets.patch"
}
build() {
cd "${srcdir}/${_name}"