updated mingw-w64-qt5-base-opengl

This commit is contained in:
Martchus 2016-02-04 18:28:15 +01:00
parent 595179f8bc
commit fc850601d7
6 changed files with 28 additions and 11 deletions

View File

@ -118,6 +118,7 @@ OTHER_FILES += \
qt5-base/mingw-w64/qt5-workaround-pkgconfig-install-issue.patch \
qt5-base/mingw-w64/use-external-angle-library.patch \
qt5-base/mingw-w64-opengl/PKGBUILD \
qt5-base/mingw-w64-opengl/a91c40868bbdc1b2d2dd3b5f8b47aae9e8589a81.diff \
qt5-base/mingw-w64-opengl/add-angle-support.patch \
qt5-base/mingw-w64-opengl/angle-fix.patch \
qt5-base/mingw-w64-opengl/fix-opengl-to-many-sections.patch \
@ -129,6 +130,7 @@ OTHER_FILES += \
qt5-base/mingw-w64-opengl/qt5-dont-add-resource-files-to-qmake-libs.patch \
qt5-base/mingw-w64-opengl/qt5-dont-build-host-libs-static.patch \
qt5-base/mingw-w64-opengl/qt5-enable-rpath-for-host-tools.patch \
qt5-base/mingw-w64-opengl/qt5-fix-QSemaphore-problem.patch \
qt5-base/mingw-w64-opengl/qt5-fix-static-dbus-detection.patch \
qt5-base/mingw-w64-opengl/qt5-fix-static-harfbuzz-detection.patch \
qt5-base/mingw-w64-opengl/qt5-merge-static-and-shared-library-trees.patch \

View File

@ -53,8 +53,10 @@ source=("https://download.qt.io/official_releases/qt/${pkgver:0:3}/${pkgver}/sub
"qt5-use-system-zlib-in-host-libs.patch"
"fix-opengl-to-many-sections.patch"
"fix-static-psql-mysql.patch"
"qt5-disable-angle-opengl-testcode.patch")
md5sums=('252613b5a180c94d7196d10467a4f08b'
"qt5-disable-angle-opengl-testcode.patch"
"qt5-fix-QSemaphore-problem.patch"
"a91c40868bbdc1b2d2dd3b5f8b47aae9e8589a81.diff")
md5sums=('687e2b122fa2c3390b5e20a166d38038'
'f51eb2b176b10af943831d33925c1251'
'bab00ccc19d888997f323c80354a7c3f'
'ec25d1ff4033383cd5d2414d8189c228'
@ -67,12 +69,14 @@ md5sums=('252613b5a180c94d7196d10467a4f08b'
'6a6bc88f35ac8080869de39bc128ce5b'
'e793479e0b86b39ddafd328140f1a24c'
'40de3aaf7d713034e06f4eece665b1ba'
'1a7921cadeb5c3db383dea068519e8d3'
'6aea7182982098de045721f51bf20fc2'
'4149c27286f110e37893d1764d4c8a68'
'39cdea1b39a1d993df6d01a576e8116f'
'a265dea62755caf38187114143999224'
'612a4dfb9f1a3898a1920c28bb999159'
'd0eb81aef1a21c65813fe4ddabbc4206'
'0076233a43e7edaaaf8c2abca2ada8df')
'0076233a43e7edaaaf8c2abca2ada8df'
'87cbd116c75ced1b075bf266f2455d50'
'1bc70e7e3ea6a0178891d984f0451b3c')
_architectures="x86_64-w64-mingw32 i686-w64-mingw32"
# Helper functions for the split builds
@ -175,6 +179,11 @@ prepare() {
# EGL_PLATFORM_ANGLE_DEVICE_TYPE_ANGLE, EGL_PLATFORM_ANGLE_DEVICE_TYPE_WARP_ANGLE, EGL_NONE }
patch -p1 -b -i ../qt5-disable-angle-opengl-testcode.patch
patch configure ../qt5-fix-QSemaphore-problem.patch
# QTBUG-49174 Prevent warning output when QWebView loads QNetworkRequest
patch -p1 -b -i ../a91c40868bbdc1b2d2dd3b5f8b47aae9e8589a81.diff
isStatic && patch -p0 -i ../fix-static-psql-mysql.patch
# Make sure the Qt5 build system uses our external ANGLE library
@ -213,6 +222,7 @@ build() {
-system-libpng \
-system-libjpeg \
-system-sqlite \
-system-harfbuzz \
-no-fontconfig \
-iconv \
-openssl \
@ -289,6 +299,10 @@ package() {
rm -f "${pkgdir}/usr/${_arch}/lib/libQt5OpenGLExtensions"*
rm -f "${pkgdir}/usr/${_arch}/lib/libQt5PlatformSupport"*
# Also keep various Qt5 plugins to be used in static builds
# https://bugzilla.redhat.com/show_bug.cgi?id=1257630
mv "${pkgdir}/usr/${_arch}/lib/qt/plugins/"*/*.a "${pkgdir}/usr/${_arch}/lib/"
# we want to keep a couple pri files not found in base
mv "${pkgdir}/usr/${_arch}/lib/qt/mkspecs/modules/qt_plugin_"*.pri "${pkgdir}/usr/${_arch}"

View File

@ -4,4 +4,4 @@
SOURCES = harfbuzz.cpp
CONFIG -= qt dylib
-LIBS += -lharfbuzz
+LIBS += -lharfbuzz -lglib-2.0 -lws2_32 -lole32 -lwinmm -lshlwapi -lintl
+LIBS += -lharfbuzz -lglib-2.0 -lws2_32 -lole32 -lwinmm -lshlwapi -lintl -liconv

View File

@ -80,7 +80,7 @@
--- src/plugins/platforms/windows/windows.pri 2014-12-05 09:24:37.000000000 -0700
+++ src/plugins/platforms/windows/windows.pri 2014-12-11 10:13:45.228261276 -0700
@@ -3,6 +3,7 @@
!wince*:LIBS *= -luser32 -lwinspool -limm32 -lwinmm -loleaut32
!wince: LIBS *= -luser32 -lwinspool -limm32 -lwinmm -loleaut32
contains(QT_CONFIG, opengl):!contains(QT_CONFIG, opengles2):!contains(QT_CONFIG, dynamicgl): LIBS *= -lopengl32
+contains(QT_CONFIG, angle):LIBS += -lGLESv2 -lEGL

View File

@ -22,7 +22,7 @@
QMAKE_LFLAGS_DEBUG =
QMAKE_LFLAGS_CONSOLE = -Wl,-subsystem,console
QMAKE_LFLAGS_WINDOWS = -Wl,-subsystem,windows
@@ -84,21 +84,25 @@
@@ -84,21 +84,26 @@
QMAKE_EXTENSION_STATICLIB = a
QMAKE_LIBS =
@ -46,6 +46,7 @@
QMAKE_LIB = $${CROSS_COMPILE}ar -ru
QMAKE_RC = $${CROSS_COMPILE}windres
+QMAKE_DLLTOOL = $${CROSS_COMPILE}dlltool
+QMAKE_LRELEASE = $${CROSS_COMPILE}lrelease-qt5
QMAKE_STRIP = $${CROSS_COMPILE}strip
QMAKE_STRIPFLAGS_LIB += --strip-unneeded

View File

@ -123,9 +123,9 @@ build() {
unset PKG_CONFIG_PATH
cd "${srcdir}/${_pkgfqn}"
for _arch in ${_architectures}; do
# Since Source/ThirdParty/ANGLE has been removed include path for
# system library must be set
export CPATH=/usr/$_arch/include
# Since Source/ThirdParty/ANGLE has been removed ensure files
# from system ANGLE can be included
export CPATH=/usr/$_arch/include:/usr/$_arch/include/GLSLANG
mkdir -p build-${_arch} && pushd build-${_arch}
${_arch}-qmake-qt5 QMAKE_CXXFLAGS+=-Wno-c++0x-compat ../WebKit.pro