PKGBUILDs/devtools/custom/PKGBUILD

59 lines
1.2 KiB
Bash

# Maintainer of regular devtools package: Pierre Schmitz <pierre@archlinux.de>
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - patches to fix issues with how we use the tools
# "custom": Martchus <martchus@gmx.net>
# - patches to fix issues with how I use the tools
pkgname=devtools-custom
_pkgname=devtools
epoch=1
pkgver=1.1.1
pkgrel=1
pkgdesc='Tools for Arch Linux package maintainers (patches from ALARM and custom ones)'
arch=('any')
license=('GPL')
url='https://martchus.no-ip.biz/gitea/Martchus/devtools/src/branch/custom'
conflicts=('devtools' 'devtools-alarm')
provides=('devtools' 'devtools-alarm')
depends=(
arch-install-scripts
awk
bash
binutils
coreutils
diffutils
fakeroot
findutils
grep
jq
openssh
parallel
rsync
sed
util-linux
breezy
git
mercurial
subversion
)
makedepends=(
asciidoc
shellcheck
)
optdepends=('btrfs-progs: btrfs support')
source=("git+https://martchus.no-ip.biz/gitea/Martchus/$_pkgname.git#branch=custom-v$pkgver")
sha256sums=('SKIP')
build() {
cd "$srcdir/${_pkgname}"
make BUILDTOOLVER="${epoch}:${pkgver}-${pkgrel}-${arch}" PREFIX=/usr
}
package() {
cd "$srcdir/${_pkgname}"
make PREFIX=/usr DESTDIR="${pkgdir}" install
}