PKGBUILDs/jasper/mingw-w64/0001-Fix-exports.patch

40 lines
1.4 KiB
Diff

From e5ddfa21a008708e12eedadbb1d7b0b377fd2680 Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Tue, 14 Jun 2022 23:12:32 +0200
Subject: [PATCH 1/2] Fix exports
---
src/libjasper/jp2/jp2_cod.h | 10 +++++-----
1 file changed, 5 insertions(+), 5 deletions(-)
diff --git a/src/libjasper/jp2/jp2_cod.h b/src/libjasper/jp2/jp2_cod.h
index 81d3b7e..4f22fa3 100644
--- a/src/libjasper/jp2/jp2_cod.h
+++ b/src/libjasper/jp2/jp2_cod.h
@@ -288,10 +288,10 @@ typedef struct jp2_boxinfo_s {
* Box class.
\******************************************************************************/
-jp2_box_t *jp2_box_create(int type);
-void jp2_box_destroy(jp2_box_t *box);
-jp2_box_t *jp2_box_get(jas_stream_t *in);
-int jp2_box_put(jp2_box_t *box, jas_stream_t *out);
+JAS_DLLEXPORT jp2_box_t *jp2_box_create(int type);
+JAS_DLLEXPORT void jp2_box_destroy(jp2_box_t *box);
+JAS_DLLEXPORT jp2_box_t *jp2_box_get(jas_stream_t *in);
+JAS_DLLEXPORT int jp2_box_put(jp2_box_t *box, jas_stream_t *out);
JAS_ATTRIBUTE_CONST
static inline uint_least8_t JP2_DTYPETOBPC(uint_least8_t dtype)
@@ -309,6 +309,6 @@ static inline uint_least8_t JP2_BPCTODTYPE(uint_least8_t bpc)
#define ICC_CS_YCBCR 0x59436272
#define ICC_CS_GRAY 0x47524159
-const jp2_cdefchan_t *jp2_cdef_lookup(jp2_cdef_t *cdef, int channo);
+JAS_DLLEXPORT const jp2_cdefchan_t *jp2_cdef_lookup(jp2_cdef_t *cdef, int channo);
#endif
--
2.43.0