PKGBUILDs/qt6-base/mingw-w64/0015-Link-corelib-correctly...

32 lines
1.0 KiB
Diff

From ad906387f486d196bfe083bd98dcfe7b1359594c Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Sat, 17 Feb 2024 21:39:39 +0100
Subject: [PATCH 15/16] Link corelib correctly against runtimeobject when
compiling for Windows
This library is included by mingw-w64 and also needs to be linked against
for code in `qlocale_win.cpp` enabled via the `cpp_winrt` feature flag.
Change-Id: I9f06f3845165afaf305a0fc7771a1093cba08811
---
src/corelib/CMakeLists.txt | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
diff --git a/src/corelib/CMakeLists.txt b/src/corelib/CMakeLists.txt
index bbe8ba84890..06ede966852 100644
--- a/src/corelib/CMakeLists.txt
+++ b/src/corelib/CMakeLists.txt
@@ -819,8 +819,7 @@ qt_internal_extend_target(Core CONDITION WASM
text/qlocale_wasm.cpp
)
-# On MS-Win, clang has two flavors, one of which immitates MSVC (so claims to be it)
-qt_internal_extend_target(Core CONDITION MSVC
+qt_internal_extend_target(Core CONDITION WIN32
LIBRARIES
runtimeobject
)
--
2.45.1