PKGBUILDs/qt5-base/mingw-w64-angle/0003-Fix-too-many-sections-...

30 lines
892 B
Diff

From dc9fb928edeae31a253b27dc6536117b1ec3ed0d Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Sun, 18 Sep 2016 13:48:51 +0200
Subject: [PATCH 03/33] Fix too many sections assemler error in OpenGL factory
On x86_64 qopenglversionfunctionsfactory.o exceeds the
limit of 32768 sections.
Hence the assembler option -mbig-obj is required.
---
src/gui/opengl/opengl.pri | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/src/gui/opengl/opengl.pri b/src/gui/opengl/opengl.pri
index 24758afdeb..aa04b4a672 100644
--- a/src/gui/opengl/opengl.pri
+++ b/src/gui/opengl/opengl.pri
@@ -3,7 +3,8 @@
qtConfig(opengl): CONFIG += opengl
qtConfig(opengles2): CONFIG += opengles2
-qtConfig(opengl) {
+qtConfig(opengl)|qtConfig(opengles2) {
+ mingw:QMAKE_CXXFLAGS+="-Wa,-mbig-obj"
HEADERS += opengl/qopengl.h \
opengl/qopengl_p.h \
--
2.23.0