PKGBUILDs/qt5-base/mingw-w64-opengl/0008-Fix-linking-against-st...

59 lines
1.8 KiB
Diff

From f6e638c4058335603797e7cd451fc71e89866b7e Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Fri, 3 Feb 2017 19:36:25 +0100
Subject: [PATCH 08/33] Fix linking against static D-Bus
---
configure.json | 9 +++++++--
src/dbus/qdbus_symbols_p.h | 4 ++++
2 files changed, 11 insertions(+), 2 deletions(-)
diff --git a/configure.json b/configure.json
index af55bb6fd2..370c27af5b 100644
--- a/configure.json
+++ b/configure.json
@@ -187,18 +187,23 @@
"dbus": {
"label": "D-Bus >= 1.2",
"test": {
- "main": "(void) dbus_bus_get_private(DBUS_BUS_SYSTEM, (DBusError *)NULL);"
+ "main": "(void) dbus_bus_get_private(DBUS_BUS_SYSTEM, (DBusError *)NULL);",
+ "qmake": "static: DEFINES += DBUS_STATIC_BUILD"
},
"headers": "dbus/dbus.h",
"sources": [
{ "type": "pkgConfig", "args": "dbus-1 >= 1.2" },
+ {
+ "libs": "-ldbus-1 -lws2_32 -liphlpapi",
+ "condition": "config.win32 && !features.shared"
+ },
{
"libs": "",
"builds": {
"debug": "-ldbus-1d",
"release": "-ldbus-1"
},
- "condition": "config.win32"
+ "condition": "config.win32 && features.shared"
},
{ "libs": "-ldbus-1", "condition": "!config.win32" }
]
diff --git a/src/dbus/qdbus_symbols_p.h b/src/dbus/qdbus_symbols_p.h
index 7cce0d71aa..4d3d774d45 100644
--- a/src/dbus/qdbus_symbols_p.h
+++ b/src/dbus/qdbus_symbols_p.h
@@ -57,6 +57,10 @@
#ifndef QT_NO_DBUS
+#ifdef QT_STATIC
+# define DBUS_STATIC_BUILD
+#endif
+
#ifdef QT_LINKED_LIBDBUS
# include <dbus/dbus.h>
#else
--
2.23.0