PKGBUILDs/qt5-webkit/mingw-w64/0007-Include-intrin.h-for-d...

26 lines
649 B
Diff

From e2623801cfd15fdf24f0af2bfc01bdfb2b0ca22d Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Sun, 25 Sep 2016 22:21:54 +0200
Subject: [PATCH 7/9] Include intrin.h for declaration of _mm_mfence
---
Source/WTF/wtf/Atomics.h | 2 ++
1 file changed, 2 insertions(+)
diff --git a/Source/WTF/wtf/Atomics.h b/Source/WTF/wtf/Atomics.h
index 8f950c718..142c0db3e 100644
--- a/Source/WTF/wtf/Atomics.h
+++ b/Source/WTF/wtf/Atomics.h
@@ -68,6 +68,8 @@
#elif !COMPILER(GCC)
extern "C" void _ReadWriteBarrier(void);
#pragma intrinsic(_ReadWriteBarrier)
+#else
+#include <intrin.h>
#endif
#include <windows.h>
#elif OS(QNX)
--
2.11.0