PKGBUILDs/qt5-declarative/apple-darwin/0003-Prevent-exporting-QML-...

38 lines
1.3 KiB
Diff

From 6a34e383816f0ef74241980e7d712fd51974b40d Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Sat, 4 Feb 2017 01:59:59 +0100
Subject: [PATCH 3/3] Prevent exporting QML parser symbols on static build
---
src/qml/parser/qqmljsglobal_p.h | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/src/qml/parser/qqmljsglobal_p.h b/src/qml/parser/qqmljsglobal_p.h
index 0e195994b..8aa451e9d 100644
--- a/src/qml/parser/qqmljsglobal_p.h
+++ b/src/qml/parser/qqmljsglobal_p.h
@@ -56,9 +56,9 @@
# define QT_QML_BEGIN_NAMESPACE
# define QT_QML_END_NAMESPACE
-# ifdef QDECLARATIVEJS_BUILD_DIR
+# if defined(QDECLARATIVEJS_BUILD_DIR) && !defined(QT_STATIC)
# define QML_PARSER_EXPORT Q_DECL_EXPORT
-# elif QML_BUILD_STATIC_LIB
+# elif defined(QML_BUILD_STATIC_LIB) || defined(QT_STATIC)
# define QML_PARSER_EXPORT
# else
# define QML_PARSER_EXPORT Q_DECL_IMPORT
@@ -68,7 +68,7 @@
# define QT_QML_BEGIN_NAMESPACE QT_BEGIN_NAMESPACE
# define QT_QML_END_NAMESPACE QT_END_NAMESPACE
# ifndef QT_STATIC
-# if defined(QT_BUILD_QMLDEVTOOLS_LIB) || defined(QT_QMLDEVTOOLS_LIB)
+# if defined(QT_BUILD_QMLDEVTOOLS_LIB) || defined(QT_QMLDEVTOOLS_LIB) || defined(QT_STATIC)
// QmlDevTools is a static library
# define QML_PARSER_EXPORT
# elif defined(QT_BUILD_QML_LIB)
--
2.13.2