PKGBUILDs/qt5-base/mingw-w64-dynamic/0023-Use-correct-pkg-config...

29 lines
1018 B
Diff

From aeec21b7d2c0185499531c55282d8738c19770f2 Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Sun, 18 Sep 2016 18:50:21 +0200
Subject: [PATCH 23/25] Use correct pkg-config --static flag
---
configure | 5 +++++
1 file changed, 5 insertions(+)
diff --git a/configure b/configure
index b4c75c6..eea15f0 100755
--- a/configure
+++ b/configure
@@ -4153,6 +4153,11 @@ if [ -z "$PKG_CONFIG" ]; then
# See if PKG_CONFIG is set in the mkspec:
PKG_CONFIG="`"$CFG_QMAKE_PATH" -qtconf "$QTCONFFILE" -E -nocache -spec "$XQMAKESPEC" "CONFIG=" $DEV_NULL 2>&1 | sed -n -e 's,^PKG_CONFIG = \(.*\),\1,p'`"
[ -n "$PKG_CONFIG" ] && [ "$OPT_VERBOSE" = "yes" ] && echo "Found pkg-config from mkspec: $PKG_CONFIG"
+
+ if [ "$CFG_SHARED" = "no" ] ; then
+ PKG_CONFIG="$PKG_CONFIG --static"
+ [ "$OPT_VERBOSE" = "yes" ] && echo "Using '$PKG_CONFIG' because we're doing a static build"
+ fi
fi
if [ -z "$PKG_CONFIG" ]; then
PKG_CONFIG=`"$WHICH" pkg-config 2>/dev/null`
--
2.10.2