PKGBUILDs/qt5-base/mingw-w64/0013-Fix-linking-against-ex...

37 lines
1.5 KiB
Diff

From 3bbcdf8e7657d5112e3d35e372786949424b5a37 Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Sun, 18 Sep 2016 14:22:56 +0200
Subject: [PATCH 13/25] Fix linking against external harfbuzz
---
config.tests/unix/harfbuzz/harfbuzz.pro | 3 ++-
src/3rdparty/harfbuzz_dependency.pri | 4 +++-
2 files changed, 5 insertions(+), 2 deletions(-)
diff --git a/config.tests/unix/harfbuzz/harfbuzz.pro b/config.tests/unix/harfbuzz/harfbuzz.pro
index 32edd6e..cc40fc1 100644
--- a/config.tests/unix/harfbuzz/harfbuzz.pro
+++ b/config.tests/unix/harfbuzz/harfbuzz.pro
@@ -1,3 +1,4 @@
SOURCES = harfbuzz.cpp
CONFIG -= qt dylib
-LIBS += -lharfbuzz
+contains(CONFIG, static): LIBS += $$system($$PKG_CONFIG --static --libs harfbuzz)
+else: LIBS += $$system($$PKG_CONFIG --libs harfbuzz)
diff --git a/src/3rdparty/harfbuzz_dependency.pri b/src/3rdparty/harfbuzz_dependency.pri
index 7443368..2932f05 100644
--- a/src/3rdparty/harfbuzz_dependency.pri
+++ b/src/3rdparty/harfbuzz_dependency.pri
@@ -2,5 +2,7 @@ contains(QT_CONFIG, harfbuzz) {
INCLUDEPATH += $$PWD/harfbuzz-ng/include
LIBS_PRIVATE += -L$$QT_BUILD_TREE/lib -lqtharfbuzzng$$qtPlatformTargetSuffix()
} else:contains(QT_CONFIG, system-harfbuzz) {
- LIBS_PRIVATE += -lharfbuzz
+ # can't use 'feature' link_pkgconfig here because it would add harfbuzz to LIBS rather than LIBS_PRIVATE
+ contains(QT_CONFIG, static): LIBS_PRIVATE += $$system($$PKG_CONFIG --static --libs harfbuzz)
+ else: LIBS_PRIVATE += $$system($$PKG_CONFIG --libs harfbuzz)
}
--
2.10.2