PKGBUILDs/qt5-base/mingw-w64-dynamic/0024-Use-correct-pkg-config...

27 lines
751 B
Diff

From 707d13766144a4d66f10a853acada867913ef03e Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Sun, 18 Sep 2016 18:50:21 +0200
Subject: [PATCH 24/33] Use correct pkg-config --static flag
---
configure.pri | 3 +++
1 file changed, 3 insertions(+)
diff --git a/configure.pri b/configure.pri
index 8e703a0975..c2857cc439 100644
--- a/configure.pri
+++ b/configure.pri
@@ -350,6 +350,9 @@ defineTest(qtConfTest_detectPkgConfig) {
qtLog("Found pkg-config from path: $$pkgConfig")
}
}
+ !isEmpty(pkgConfig):qtConfig(static) {
+ pkgConfig = "$$pkgConfig --static"
+ }
$$qtConfEvaluate("features.cross_compile") {
# cross compiling, check that pkg-config is set up sanely
--
2.22.0