PKGBUILDs/qt5-base/mingw-w64/0023-Use-correct-pkg-config...

27 lines
751 B
Diff

From 705484ee67ab6686670f6249526da70bcb26f454 Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Sun, 18 Sep 2016 18:50:21 +0200
Subject: [PATCH 23/32] Use correct pkg-config --static flag
---
configure.pri | 3 +++
1 file changed, 3 insertions(+)
diff --git a/configure.pri b/configure.pri
index eda4a35013..6dbb1f4d1d 100644
--- a/configure.pri
+++ b/configure.pri
@@ -351,6 +351,9 @@ defineTest(qtConfTest_detectPkgConfig) {
qtLog("Found pkg-config from path: $$pkgConfig")
}
}
+ !isEmpty(pkgConfig):qtConfig(static) {
+ pkgConfig = "$$pkgConfig --static"
+ }
$$qtConfEvaluate("features.cross_compile") {
# cross compiling, check that pkg-config is set up sanely
--
2.39.0