Remove patches for rpi_ws281x-git

Only a few adjustments were left but nothing critical
to the build. So let's try to upstream the remaining
ones and get rid of the patches here.
This commit is contained in:
Martchus 2018-12-24 15:03:55 +01:00
parent f297140472
commit 25877b67fb
4 changed files with 2 additions and 94 deletions

View File

@ -1,24 +0,0 @@
From 4f4d7b74391db1cdec6b32d085090a9c6a8d4cad Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Thu, 1 Nov 2018 04:58:01 +0000
Subject: [PATCH 1/3] Allow to adjust build directory
---
SConstruct | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/SConstruct b/SConstruct
index 64c14c7..16ac279 100644
--- a/SConstruct
+++ b/SConstruct
@@ -72,5 +72,6 @@ if env['TOOLCHAIN'] != '':
env['AR'] = env['TOOLCHAIN'] + '-ar'
Export(['clean_envs'])
-SConscript('SConscript');
+AddOption('--build', default='')
+SConscript('SConscript', variant_dir=GetOption('build'), duplicate=0);
--
2.20.1

View File

@ -1,25 +0,0 @@
From 4bba7f43328617ae742ed342e16d9fc5d8f1e0fe Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Thu, 1 Nov 2018 05:02:52 +0000
Subject: [PATCH 2/3] Update help text for default DMA
---
main.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/main.c b/main.c
index 85ecd67..f88414a 100644
--- a/main.c
+++ b/main.c
@@ -247,7 +247,7 @@ void parseargs(int argc, char **argv, ws2811_t *ws2811)
"-s (--strip) - strip type - rgb, grb, gbr, rgbw\n"
"-x (--width) - matrix width (default 8)\n"
"-y (--height) - matrix height (default 8)\n"
- "-d (--dma) - dma channel to use (default 5)\n"
+ "-d (--dma) - dma channel to use (default 10)\n"
"-g (--gpio) - GPIO to use\n"
" If omitted, default is 18 (PWM0)\n"
"-i (--invert) - invert pin output (pulse LOW)\n"
--
2.20.1

View File

@ -1,27 +0,0 @@
From c5f98979c69d1bfbe1bba5349103d8872499dee8 Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Thu, 1 Nov 2018 05:05:06 +0000
Subject: [PATCH 3/3] Adjust LED defs
---
main.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/main.c b/main.c
index f88414a..d15a06c 100644
--- a/main.c
+++ b/main.c
@@ -63,8 +63,8 @@ static char VERSION[] = "XX.YY.ZZ";
#define STRIP_TYPE WS2811_STRIP_GBR // WS2812/SK6812RGB integrated chip+leds
//#define STRIP_TYPE SK6812_STRIP_RGBW // SK6812RGBW (NOT SK6812RGB)
-#define WIDTH 8
-#define HEIGHT 8
+#define WIDTH (24 + 16 + 6 + 1)
+#define HEIGHT 1
#define LED_COUNT (WIDTH * HEIGHT)
int width = WIDTH;
--
2.20.1

View File

@ -16,24 +16,8 @@ makedepends=('scons' 'git')
provides=("${_name}")
conflicts=("${_name}")
url="https://github.com/jgarff/${_reponame}"
source=("${_reponame}::git://github.com/jgarff/${_reponame}.git"
'0001-Allow-to-adjust-build-directory.patch'
'0002-Update-help-text-for-default-DMA.patch'
'0003-Adjust-LED-defs.patch')
sha256sums=('SKIP'
'26119114589fc5aef067fd1de99b532c27416642aeab9ad1150dcc5badc95b59'
'2ca78207da848ac22d7c791c564988c9a0a0c407c710fe9540ac57a580c5df1c'
'daaa7f46c988b7b37f5528361648ff2d830d3b929f0be032a9fdc4a751b9829e')
prepare() {
cd "$srcdir/$_reponame"
# apply patches; further descriptions can be found in patch files itself
for patch in "$srcdir/"*.patch; do
msg2 "Applying patch $patch"
patch -p1 -i "$patch"
done
}
source=("${_reponame}::git://github.com/jgarff/${_reponame}.git")
sha256sums=('SKIP')
pkgver() {
cd "$srcdir/$_reponame"