Merge pull request #8 from jlsantiago0/master

Make GLintptr and GLsizeiptr match those from QtOpenGL /usr/i686-w64-…
This commit is contained in:
Martchus 2016-11-04 08:31:10 +01:00 committed by GitHub
commit 359f98525f
4 changed files with 60 additions and 6 deletions

View File

@ -9,7 +9,7 @@
pkgname=mingw-w64-angleproject
pkgver=2.1.r5707.5858f7e
pkgrel=1
pkgrel=2
pkgdesc='ANGLE project (mingw-w64)'
arch=('any')
url='https://chromium.googlesource.com/angle/angle/+/master/README.md'
@ -23,14 +23,16 @@ source=('angleproject::git+https://chromium.googlesource.com/angle/angle#commit=
'libEGL_mingw32.def'
'libGLESv2_mingw32.def'
'entry_points_shader.cpp'
'provide_mbstowcs_s_for_xp.patch')
'provide_mbstowcs_s_for_xp.patch'
'fix-compatibility-with-qtopengl-and-qtwebkit.patch')
sha256sums=('SKIP'
'SKIP'
'895c62846e6784dcc33171523a452cb474010d3fc9e7c351c27b8add4e9930ab'
'fb04f30b904760d32c4c0b733d0a0b44359855db1fde9e7f5ca7d0b8b1be3e56'
'3186d913a5fb483d2ae568068453e494d52df8f3f23f09d16afbbf916a63e4a4'
'ad347c9732f8897497aa51b8969a0e01cd8cd4ebb9a0e873a2ff47c210f1d46c'
'57b16254c23dbd312dbbe0495a177690809b916c2f3d8b3bbf2dd405274d518c')
'57b16254c23dbd312dbbe0495a177690809b916c2f3d8b3bbf2dd405274d518c'
'5e4ca559a0d9efb00cbe097c8ae0102bb3132a78e68d590a5826ff86f2a6ccf2')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
#pkgver() {
@ -65,6 +67,10 @@ prepare() {
# provide own implementation of mbstowcs_s for Windows XP support
patch -p1 -i "${srcdir}/provide_mbstowcs_s_for_xp.patch"
# Fixes definition of GLsizeiptr and GLintptr to match that used by
# qopenglext.h in qt5-base. Fixes build of qt5-base-dynamic and qt5-webkit.
patch -p1 -i "${srcdir}/fix-compatibility-with-qtopengl-and-qtwebkit.patch"
# executing .bat scripts on Linux is a no-go so make this a no-op
echo "" > src/copy_compiler_dll.bat
chmod +x src/copy_compiler_dll.bat

View File

@ -0,0 +1,30 @@
diff -Naur angleproject.orig/include/KHR/khrplatform.h angleproject/include/KHR/khrplatform.h
--- angleproject.orig/include/KHR/khrplatform.h 2016-10-26 16:15:14.000000000 -0500
+++ angleproject/include/KHR/khrplatform.h 2016-11-02 17:02:26.685185043 -0500
@@ -228,17 +228,22 @@
* to be the only LLP64 architecture in current use.
*/
#ifdef _WIN64
-typedef signed long long int khronos_intptr_t;
+//typedef signed long long int khronos_intptr_t;
typedef unsigned long long int khronos_uintptr_t;
-typedef signed long long int khronos_ssize_t;
+//typedef signed long long int khronos_ssize_t;
typedef unsigned long long int khronos_usize_t;
#else
-typedef signed long int khronos_intptr_t;
+//typedef signed long int khronos_intptr_t;
typedef unsigned long int khronos_uintptr_t;
-typedef signed long int khronos_ssize_t;
+//typedef signed long int khronos_ssize_t;
typedef unsigned long int khronos_usize_t;
#endif
+// Make this compatible with QTOpenGL and QtWebkit.
+// It seems that ptrdiff_t is the right size on WIN32 and WIN64.
+typedef ptrdiff_t khronos_intptr_t;
+typedef ptrdiff_t khronos_ssize_t;
+
#if KHRONOS_SUPPORT_FLOAT
/*
* Float type

View File

@ -0,0 +1,16 @@
diff -Naur qtmultimedia-opensource-src-5.7.0.orig/src/plugins/common/evr/evrd3dpresentengine.cpp qtmultimedia-opensource-src-5.7.0/src/plugins/common/evr/evrd3dpresentengine.cpp
--- qtmultimedia-opensource-src-5.7.0.orig/src/plugins/common/evr/evrd3dpresentengine.cpp 2016-06-08 06:38:56.000000000 -0500
+++ qtmultimedia-opensource-src-5.7.0/src/plugins/common/evr/evrd3dpresentengine.cpp 2016-11-03 14:07:13.172478447 -0500
@@ -49,9 +49,9 @@
#include <private/qmediaopenglhelper_p.h>
#ifdef MAYBE_ANGLE
-# include <qtgui/qguiapplication.h>
-# include <qpa/qplatformnativeinterface.h>
-# include <qopenglfunctions.h>
+# include <QtGui/qguiapplication.h>
+# include <QtGui/qpa/qplatformnativeinterface.h>
+# include <QtGui/qopenglfunctions.h>
# include <EGL/eglext.h>
#endif

View File

@ -11,7 +11,7 @@
_qt_module=qtmultimedia
pkgname=mingw-w64-qt5-multimedia
pkgver=5.7.0
pkgrel=3
pkgrel=4
arch=('any')
pkgdesc='Classes for audio, video, radio and camera functionality (mingw-w64)'
depends=('mingw-w64-qt5-base' 'mingw-w64-qt5-declarative')
@ -22,9 +22,11 @@ license=('GPL3' 'LGPL' 'FDL' 'custom')
url='https://www.qt.io/'
_pkgfqn="${_qt_module}-opensource-src-${pkgver}"
source=("https://download.qt.io/official_releases/qt/${pkgver:0:3}/${pkgver}/submodules/${_pkgfqn}.tar.xz"
'0001-Recorder-includes-to-prevent-conflict-with-vsnprintf.patch')
'0001-Recorder-includes-to-prevent-conflict-with-vsnprintf.patch'
'0002-Fix-build-wtih-angle-enabled.patch')
md5sums=('44c1b9a1dfb0e8b13f2d9571829500ee'
'530551aefa1310f6ff740663b84751cd')
'530551aefa1310f6ff740663b84751cd'
'e4b435f51063d8d3868efb8224c89ff8')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
[[ $NO_STATIC_LIBS ]] || \