gogs: Adjust default locations for attachments/avatars

So Gogs is not trying to store them under /usr/bin by default
This commit is contained in:
Martchus 2017-04-27 02:41:00 +02:00
parent 620bbb714d
commit 4e00ff797b
3 changed files with 40 additions and 13 deletions

View File

@ -1,14 +1,14 @@
From 60c868f117e603dbe89be616539d88ca85236693 Mon Sep 17 00:00:00 2001
From 866c5d2cafa1d2a0914532e1d738678f7061952a Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Sun, 19 Mar 2017 18:03:36 +0100
Subject: [PATCH 1/2] Adjust config for Arch Linux package
---
conf/app.ini | 18 +++++++++---------
1 file changed, 9 insertions(+), 9 deletions(-)
conf/app.ini | 24 ++++++++++++------------
1 file changed, 12 insertions(+), 12 deletions(-)
diff --git a/conf/app.ini b/conf/app.ini
index 315d305d..012feb8e 100644
index 2927c2aa..899856b1 100644
--- a/conf/app.ini
+++ b/conf/app.ini
@@ -5,7 +5,7 @@
@ -47,7 +47,7 @@ index 315d305d..012feb8e 100644
; The script type server supports, sometimes could be "sh"
SCRIPT_TYPE = bash
; Default ANSI charset for an unrecognized charset
@@ -106,7 +106,7 @@ PREVIEWABLE_FILE_MODES = markdown
@@ -108,7 +108,7 @@ PREVIEWABLE_FILE_MODES = markdown
; Enable repository file uploads.
ENABLED = true
; Path to temporarily store uploads (default path gets cleaned by Gogs in every start)
@ -56,7 +56,16 @@ index 315d305d..012feb8e 100644
; File types that are allowed to be uploaded, e.g. image/jpeg|image/png. Leave empty means allow any file type
ALLOWED_TYPES =
; Maximum size of each file in MB
@@ -165,7 +165,7 @@ PASSWD =
@@ -121,7 +121,7 @@ MAX_FILES = 5
; Whether attachments are enabled. Defaults to `true`
ENABLED = true
; Path for attachments. Defaults to `data/attachments`
-PATH = data/attachments
+PATH = /var/lib/gogs/attachments
; One or more allowed types, e.g. image/jpeg|image/png
ALLOWED_TYPES = */*
; Max size of each file. Defaults to 32MB
@@ -167,7 +167,7 @@ PASSWD =
; For "postgres" only, either "disable", "require" or "verify-full"
SSL_MODE = disable
; For "sqlite3" and "tidb", use absolute path when you start as service
@ -65,7 +74,25 @@ index 315d305d..012feb8e 100644
[admin]
; Disable regular (non-admin) users to create organizations
@@ -307,7 +307,7 @@ FORMAT =
@@ -280,7 +280,7 @@ CSRF_COOKIE_NAME = _csrf
[picture]
; Path to store user uploaded avatars
-AVATAR_UPLOAD_PATH = data/avatars
+AVATAR_UPLOAD_PATH = /var/lib/gogs/avatars
; Chinese users can choose "duoshuo"
; or a custom avatar source, like: http://cn.gravatar.com/avatar/
GRAVATAR_SOURCE = gravatar
@@ -296,7 +296,7 @@ ENABLE_FEDERATED_AVATAR = true
; Whether attachments are enabled. Defaults to `true`
ENABLE = true
; Path for attachments. Defaults to `data/attachments`
-PATH = data/attachments
+PATH = /var/lib/gogs/attachments
; One or more allowed types, e.g. image/jpeg|image/png
ALLOWED_TYPES = image/jpeg|image/png
; Max size of each file. Defaults to 4MB
@@ -312,7 +312,7 @@ FORMAT =
; General settings of loggers
[log]
@ -75,5 +102,5 @@ index 315d305d..012feb8e 100644
; Use comma to separate multiple modes, e.g. "console, file"
MODE = console
--
2.12.0
2.12.2

View File

@ -1,4 +1,4 @@
From aac58a3b3036bef496937b84668424ea1c3b761a Mon Sep 17 00:00:00 2001
From fc69adfb98d736b6df628a12142c224c4b6730e2 Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Sun, 19 Mar 2017 18:04:48 +0100
Subject: [PATCH 2/2] Adjust service file for Arch Linux package
@ -30,5 +30,5 @@ index 9f105bf8..99ca11e0 100644
[Install]
WantedBy=multi-user.target
--
2.12.0
2.12.2

View File

@ -5,7 +5,7 @@
pkgname=gogs
_pkgname=${pkgname}
pkgver=0.11.4
pkgrel=1
pkgrel=2
epoch=1
pkgdesc='Self Hosted Git Service written in Go'
arch=('i686' 'x86_64' 'armv6h' 'armv7h')
@ -29,8 +29,8 @@ source=("$_pkgname-$pkgver::https://${_gourl}/archive/v${pkgver}.tar.gz"
'0001-Adjust-config-for-Arch-Linux-package.patch'
'0002-Adjust-service-file-for-Arch-Linux-package.patch')
sha512sums=('e262cdd2409dd846a1473993c222a7b9692c694ac9620a5dcd576a17714bfee76212935dcfbf0ad83b7b95623c075f1622613524f347d24d7530732e966c733f'
'eb888ebc4b85671eb06ba46fb15b53d96fdc27f5429258fed7d841104b358a7c51b465c22bde551b4627c48028822d39292e6933d8f68a5e0483efab16ad2265'
'd3ad394804fa801f28c324344ca2d99f92c3b547eb5326c48897aa8d80c6d92468ab2a528e721b7129db4836e48c58b2695f61555f7d134abdde5ac53053ca6b')
'1df73da8962605369bbefcf6ad2b2cf1594b628b182f9ef591089da9324d134b352a0cd3999748bf52b42a260421f08f128a8b61c9f89f70ef11c6c3bc92786c'
'9a869febcdd74e7cb81c4fb5f23d23e6ec70c94e88849fefe6e9c34902de380e5dd3aabced302a5c6b1eab061252b046aa3878caa69893a6240ae14984a0341c')
_goroot='/usr/lib/go'
prepare() {