Rebuild c++utilities/syncthingtray-qt6 against Plasma 6 beta

This commit is contained in:
Martchus 2023-11-30 19:47:37 +01:00
parent d8097abdb4
commit 63b60bd972
5 changed files with 117 additions and 7 deletions

View File

@ -0,0 +1,33 @@
From 35f56d486c7f6c4b110a27476e9114f3e19c0fae Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Thu, 30 Nov 2023 19:44:08 +0100
Subject: [PATCH] Fix enabling AppStream tests
---
cmake/modules/AppUtilities.cmake | 10 ++++++----
1 file changed, 6 insertions(+), 4 deletions(-)
diff --git a/cmake/modules/AppUtilities.cmake b/cmake/modules/AppUtilities.cmake
index 2272431..bd93d92 100644
--- a/cmake/modules/AppUtilities.cmake
+++ b/cmake/modules/AppUtilities.cmake
@@ -86,10 +86,12 @@ function (add_appstream_file)
set(APPSTREAM_TESTS_ENABLED_DEFAULT ON)
endif ()
option(APPSTREAM_TESTS_ENABLED "enables tests for checking whether AppStream files" "${APPSTREAM_TESTS_ENABLED_DEFAULT}")
- if (NOT APPSTREAMCLI_BIN)
- message(FATAL_ERROR "Unable to validate appstreamcli files; appstreamcli not found")
- else ()
- add_test(NAME "${META_TARGET_NAME}_appstream_validation" COMMAND "${APPSTREAMCLI_BIN}" validate "${APPSTREAM_FILE}")
+ if (APPSTREAM_TESTS_ENABLED)
+ if (NOT APPSTREAMCLI_BIN)
+ message(FATAL_ERROR "Unable to validate appstreamcli files; appstreamcli not found")
+ else ()
+ add_test(NAME "${META_TARGET_NAME}_appstream_validation" COMMAND "${APPSTREAMCLI_BIN}" validate "${APPSTREAM_FILE}")
+ endif ()
endif ()
endfunction ()
--
2.43.0

View File

@ -6,7 +6,7 @@
_reponame=cpp-utilities
pkgname=c++utilities
pkgver=5.24.2
pkgrel=2
pkgrel=3
arch=('i686' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
pkgdesc='Common C++ classes and routines such as argument parser, IO and conversion utilities'
license=('GPL')
@ -18,14 +18,16 @@ provides=(libc++utilities.so)
url="https://github.com/Martchus/${_reponame}"
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/Martchus/${_reponame}/archive/v${pkgver}.tar.gz"
0001-Enable-tidy-tests-only-by-default-via-ENABLE_DEVEL_D.patch
0002-Enable-AppStream-tests-only-by-default-via-ENABLE_DE.patch)
0002-Enable-AppStream-tests-only-by-default-via-ENABLE_DE.patch
0001-Fix-enabling-AppStream-tests.patch)
sha256sums=('46e79313900a8cbb7a3c0211fcc0cd07c2c8a6c2bcaeb11aec7fc706dc5914b1'
SKIP SKIP)
SKIP SKIP SKIP)
prepare() {
cd "$srcdir/${PROJECT_DIR_NAME:-$_reponame-$pkgver}"
patch -p1 -i ../0001-Enable-tidy-tests-only-by-default-via-ENABLE_DEVEL_D.patch
patch -p1 -i ../0002-Enable-AppStream-tests-only-by-default-via-ENABLE_DE.patch
patch -p1 -i ../0001-Fix-enabling-AppStream-tests.patch
}
build() {

View File

@ -0,0 +1,42 @@
From ddbd6f309b3a353c9c40c71cd0877f6db6b680c6 Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Thu, 30 Nov 2023 19:55:32 +0100
Subject: [PATCH] Fix building Plasmoid after Plasma 6 beta release
---
plasmoid/CMakeLists.txt | 2 +-
plasmoid/lib/CMakeLists.txt | 4 +++-
2 files changed, 4 insertions(+), 2 deletions(-)
diff --git a/plasmoid/CMakeLists.txt b/plasmoid/CMakeLists.txt
index e1eeaa4..18196ed 100644
--- a/plasmoid/CMakeLists.txt
+++ b/plasmoid/CMakeLists.txt
@@ -12,7 +12,7 @@ set(META_QT5_VERSION 5.8)
set(META_SRCDIR_REFS "${CMAKE_CURRENT_SOURCE_DIR}\n${CMAKE_CURRENT_SOURCE_DIR}/../syncthingconnector")
# find Plasma and its dependencies (which are not pulled-in automatically as of Plasma 6)
-find_package(${KF_PACKAGE_PREFIX}Plasma REQUIRED)
+find_package(Plasma REQUIRED)
if (KF_MAJOR_VERSION GREATER_EQUAL 6)
find_package(${QT_PACKAGE_PREFIX}Qml REQUIRED)
find_package(${KF_PACKAGE_PREFIX}Config REQUIRED)
diff --git a/plasmoid/lib/CMakeLists.txt b/plasmoid/lib/CMakeLists.txt
index 1c6654a..a757cc4 100644
--- a/plasmoid/lib/CMakeLists.txt
+++ b/plasmoid/lib/CMakeLists.txt
@@ -40,8 +40,10 @@ list(APPEND ADDITIONAL_QT_MODULES Network Qml)
if (KF_MAJOR_VERSION GREATER_EQUAL 6)
set(Config_MODULE_TARGETS ${KF_PACKAGE_PREFIX}::ConfigCore)
list(APPEND ADDITIONAL_KF_MODULES Config)
+ use_package(TARGET_NAME Plasma::Plasma PACKAGE_NAME Plasma PACKAGE_ARGS REQUIRED)
+else ()
+ list(APPEND ADDITIONAL_KF_MODULES Plasma)
endif ()
-list(APPEND ADDITIONAL_KF_MODULES Plasma)
include(BasicConfig)
include(QtGuiConfig)
--
2.43.0

View File

@ -0,0 +1,29 @@
From eaf8d6d1647a55fea2f76185544799b891aa16a5 Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Sun, 26 Nov 2023 17:06:06 +0100
Subject: [PATCH] Mention PLASMA_ENABLE_QML_DEBUG in the Plasmoid testing docs
This variable might be useful and now seems to be supported by
`plasmawindowed`, see
https://invent.kde.org/plasma/plasma-workspace/-/merge_requests/3237.
---
plasmoid/testing.md | 3 +++
1 file changed, 3 insertions(+)
diff --git a/plasmoid/testing.md b/plasmoid/testing.md
index f80aa66..361e31d 100644
--- a/plasmoid/testing.md
+++ b/plasmoid/testing.md
@@ -48,6 +48,9 @@ It works quite well within a Plasma session when both shells are placed on diffe
edges.
## Enable QML debugging
+It is not clear whether the following instructions are still valid for Plasma 6.
+It seems that QML debugging can be enabled under Plasma 6 by setting the environment variable
+`PLASMA_ENABLE_QML_DEBUG` but this has not been tested yet.
To enable QML debugging, it is required to rebuild `plasmoidviewer` with QML debugging
enabled.
--
2.43.0

View File

@ -27,7 +27,7 @@ _cfg=qt6
pkgname=syncthingtray-$_cfg
_name=${pkgname%-$_cfg}
pkgver=1.4.9
pkgrel=2
pkgrel=3
arch=('i686' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
pkgdesc='Tray application for Syncthing (using Qt 6)'
license=('GPL')
@ -43,12 +43,14 @@ depends=('libqtutilities-qt6.so' 'libqtforkawesome-qt6.so' 'libc++utilities.so'
makedepends=('cmake' 'ninja' 'qt6-tools' 'qt6-declarative' 'clang' 'boost')
checkdepends=('cppunit' 'syncthing' 'iproute2')
[[ $_enable_kio_plugin ]] && makedepends+=('kio')
[[ $_enable_plasmoid ]] && makedepends+=('plasma-framework' 'extra-cmake-modules')
[[ $_enable_plasmoid ]] && makedepends+=('libplasma' 'extra-cmake-modules')
url="https://github.com/Martchus/${_reponame}"
source=("${_name}-${pkgver}.tar.gz::https://github.com/Martchus/${_reponame}/archive/v${pkgver}.tar.gz"
0001-Fix-install-path-of-KIO-plugin.patch)
0001-Fix-install-path-of-KIO-plugin.patch
0001-Mention-PLASMA_ENABLE_QML_DEBUG-in-the-Plasmoid-test.patch
0001-Fix-building-Plasmoid-after-Plasma-6-beta-release.patch)
sha256sums=('f9003bbe185d355f9cac18862077fa2cc4e809f7f416d9b1dd5ef6474c926742'
SKIP)
SKIP SKIP SKIP)
ephemeral_port() {
comm -23 <(seq 49152 65535) <(ss -tan | awk '{print $4}' | cut -d':' -f2 | grep "[0-9]\{1,5\}" | sort | uniq) | shuf | head -n 1
@ -57,6 +59,8 @@ ephemeral_port() {
prepare() {
cd "$srcdir/${PROJECT_DIR_NAME:-$_reponame-$pkgver}"
patch -p1 -i ../0001-Fix-install-path-of-KIO-plugin.patch
patch -p1 -i ../0001-Mention-PLASMA_ENABLE_QML_DEBUG-in-the-Plasmoid-test.patch
patch -p1 -i ../0001-Fix-building-Plasmoid-after-Plasma-6-beta-release.patch
}
build() {