Update vlc-nightly to rebuild against protobuf 3.6.0

This commit is contained in:
Martchus 2018-07-29 22:42:51 +02:00
parent 58d49a7234
commit 9a5d4f083c
4 changed files with 502 additions and 284 deletions

View File

@ -1,4 +1,4 @@
From 4d5b19c96894ffe2fd699838b08d91f4ed11a552 Mon Sep 17 00:00:00 2001
From 8dc6dcc3c79aef64cc6aa50cbcd769503d9e5b1b Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Sat, 24 Feb 2018 01:32:40 +0100
Subject: [PATCH 1/3] lua: Fix build using lua 5.3
@ -20,5 +20,5 @@ index 71f381d334..b46b5f67a1 100644
#include <lua.h> /* Low level lua C API */
#include <lauxlib.h> /* Higher level C API */
--
2.17.0
2.18.0

View File

@ -1,299 +1,517 @@
From 1424be0fc4a3239273d77005f4e126f52208a322 Mon Sep 17 00:00:00 2001
From aa5123d83c6d2a9eaa01be74b3f14eb817da2213 Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Sun, 11 Mar 2018 20:23:42 +0100
Subject: [PATCH 2/3] Fix compatibility with OpenCV 3.4.1
---
modules/video_filter/Makefile.am | 2 +-
modules/video_filter/opencv_example.cpp | 4 +-
.../{opencv_wrapper.c => opencv_wrapper.cpp} | 113 +++++++++---------
po/POTFILES.in | 2 +-
4 files changed, 62 insertions(+), 59 deletions(-)
rename modules/video_filter/{opencv_wrapper.c => opencv_wrapper.cpp} (82%)
modules/video_filter/Makefile.am | 7 -
modules/video_filter/opencv_wrapper.c | 466 --------------------------
po/POTFILES.in | 1 -
3 files changed, 474 deletions(-)
delete mode 100644 modules/video_filter/opencv_wrapper.c
diff --git a/modules/video_filter/Makefile.am b/modules/video_filter/Makefile.am
index af190d16e3..d1703a7ed3 100644
index af190d16e3..fbfcdf8a30 100644
--- a/modules/video_filter/Makefile.am
+++ b/modules/video_filter/Makefile.am
@@ -147,7 +147,7 @@ endif
@@ -147,13 +147,6 @@ endif
libdeinterlace_plugin_la_LIBADD = libdeinterlace_common.la
video_filter_LTLIBRARIES += libdeinterlace_plugin.la
-libopencv_wrapper_plugin_la_SOURCES = video_filter/opencv_wrapper.c
+libopencv_wrapper_plugin_la_SOURCES = video_filter/opencv_wrapper.cpp
libopencv_wrapper_plugin_la_CPPFLAGS = $(AM_CPPFLAGS) $(OPENCV_CFLAGS)
libopencv_wrapper_plugin_la_LIBADD = $(OPENCV_LIBS)
libopencv_wrapper_plugin_la_LDFLAGS = $(AM_LDFLAGS) -rpath '$(video_filterdir)'
diff --git a/modules/video_filter/opencv_example.cpp b/modules/video_filter/opencv_example.cpp
index a7a0bd7821..119c40d3fc 100644
--- a/modules/video_filter/opencv_example.cpp
+++ b/modules/video_filter/opencv_example.cpp
@@ -129,7 +129,7 @@ static int OpenFilter( vlc_object_t *p_this )
static void CloseFilter( vlc_object_t *p_this )
{
filter_t *p_filter = (filter_t*)p_this;
- filter_sys_t *p_sys = p_filter->p_sys;
+ filter_sys_t *p_sys = reinterpret_cast<filter_sys_t *>(p_filter->p_sys);
if( p_sys->p_cascade )
cvReleaseHaarClassifierCascade( &p_sys->p_cascade );
@@ -151,7 +151,7 @@ static picture_t *Filter( filter_t *p_filter, picture_t *p_pic )
IplImage** p_img = NULL;
CvPoint pt1, pt2;
int scale = 1;
- filter_sys_t *p_sys = p_filter->p_sys;
+ filter_sys_t *p_sys = reinterpret_cast<filter_sys_t *>(p_filter->p_sys);
if ((!p_pic) )
{
diff --git a/modules/video_filter/opencv_wrapper.c b/modules/video_filter/opencv_wrapper.cpp
similarity index 82%
rename from modules/video_filter/opencv_wrapper.c
rename to modules/video_filter/opencv_wrapper.cpp
index ed48fe1f67..dade9b2f6c 100644
-libopencv_wrapper_plugin_la_CPPFLAGS = $(AM_CPPFLAGS) $(OPENCV_CFLAGS)
-libopencv_wrapper_plugin_la_LIBADD = $(OPENCV_LIBS)
-libopencv_wrapper_plugin_la_LDFLAGS = $(AM_LDFLAGS) -rpath '$(video_filterdir)'
-video_filter_LTLIBRARIES += $(LTLIBopencv_wrapper)
-EXTRA_LTLIBRARIES += libopencv_wrapper_plugin.la
-
libpostproc_plugin_la_SOURCES = video_filter/postproc.c
libpostproc_plugin_la_CPPFLAGS = $(AM_CPPFLAGS) $(POSTPROC_CFLAGS) $(AVUTIL_CFLAGS)
libpostproc_plugin_la_LIBADD = $(LIBM) $(POSTPROC_LIBS) $(AVUTIL_LIBS)
diff --git a/modules/video_filter/opencv_wrapper.c b/modules/video_filter/opencv_wrapper.c
deleted file mode 100644
index f8710119f2..0000000000
--- a/modules/video_filter/opencv_wrapper.c
+++ b/modules/video_filter/opencv_wrapper.cpp
@@ -154,7 +154,7 @@ static int Create( vlc_object_t *p_this )
char *psz_chroma, *psz_output;
/* Allocate structure */
- p_filter->p_sys = malloc( sizeof( filter_sys_t ) );
+ p_filter->p_sys = reinterpret_cast<filter_sys_t*>( malloc( sizeof( filter_sys_t ) ) );
if( p_filter->p_sys == NULL )
return VLC_ENOMEM;
@@ -167,39 +167,40 @@ static int Create( vlc_object_t *p_this )
* We don't need to set up video formats for this filter as it not
* actually using a picture_t.
*/
- p_filter->p_sys->p_opencv = vlc_object_create( p_filter, sizeof(filter_t) );
- if( !p_filter->p_sys->p_opencv ) {
+ auto *p_filter_sys = reinterpret_cast<filter_sys_t*>(p_filter->p_sys);
+ p_filter_sys->p_opencv = reinterpret_cast<filter_t*>( vlc_object_create( p_filter, sizeof(filter_t) ) );
+ if( !p_filter_sys->p_opencv ) {
free( p_filter->p_sys );
return VLC_ENOMEM;
}
- p_filter->p_sys->psz_inner_name = var_InheritString( p_filter, "opencv-filter-name" );
- if( p_filter->p_sys->psz_inner_name )
- p_filter->p_sys->p_opencv->p_module =
- module_need( p_filter->p_sys->p_opencv,
+ p_filter_sys->psz_inner_name = var_InheritString( p_filter, "opencv-filter-name" );
+ if( p_filter_sys->psz_inner_name )
+ p_filter_sys->p_opencv->p_module =
+ module_need( p_filter_sys->p_opencv,
"opencv internal filter",
- p_filter->p_sys->psz_inner_name,
+ p_filter_sys->psz_inner_name,
true );
- if( !p_filter->p_sys->p_opencv->p_module )
+ if( !p_filter_sys->p_opencv->p_module )
{
- msg_Err( p_filter, "can't open internal opencv filter: %s", p_filter->p_sys->psz_inner_name );
- free( p_filter->p_sys->psz_inner_name );
- p_filter->p_sys->psz_inner_name = NULL;
- vlc_object_release( p_filter->p_sys->p_opencv );
- free( p_filter->p_sys );
+ msg_Err( p_filter, "can't open internal opencv filter: %s", p_filter_sys->psz_inner_name );
+ free( p_filter_sys->psz_inner_name );
+ p_filter_sys->psz_inner_name = NULL;
+ vlc_object_release( p_filter_sys->p_opencv );
+ free( p_filter_sys );
return VLC_ENOMOD;
}
/* Init structure */
- p_filter->p_sys->p_image = image_HandlerCreate( p_filter );
+ p_filter_sys->p_image = image_HandlerCreate( p_filter );
for( int i = 0; i < VOUT_MAX_PLANES; i++ )
- p_filter->p_sys->p_cv_image[i] = NULL;
- p_filter->p_sys->p_proc_image = NULL;
- p_filter->p_sys->p_to_be_freed = NULL;
- p_filter->p_sys->i_cv_image_size = 0;
+ p_filter_sys->p_cv_image[i] = NULL;
+ p_filter_sys->p_proc_image = NULL;
+ p_filter_sys->p_to_be_freed = NULL;
+ p_filter_sys->i_cv_image_size = 0;
/* Retrieve and apply config */
psz_chroma = var_InheritString( p_filter, "opencv-chroma" );
@@ -207,16 +208,16 @@ static int Create( vlc_object_t *p_this )
{
msg_Err( p_filter, "configuration variable %s empty, using 'grey'",
"opencv-chroma" );
- p_filter->p_sys->i_internal_chroma = GREY;
+ p_filter_sys->i_internal_chroma = GREY;
} else if( !strcmp( psz_chroma, "input" ) )
- p_filter->p_sys->i_internal_chroma = CINPUT;
+ p_filter_sys->i_internal_chroma = CINPUT;
else if( !strcmp( psz_chroma, "I420" ) )
- p_filter->p_sys->i_internal_chroma = GREY;
+ p_filter_sys->i_internal_chroma = GREY;
else if( !strcmp( psz_chroma, "RGB32" ) )
- p_filter->p_sys->i_internal_chroma = RGB;
+ p_filter_sys->i_internal_chroma = RGB;
else {
msg_Err( p_filter, "no valid opencv-chroma provided, using 'grey'" );
- p_filter->p_sys->i_internal_chroma = GREY;
+ p_filter_sys->i_internal_chroma = GREY;
}
free( psz_chroma );
@@ -226,28 +227,28 @@ static int Create( vlc_object_t *p_this )
{
msg_Err( p_filter, "configuration variable %s empty, using 'input'",
"opencv-output" );
- p_filter->p_sys->i_wrapper_output = VINPUT;
+ p_filter_sys->i_wrapper_output = VINPUT;
} else if( !strcmp( psz_output, "none" ) )
- p_filter->p_sys->i_wrapper_output = NONE;
+ p_filter_sys->i_wrapper_output = NONE;
else if( !strcmp( psz_output, "input" ) )
- p_filter->p_sys->i_wrapper_output = VINPUT;
+ p_filter_sys->i_wrapper_output = VINPUT;
else if( !strcmp( psz_output, "processed" ) )
- p_filter->p_sys->i_wrapper_output = PROCESSED;
+ p_filter_sys->i_wrapper_output = PROCESSED;
else {
msg_Err( p_filter, "no valid opencv-output provided, using 'input'" );
- p_filter->p_sys->i_wrapper_output = VINPUT;
+ p_filter_sys->i_wrapper_output = VINPUT;
}
free( psz_output );
- p_filter->p_sys->f_scale =
+ p_filter_sys->f_scale =
var_InheritFloat( p_filter, "opencv-scale" );
msg_Info(p_filter, "Configuration: opencv-scale: %f, opencv-chroma: %d, "
"opencv-output: %d, opencv-filter %s",
- p_filter->p_sys->f_scale,
- p_filter->p_sys->i_internal_chroma,
- p_filter->p_sys->i_wrapper_output,
- p_filter->p_sys->psz_inner_name);
+ p_filter_sys->f_scale,
+ p_filter_sys->i_internal_chroma,
+ p_filter_sys->i_wrapper_output,
+ p_filter_sys->psz_inner_name);
#ifndef NDEBUG
msg_Dbg( p_filter, "opencv_wrapper successfully started" );
@@ -269,11 +270,12 @@ static void Destroy( vlc_object_t *p_this )
ReleaseImages( p_filter );
// Release the internal OpenCV filter.
- module_unneed( p_filter->p_sys->p_opencv, p_filter->p_sys->p_opencv->p_module );
- vlc_object_release( p_filter->p_sys->p_opencv );
- p_filter->p_sys->p_opencv = NULL;
+ auto *p_filter_sys = reinterpret_cast<filter_sys_t*>(p_filter->p_sys);
+ module_unneed( p_filter_sys->p_opencv, p_filter_sys->p_opencv->p_module );
+ vlc_object_release( p_filter_sys->p_opencv );
+ p_filter_sys->p_opencv = NULL;
- free( p_filter->p_sys );
+ free( p_filter_sys );
}
/*****************************************************************************
@@ -281,7 +283,7 @@ static void Destroy( vlc_object_t *p_this )
*****************************************************************************/
static void ReleaseImages( filter_t* p_filter )
{
+++ /dev/null
@@ -1,466 +0,0 @@
-/*****************************************************************************
- * opencv_wrapper.c : OpenCV wrapper video filter
- *****************************************************************************
- * Copyright (C) 2006-2012 VLC authors and VideoLAN
- * Copyright (C) 2012 Edward Wang
- *
- * Authors: Dugal Harris <dugalh@protoclea.co.za>
- * Edward Wang <edward.c.wang@compdigitec.com>
- *
- * This program is free software; you can redistribute it and/or modify it
- * under the terms of the GNU Lesser General Public License as published by
- * the Free Software Foundation; either version 2.1 of the License, or
- * (at your option) any later version.
- *
- * This program is distributed in the hope that it will be useful,
- * but WITHOUT ANY WARRANTY; without even the implied warranty of
- * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- * GNU Lesser General Public License for more details.
- *
- * You should have received a copy of the GNU Lesser General Public License
- * along with this program; if not, write to the Free Software Foundation,
- * Inc., 51 Franklin Street, Fifth Floor, Boston MA 02110-1301, USA.
- *****************************************************************************/
-
-/*****************************************************************************
- * Preamble
- *****************************************************************************/
-
-#ifdef HAVE_CONFIG_H
-# include "config.h"
-#endif
-
-#include <vlc_common.h>
-#include <vlc_plugin.h>
-#include <vlc_vout.h>
-#include <vlc_modules.h>
-#include <vlc_picture.h>
-#include <vlc_filter.h>
-#include <vlc_image.h>
-#include "filter_picture.h"
-
-#include <opencv2/core/core_c.h>
-#include <opencv2/core/types_c.h>
-
-/*****************************************************************************
- * Local prototypes
- *****************************************************************************/
-static int Create ( vlc_object_t * );
-static void Destroy ( vlc_object_t * );
-
-static picture_t* Filter( filter_t*, picture_t* );
-
-static void ReleaseImages( filter_t* p_filter );
-static void VlcPictureToIplImage( filter_t* p_filter, picture_t* p_in );
-
-/*****************************************************************************
- * Module descriptor
- *****************************************************************************/
-
-static const char *const chroma_list[] = { "input", "I420", "RGB32"};
-static const char *const chroma_list_text[] = { N_("Use input chroma unaltered"),
- N_("I420 - first plane is grayscale"), N_("RGB32")};
-
-static const char *const output_list[] = { "none", "input", "processed"};
-static const char *const output_list_text[] = { N_("Don't display any video"),
- N_("Display the input video"), N_("Display the processed video")};
-
-vlc_module_begin ()
- set_description( N_("OpenCV video filter wrapper") )
- set_shortname( N_("OpenCV" ))
- set_category( CAT_VIDEO )
- set_subcategory( SUBCAT_VIDEO_VFILTER )
- set_capability( "video filter", 0 )
- add_shortcut( "opencv_wrapper" )
- set_callbacks( Create, Destroy )
- add_float_with_range( "opencv-scale", 1.0, 0.1, 2.0,
- N_("Scale factor (0.1-2.0)"),
- N_("Amount by which to scale the picture before sending it to the internal OpenCV filter"),
- false )
- add_string( "opencv-chroma", "input",
- N_("OpenCV filter chroma"),
- N_("Chroma to convert picture to before sending it to the internal OpenCV filter"), false);
- change_string_list( chroma_list, chroma_list_text )
- add_string( "opencv-output", "input",
- N_("Wrapper filter output"),
- N_("Determines what (if any) video is displayed by the wrapper filter"), false);
- change_string_list( output_list, output_list_text )
- add_string( "opencv-filter-name", "none",
- N_("OpenCV internal filter name"),
- N_("Name of internal OpenCV plugin filter to use"), false);
-vlc_module_end ()
-
-
-/*****************************************************************************
- * wrapper_output_t: what video is output
- *****************************************************************************/
-enum wrapper_output_t
-{
- NONE,
- VINPUT,
- PROCESSED
-};
-
-/*****************************************************************************
- * internal_chroma_t: what chroma is sent to the internal opencv filter
- *****************************************************************************/
-enum internal_chroma_t
-{
- CINPUT,
- GREY,
- RGB
-};
-
-/*****************************************************************************
- * filter_sys_t: opencv_wrapper video output method descriptor
- *****************************************************************************
- * This structure is part of the video output thread descriptor.
- * It describes the opencv_wrapper specific properties of an output thread.
- *****************************************************************************/
-typedef struct
-{
- image_handler_t *p_image;
-
- int i_cv_image_size;
-
- picture_t *p_proc_image;
- picture_t *p_to_be_freed;
-
- float f_scale;
-
- int i_wrapper_output;
- int i_internal_chroma;
-
- IplImage *p_cv_image[VOUT_MAX_PLANES];
-
- filter_t *p_opencv;
- char* psz_inner_name;
-
- picture_t hacked_pic;
-} filter_sys_t;
-
-/*****************************************************************************
- * Create: allocates opencv_wrapper video thread output method
- *****************************************************************************
- * This function allocates and initializes a opencv_wrapper vout method.
- *****************************************************************************/
-static int Create( vlc_object_t *p_this )
-{
- filter_t* p_filter = (filter_t*)p_this;
- filter_sys_t *p_sys;
- char *psz_chroma, *psz_output;
-
- /* Allocate structure */
- p_sys = malloc( sizeof( filter_sys_t ) );
- if( p_sys == NULL )
- return VLC_ENOMEM;
-
- /* Load the internal OpenCV filter.
- *
- * This filter object is needed to call the internal OpenCV filter
- * for processing, the wrapper just converts into an IplImage* for
- * the other filter.
- *
- * We don't need to set up video formats for this filter as it not
- * actually using a picture_t.
- */
- p_sys->p_opencv = vlc_object_create( p_filter, sizeof(filter_t) );
- if( !p_sys->p_opencv ) {
- free( p_sys );
- return VLC_ENOMEM;
- }
-
- p_sys->psz_inner_name = var_InheritString( p_filter, "opencv-filter-name" );
- if( p_sys->psz_inner_name )
- p_sys->p_opencv->p_module =
- module_need( p_sys->p_opencv,
- "opencv internal filter",
- p_sys->psz_inner_name,
- true );
-
- if( !p_sys->p_opencv->p_module )
- {
- msg_Err( p_filter, "can't open internal opencv filter: %s", p_sys->psz_inner_name );
- free( p_sys->psz_inner_name );
- vlc_object_release( p_sys->p_opencv );
- free( p_sys );
-
- return VLC_ENOMOD;
- }
-
-
- /* Init structure */
- p_sys->p_image = image_HandlerCreate( p_filter );
- for( int i = 0; i < VOUT_MAX_PLANES; i++ )
- p_sys->p_cv_image[i] = NULL;
- p_sys->p_proc_image = NULL;
- p_sys->p_to_be_freed = NULL;
- p_sys->i_cv_image_size = 0;
-
- /* Retrieve and apply config */
- psz_chroma = var_InheritString( p_filter, "opencv-chroma" );
- if( psz_chroma == NULL )
- {
- msg_Err( p_filter, "configuration variable %s empty, using 'grey'",
- "opencv-chroma" );
- p_sys->i_internal_chroma = GREY;
- } else if( !strcmp( psz_chroma, "input" ) )
- p_sys->i_internal_chroma = CINPUT;
- else if( !strcmp( psz_chroma, "I420" ) )
- p_sys->i_internal_chroma = GREY;
- else if( !strcmp( psz_chroma, "RGB32" ) )
- p_sys->i_internal_chroma = RGB;
- else {
- msg_Err( p_filter, "no valid opencv-chroma provided, using 'grey'" );
- p_sys->i_internal_chroma = GREY;
- }
-
- free( psz_chroma );
-
- psz_output = var_InheritString( p_filter, "opencv-output" );
- if( psz_output == NULL )
- {
- msg_Err( p_filter, "configuration variable %s empty, using 'input'",
- "opencv-output" );
- p_sys->i_wrapper_output = VINPUT;
- } else if( !strcmp( psz_output, "none" ) )
- p_sys->i_wrapper_output = NONE;
- else if( !strcmp( psz_output, "input" ) )
- p_sys->i_wrapper_output = VINPUT;
- else if( !strcmp( psz_output, "processed" ) )
- p_sys->i_wrapper_output = PROCESSED;
- else {
- msg_Err( p_filter, "no valid opencv-output provided, using 'input'" );
- p_sys->i_wrapper_output = VINPUT;
- }
- free( psz_output );
-
- p_sys->f_scale =
- var_InheritFloat( p_filter, "opencv-scale" );
-
- msg_Info(p_filter, "Configuration: opencv-scale: %f, opencv-chroma: %d, "
- "opencv-output: %d, opencv-filter %s",
- p_sys->f_scale,
- p_sys->i_internal_chroma,
- p_sys->i_wrapper_output,
- p_sys->psz_inner_name);
-
-#ifndef NDEBUG
- msg_Dbg( p_filter, "opencv_wrapper successfully started" );
-#endif
-
- p_filter->p_sys = p_sys;
- p_filter->pf_video_filter = Filter;
-
- return VLC_SUCCESS;
-}
-
-/*****************************************************************************
- * Destroy: destroy opencv_wrapper video thread output method
- *****************************************************************************
- * Terminate an output method created by opencv_wrapperCreateOutputMethod
- *****************************************************************************/
-static void Destroy( vlc_object_t *p_this )
-{
- filter_t* p_filter = (filter_t*)p_this;
- filter_sys_t *p_sys = p_filter->p_sys;
- ReleaseImages( p_filter );
-
- // Release the internal OpenCV filter.
- module_unneed( p_sys->p_opencv, p_sys->p_opencv->p_module );
- vlc_object_release( p_sys->p_opencv );
-
- free( p_sys );
-}
-
-/*****************************************************************************
- * ReleaseImages: Release OpenCV images in filter_sys_t.
- *****************************************************************************/
-static void ReleaseImages( filter_t* p_filter )
-{
- filter_sys_t* p_sys = p_filter->p_sys;
+ filter_sys_t* p_sys = reinterpret_cast<filter_sys_t*>(p_filter->p_sys);
for( int i = 0; i < VOUT_MAX_PLANES; i++ )
{
@@ -315,9 +317,9 @@ static void VlcPictureToIplImage( filter_t* p_filter, picture_t* p_in )
{
int planes = p_in->i_planes; //num input video planes
// input video size
- CvSize sz = cvSize(abs(p_in->format.i_width), abs(p_in->format.i_height));
+ CvSize sz = cvSize(abs(static_cast<int>(p_in->format.i_width)), abs(static_cast<int>(p_in->format.i_height)));
video_format_t fmt_out;
-
- for( int i = 0; i < VOUT_MAX_PLANES; i++ )
- {
- if (p_sys->p_cv_image[i] != NULL)
- {
- cvReleaseImageHeader(&(p_sys->p_cv_image[i]));
- p_sys->p_cv_image[i] = NULL;
- }
- }
- p_sys->i_cv_image_size = 0;
-
- /* Release temp picture_t if it exists */
- if (p_sys->p_to_be_freed)
- {
- picture_Release( p_sys->p_to_be_freed );
- p_sys->p_to_be_freed = NULL;
- }
-
-#ifndef NDEBUG
- msg_Dbg( p_filter, "images released" );
-#endif
-}
-
-/*****************************************************************************
- * VlcPictureToIplImage: Convert picture_t to IplImage
- *****************************************************************************
- * Converts given picture_t into IplImage(s) according to module config.
- * IplImage(s) are stored in vout_sys_t.
- *****************************************************************************/
-static void VlcPictureToIplImage( filter_t* p_filter, picture_t* p_in )
-{
- int planes = p_in->i_planes; //num input video planes
- // input video size
- CvSize sz = cvSize(p_in->format.i_width, p_in->format.i_height);
- video_format_t fmt_out;
- filter_sys_t* p_sys = p_filter->p_sys;
+ filter_sys_t* p_sys = reinterpret_cast<filter_sys_t*>(p_filter->p_sys);
memset( &fmt_out, 0, sizeof(video_format_t) );
@@ -413,20 +415,21 @@ static picture_t* Filter( filter_t* p_filter, picture_t* p_pic )
video_format_t fmt_out;
// Make a copy if we want to show the original input
- if (p_filter->p_sys->i_wrapper_output == VINPUT)
+ auto *p_filter_sys = reinterpret_cast<filter_sys_t*>(p_filter->p_sys);
+ if (p_filter_sys->i_wrapper_output == VINPUT)
picture_Copy( p_outpic, p_pic );
VlcPictureToIplImage( p_filter, p_pic );
// Pass the image (as a pointer to the first IplImage*) to the
// internal OpenCV filter for processing.
- p_filter->p_sys->p_opencv->pf_video_filter( p_filter->p_sys->p_opencv, (picture_t*)&(p_filter->p_sys->p_cv_image[0]) );
+ p_filter_sys->p_opencv->pf_video_filter( p_filter_sys->p_opencv, (picture_t*)&(p_filter_sys->p_cv_image[0]) );
- if(p_filter->p_sys->i_wrapper_output == PROCESSED) {
+ if(p_filter_sys->i_wrapper_output == PROCESSED) {
// Processed video
- if( (p_filter->p_sys->p_proc_image) &&
- (p_filter->p_sys->p_proc_image->i_planes > 0) &&
- (p_filter->p_sys->i_internal_chroma != CINPUT) ) {
- //p_filter->p_sys->p_proc_image->format.i_chroma = VLC_CODEC_RGB24;
+ if( (p_filter_sys->p_proc_image) &&
+ (p_filter_sys->p_proc_image->i_planes > 0) &&
+ (p_filter_sys->i_internal_chroma != CINPUT) ) {
+ //p_filter_sys->p_proc_image->format.i_chroma = VLC_CODEC_RGB24;
memset( &fmt_out, 0, sizeof(video_format_t) );
fmt_out = p_pic->format;
@@ -438,16 +441,16 @@ static picture_t* Filter( filter_t* p_filter, picture_t* p_pic )
* main video output error: pictures leaked, trying to workaround
*/
picture_t* p_outpic_tmp = image_Convert(
- p_filter->p_sys->p_image,
- p_filter->p_sys->p_proc_image,
- &(p_filter->p_sys->p_proc_image->format),
+ p_filter_sys->p_image,
+ p_filter_sys->p_proc_image,
+ &(p_filter_sys->p_proc_image->format),
&fmt_out );
picture_CopyPixels( p_outpic, p_outpic_tmp );
CopyInfoAndRelease( p_outpic, p_outpic_tmp );
- } else if( p_filter->p_sys->i_internal_chroma == CINPUT ) {
- picture_CopyPixels( p_outpic, p_filter->p_sys->p_proc_image );
- picture_CopyProperties( p_outpic, p_filter->p_sys->p_proc_image );
+ } else if( p_filter_sys->i_internal_chroma == CINPUT ) {
+ picture_CopyPixels( p_outpic, p_filter_sys->p_proc_image );
+ picture_CopyProperties( p_outpic, p_filter_sys->p_proc_image );
}
}
@@ -458,7 +461,7 @@ static picture_t* Filter( filter_t* p_filter, picture_t* p_pic )
msg_Dbg( p_filter, "Filter() done" );
#endif
- if( p_filter->p_sys->i_wrapper_output != NONE ) {
+ if( p_filter_sys->i_wrapper_output != NONE ) {
return p_outpic;
} else { // NONE
picture_Release( p_outpic );
-
- memset( &fmt_out, 0, sizeof(video_format_t) );
-
- //do scale / color conversion according to p_sys config
- if ((p_sys->f_scale != 1) || (p_sys->i_internal_chroma != CINPUT))
- {
- fmt_out = p_in->format;
-
- //calc the scaled video size
- fmt_out.i_width = p_in->format.i_width * p_sys->f_scale;
- fmt_out.i_height = p_in->format.i_height * p_sys->f_scale;
-
- if (p_sys->i_internal_chroma == RGB)
- {
- //rgb2 gives 3 separate planes, this gives 1 interleaved plane
- //rv24 gives is about 20% faster but gives r&b the wrong way round
- //and I can't think of an easy way to fix this
- fmt_out.i_chroma = VLC_CODEC_RGB24;
- }
- else if (p_sys->i_internal_chroma == GREY)
- {
- //take the I (gray) plane (video seems to commonly be in this fmt so usually the
- //conversion does nothing)
- fmt_out.i_chroma = VLC_CODEC_I420;
- }
-
- //convert from the input image
- p_sys->p_proc_image = image_Convert( p_sys->p_image, p_in,
- &(p_in->format), &fmt_out );
-
- if (!p_sys->p_proc_image)
- {
- msg_Err(p_filter, "can't convert (unsupported formats?), aborting...");
- return;
- }
-
- p_sys->p_to_be_freed = p_sys->p_proc_image; //remember this so we can free it later
-
- }
- else //((p_sys->f_scale != 1) || (p_sys->i_internal_chroma != CINPUT))
- {
- // In theory, you could use the input image without conversion,
- // but it seems to cause weird picture effects (like repeated
- // image filtering) and picture leaking.
- p_sys->p_proc_image = filter_NewPicture( p_filter ); //p_in
- picture_Copy( p_sys->p_proc_image, p_in );
- p_sys->p_to_be_freed = p_sys->p_proc_image;
- }
-
- //Convert to the IplImage array that is to be processed.
- //If there are multiple planes in p_sys->p_proc_image, then 1 IplImage
- //is created for each plane.
- planes = p_sys->p_proc_image->i_planes;
- p_sys->i_cv_image_size = planes;
- for( int i = 0; i < planes; i++ )
- {
- sz = cvSize(abs(p_sys->p_proc_image->p[i].i_visible_pitch /
- p_sys->p_proc_image->p[i].i_pixel_pitch),
- abs(p_sys->p_proc_image->p[i].i_visible_lines));
-
- p_sys->p_cv_image[i] = cvCreateImageHeader(sz, IPL_DEPTH_8U,
- p_sys->p_proc_image->p[i].i_pixel_pitch);
-
- cvSetData( p_sys->p_cv_image[i],
- (char*)(p_sys->p_proc_image->p[i].p_pixels), p_sys->p_proc_image->p[i].i_pitch );
- }
-
- //Hack the above opencv image array into a picture_t so that it can be sent to
- //another video filter
- p_sys->hacked_pic.i_planes = planes;
- p_sys->hacked_pic.format.i_chroma = fmt_out.i_chroma;
-
-#ifndef NDEBUG
- msg_Dbg( p_filter, "VlcPictureToIplImageRgb() completed" );
-#endif
-}
-
-/*****************************************************************************
- * Filter: displays previously rendered output
- *****************************************************************************
- * This function send the currently rendered image to the internal opencv
- * filter for processing.
- *****************************************************************************/
-static picture_t* Filter( filter_t* p_filter, picture_t* p_pic )
-{
- filter_sys_t *p_sys = p_filter->p_sys;
- picture_t* p_outpic = filter_NewPicture( p_filter );
- if( p_outpic == NULL ) {
- msg_Err( p_filter, "couldn't get a p_outpic!" );
- picture_Release( p_pic );
- return NULL;
- }
-
- video_format_t fmt_out;
-
- // Make a copy if we want to show the original input
- if (p_sys->i_wrapper_output == VINPUT)
- picture_Copy( p_outpic, p_pic );
-
- VlcPictureToIplImage( p_filter, p_pic );
- // Pass the image (as a pointer to the first IplImage*) to the
- // internal OpenCV filter for processing.
- p_sys->p_opencv->pf_video_filter( p_sys->p_opencv, (picture_t*)&(p_sys->p_cv_image[0]) );
-
- if(p_sys->i_wrapper_output == PROCESSED) {
- // Processed video
- if( (p_sys->p_proc_image) &&
- (p_sys->p_proc_image->i_planes > 0) &&
- (p_sys->i_internal_chroma != CINPUT) ) {
- //p_sys->p_proc_image->format.i_chroma = VLC_CODEC_RGB24;
-
- memset( &fmt_out, 0, sizeof(video_format_t) );
- fmt_out = p_pic->format;
- //picture_Release( p_outpic );
-
- /*
- * We have to copy out the image from image_Convert(), otherwise
- * you leak pictures for some reason:
- * main video output error: pictures leaked, trying to workaround
- */
- picture_t* p_outpic_tmp = image_Convert(
- p_sys->p_image,
- p_sys->p_proc_image,
- &(p_sys->p_proc_image->format),
- &fmt_out );
-
- picture_CopyPixels( p_outpic, p_outpic_tmp );
- CopyInfoAndRelease( p_outpic, p_outpic_tmp );
- } else if( p_sys->i_internal_chroma == CINPUT ) {
- picture_CopyPixels( p_outpic, p_sys->p_proc_image );
- picture_CopyProperties( p_outpic, p_sys->p_proc_image );
- }
- }
-
- ReleaseImages( p_filter );
- picture_Release( p_pic );
-
-#ifndef NDEBUG
- msg_Dbg( p_filter, "Filter() done" );
-#endif
-
- if( p_sys->i_wrapper_output != NONE ) {
- return p_outpic;
- } else { // NONE
- picture_Release( p_outpic );
- return NULL;
- }
-}
-
diff --git a/po/POTFILES.in b/po/POTFILES.in
index 665e02002a..82130b14cc 100644
index ab257a3402..ae48b34734 100644
--- a/po/POTFILES.in
+++ b/po/POTFILES.in
@@ -1142,7 +1142,7 @@ modules/video_filter/motionblur.c
@@ -1139,7 +1139,6 @@ modules/video_filter/motionblur.c
modules/video_filter/motiondetect.c
modules/video_filter/oldmovie.c
modules/video_filter/opencv_example.cpp
-modules/video_filter/opencv_wrapper.c
+modules/video_filter/opencv_wrapper.cpp
modules/video_filter/posterize.c
modules/video_filter/postproc.c
modules/video_filter/psychedelic.c
--
2.17.0
2.18.0

View File

@ -1,4 +1,4 @@
From b086eb86b55868d61316996ac346bde57408d5a8 Mon Sep 17 00:00:00 2001
From 2b6384b93e82d4366b96d353804c872ed1137c55 Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Sat, 26 May 2018 15:12:05 +0200
Subject: [PATCH 3/3] Fix compilation with Qt 5.11
@ -8,7 +8,7 @@ Subject: [PATCH 3/3] Fix compilation with Qt 5.11
1 file changed, 1 insertion(+)
diff --git a/modules/gui/qt/components/simple_preferences.cpp b/modules/gui/qt/components/simple_preferences.cpp
index 7a9c2dbf28..afdcf64672 100644
index a6efacdcf5..ade20a9847 100644
--- a/modules/gui/qt/components/simple_preferences.cpp
+++ b/modules/gui/qt/components/simple_preferences.cpp
@@ -33,6 +33,7 @@
@ -20,5 +20,5 @@ index 7a9c2dbf28..afdcf64672 100644
#include <QFont>
#include <QToolButton>
--
2.17.0
2.18.0

View File

@ -5,10 +5,10 @@
_appname_=vlc
pkgname=${_appname_}-nightly
pkgver=4.0.0v20180520
pkgver=4.0.0v20180729
_pkgver=4.0.0
_snapshot_=20180520
_snapver_=0236
_snapshot_=20180729
_snapver_=0245
_suffix_=dev
_nightly_=${_snapshot_}-${_snapver_}
pkgrel=1
@ -139,7 +139,7 @@ build() {
export CFLAGS+=" -I/usr/include/samba-4.0"
export CPPFLAGS+=" -I/usr/include/samba-4.0"
export CXXFLAGS+=" -std=gnu++11"
export CXXFLAGS+=" -std=c++11"
export LUAC=/usr/bin/luac
export LUA_LIBS="`pkg-config --libs lua`"
export RCC=/usr/bin/rcc-qt5
@ -260,9 +260,9 @@ package() {
# depends=("${_detected_depends[@]}" "${_undetected_depends[@]}")
}
sha256sums=('4ff76580ca9fdc349a086ab6d8d2105bc51cb9c766fb488ef4f8ce47d08122dd'
sha256sums=('40ae221dbbf76b99b03b76175b558db88bdbc18c5799e64423b8493394e885d4'
'c6f60c50375ae688755557dbfc5bd4a90a8998f8cf4d356c10d872a1a0b44f3a'
'a9400046090b4713edbae14f50afca0ff36335b69fd0d2d082c35eea35e97c15'
'ca3e7c38a335551fe8b0c8d3e270cca3a6f70ffd06ec82880b26a0f78ac1ea39'
'e64e37f98862aa14077a48ba313e590677f768e82d4cd9b01b194bdf4146bf7d'
'3e6bddbaed443e40036c494a0754aedd2f94fe41bfa3754855e16f7452a03cdf'
'c33461cad1fb725754a80b4dd63eb144dbd9719ac99139f9553089ef09907b0a'
'9ba5fcc11de9ee2a88be3d2eedd1ab45133cb8bed3943c2e11531b45834aa9b2'
'90b0e34d5772d2307ba07a1c2aa715db7488389003cfe6d3570b2a9c63061db7')