Improve static-compat-syncthingtray

* Enable Wayland QPA plugin
* Enable icon themes
* Avoid regular Harfbuzz CMake find module from being used
This commit is contained in:
Martchus 2022-05-01 23:29:10 +02:00
parent 567f591ea0
commit b1dccff4ae
39 changed files with 177 additions and 67 deletions

View File

@ -15,7 +15,7 @@
pkgname=<%= $package_name %>
_qtver=6.3.0
pkgver=${_qtver/-/}
pkgrel=2
pkgrel=3
arch=(x86_64)
url='https://www.qt.io'
license=(GPL3 LGPL3 FDL custom)
@ -88,6 +88,8 @@ build() {
-DQT_FEATURE_dynamicgl=OFF \\
-DQT_FEATURE_opengl_dynamic=OFF \\
-DGLIB2_USE_PKG_CONFIG=ON \\
-DWAYLAND_USE_PKG_CONFIG=ON \\
-DCMAKE_DISABLE_FIND_PACKAGE_harfbuzz=TRUE \\
-DCMAKE_INSTALL_OLDINCLUDEDIR=$static_compat_prefix/include \\
-DGSSAPI_INCLUDE_DIRS=$static_compat_prefix/include \\
-DICU_INCLUDE_DIR=$static_compat_prefix/include \\

View File

@ -42,6 +42,8 @@ build() {
$ccache_args \\
-DCMAKE_SKIP_INSTALL_RPATH=ON \\
-DGLIB2_USE_PKG_CONFIG=ON \\
-DWAYLAND_USE_PKG_CONFIG=ON \\
-DCMAKE_DISABLE_FIND_PACKAGE_harfbuzz=TRUE \\
-DQT_FEATURE_static_runtime=ON \\
-DFEATURE_pkg_config=ON<%== content_for 'additional_cmake_args' %>
VERBOSE=1 cmake --build build

View File

@ -31,6 +31,8 @@ build() {
$ccache_args \
-DCMAKE_SKIP_INSTALL_RPATH=ON \
-DGLIB2_USE_PKG_CONFIG=ON \
-DWAYLAND_USE_PKG_CONFIG=ON \
-DCMAKE_DISABLE_FIND_PACKAGE_harfbuzz=TRUE \
-DQT_FEATURE_static_runtime=ON \
-DFEATURE_pkg_config=ON
VERBOSE=1 cmake --build build

View File

@ -0,0 +1 @@
../mingw-w64/0012-Allow-using-properties-of-PkgConfig-targets-for-Wayl.patch

View File

@ -38,19 +38,21 @@ source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/subm
'0008-Fix-crashes-in-rasterization-code-using-setjmp.patch'
'0009-Find-fontconfig-via-pkg-config-for-correct-handling-.patch'
'0010-Fix-dependency-of-xcb-image-on-xcb-util.patch'
'0011-Allow-using-properties-of-PkgConfig-targets-for-glib.patch')
'0011-Allow-using-properties-of-PkgConfig-targets-for-glib.patch'
'0012-Allow-using-properties-of-PkgConfig-targets-for-Wayl.patch')
sha256sums=('b865aae43357f792b3b0a162899d9bf6a1393a55c4e5e4ede5316b157b1a0f99'
'c570a73b499f2b7c6d24da37bcfbaef900d5cde131c1d78ef871e8def0043395'
'2ccf9394c8d9eebbef1ce21bd854b995240084defafc9f1ff72a5cb6859f4da3'
'4fa0d685cee2b918e7bbfe9e870a707eca6dcd74a53a3c95c032d9bd91fa21bf'
'8f520ef33be9cf2d9b1b9f99deae3608770837ba587039c7bd534bded4a919dd'
'482d48e8f0462e85155d1d02a64e7372b6d852a45d74e677f33d3726d01d3ab4'
'30ab970e33d7ceaec711ec20aeeb2d9d4c84615cfca92e657d3fb72f83e1e6a5'
'414413e6882746457259e7d2c2d332566fa818b0fb8396c0344b2931d106c7c3'
'6d48fa790e14af053eb2dd0146688bc7334bb9123b7575d4229e2a030f0f5a75'
'909e94ac3566475a858302f92bcc2c5297721ec49f1598bf1708389761c15f05'
'dc4dfcb55e1de9e9f7d2d16fca3d743f03f35418989e908b39a533b22375c099'
'50a2d5ee429e9fc9994175a5cb8f205ad4b252e35e800d3508c1d49382adcf85')
'3bd925d113a0ae1d3db5e6e001fb745ec0625d3212686aeaf9a0b121a48afc51'
'f68fa8937d59579ef60d769f7ca0b308216ab360552aae6fd63e86d6140ff04f'
'c0ce8ffcbc56e502604346d71b81d5fc8bdf625525b6330ba9ab64e10f2d7d5a'
'4af1a6c2f75cd979ff9ed07c4e78da638668523a54370884978934ac1bbaffd7'
'44dd65f1fac710cfa1e3fc36606026b8f2d5513ec346fc177231ab98a1cc06fa'
'393bc8ad824198a9f94d46bb4553f1f4b644ff156da522d1be387518dcf69f8b'
'0fc110150906fc6af37ad9549e92258923f0c6922dc3fca163fb200eb54df940'
'5a88e320849fe4625687a8e3e2239f59635b02852d2e0c42f7f532a7cb459889'
'85495ac317f403f8b406e5d85afd106cacc855190b351f6ee97a14598024c9d1'
'179d7e3bf2c25a5f098a9fb5ed22f659dd094588a5a418989e11a2afb165428b'
'80a5839cc2b60d3cd68e6abb365997c70770b8aa19fbbc8b80f82bac562e2c11'
'ce926322642daaae84094801da24b10fb832d5b9ac46c3fc1d591d2a111bcc36')
prepare () {
cd $_pkgfqn

View File

@ -0,0 +1 @@
../mingw-w64/0012-Allow-using-properties-of-PkgConfig-targets-for-Wayl.patch

View File

@ -41,19 +41,21 @@ source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/subm
'0008-Fix-crashes-in-rasterization-code-using-setjmp.patch'
'0009-Find-fontconfig-via-pkg-config-for-correct-handling-.patch'
'0010-Fix-dependency-of-xcb-image-on-xcb-util.patch'
'0011-Allow-using-properties-of-PkgConfig-targets-for-glib.patch')
'0011-Allow-using-properties-of-PkgConfig-targets-for-glib.patch'
'0012-Allow-using-properties-of-PkgConfig-targets-for-Wayl.patch')
sha256sums=('b865aae43357f792b3b0a162899d9bf6a1393a55c4e5e4ede5316b157b1a0f99'
'c570a73b499f2b7c6d24da37bcfbaef900d5cde131c1d78ef871e8def0043395'
'2ccf9394c8d9eebbef1ce21bd854b995240084defafc9f1ff72a5cb6859f4da3'
'4fa0d685cee2b918e7bbfe9e870a707eca6dcd74a53a3c95c032d9bd91fa21bf'
'8f520ef33be9cf2d9b1b9f99deae3608770837ba587039c7bd534bded4a919dd'
'482d48e8f0462e85155d1d02a64e7372b6d852a45d74e677f33d3726d01d3ab4'
'30ab970e33d7ceaec711ec20aeeb2d9d4c84615cfca92e657d3fb72f83e1e6a5'
'414413e6882746457259e7d2c2d332566fa818b0fb8396c0344b2931d106c7c3'
'6d48fa790e14af053eb2dd0146688bc7334bb9123b7575d4229e2a030f0f5a75'
'909e94ac3566475a858302f92bcc2c5297721ec49f1598bf1708389761c15f05'
'dc4dfcb55e1de9e9f7d2d16fca3d743f03f35418989e908b39a533b22375c099'
'50a2d5ee429e9fc9994175a5cb8f205ad4b252e35e800d3508c1d49382adcf85')
'3bd925d113a0ae1d3db5e6e001fb745ec0625d3212686aeaf9a0b121a48afc51'
'f68fa8937d59579ef60d769f7ca0b308216ab360552aae6fd63e86d6140ff04f'
'c0ce8ffcbc56e502604346d71b81d5fc8bdf625525b6330ba9ab64e10f2d7d5a'
'4af1a6c2f75cd979ff9ed07c4e78da638668523a54370884978934ac1bbaffd7'
'44dd65f1fac710cfa1e3fc36606026b8f2d5513ec346fc177231ab98a1cc06fa'
'393bc8ad824198a9f94d46bb4553f1f4b644ff156da522d1be387518dcf69f8b'
'0fc110150906fc6af37ad9549e92258923f0c6922dc3fca163fb200eb54df940'
'5a88e320849fe4625687a8e3e2239f59635b02852d2e0c42f7f532a7cb459889'
'85495ac317f403f8b406e5d85afd106cacc855190b351f6ee97a14598024c9d1'
'179d7e3bf2c25a5f098a9fb5ed22f659dd094588a5a418989e11a2afb165428b'
'80a5839cc2b60d3cd68e6abb365997c70770b8aa19fbbc8b80f82bac562e2c11'
'ce926322642daaae84094801da24b10fb832d5b9ac46c3fc1d591d2a111bcc36')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'

View File

@ -1,7 +1,7 @@
From 9636662a15e67ba2a1e9f1374537d3b390e9d04d Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Thu, 5 Nov 2020 22:08:10 +0100
Subject: [PATCH 01/11] Use CMake's default import library suffix
Subject: [PATCH 01/12] Use CMake's default import library suffix
Change-Id: I3dbedaec74683e5bfd008f7f2fd1e046dfb921b2
---

View File

@ -1,7 +1,7 @@
From 0ee959c716f76b22e32bbcd74d4d3c27c45054eb Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Wed, 7 Oct 2020 12:13:37 +0200
Subject: [PATCH 02/11] Fix finding D-Bus
Subject: [PATCH 02/12] Fix finding D-Bus
Change-Id: Ie21eb9cbc6b1b5d9c8b34eea46f54718e5926986
---

View File

@ -1,7 +1,7 @@
From c32b8866da5b01a75b61c26a288d4c1497bd197b Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Thu, 5 Nov 2020 21:13:19 +0100
Subject: [PATCH 03/11] Fix using static PCRE2 and DBus-1
Subject: [PATCH 03/12] Fix using static PCRE2 and DBus-1
When making a static build of Qt we're using the static version of these
libraries and must define the corresponding macros.

View File

@ -1,7 +1,7 @@
From ffdf568ee684a97d59e4668eea92d9e3cedaed30 Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Thu, 5 Nov 2020 21:59:33 +0100
Subject: [PATCH 04/11] Fix transitive dependencies (of static libraries)
Subject: [PATCH 04/12] Fix transitive dependencies (of static libraries)
The dependencies of these libraries are not reliably picked up by their
corresponding find modules. This change allows adding the required

View File

@ -1,7 +1,7 @@
From dda151c4601c0f5453ffa7b80f4c77f65ae04bcd Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Mon, 2 Nov 2020 13:47:45 +0100
Subject: [PATCH 05/11] Fix libjpeg workaround for conflict with rpcndr.h
Subject: [PATCH 05/12] Fix libjpeg workaround for conflict with rpcndr.h
Otherwise it won't compile against mingw-w64-libjpeg-turbo. This version of
libjpeg seems to take care of the conflict already as long as jconfig.h is

View File

@ -1,7 +1,7 @@
From d0bbc1ae7e19e0622d1015f9d773a0d5d2d891f6 Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Sun, 8 Nov 2020 00:33:12 +0100
Subject: [PATCH 06/11] Support finding static MariaDB client library
Subject: [PATCH 06/12] Support finding static MariaDB client library
We need to reverse the order to look for mariadb first (and only then
for mysql) because otherwise it would pick up the static library

View File

@ -1,7 +1,7 @@
From f2f0f4c188747c95a80317e95c71a1c75ccc9bd3 Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Sun, 8 Nov 2020 00:34:09 +0100
Subject: [PATCH 07/11] Allow overriding CMAKE_FIND_LIBRARY_SUFFIXES to prefer
Subject: [PATCH 07/12] Allow overriding CMAKE_FIND_LIBRARY_SUFFIXES to prefer
static libraries
Change-Id: I4c617e0706044d31da1bd56ae51615dc8ed37099

View File

@ -1,7 +1,7 @@
From 3a7e6c01e86ff8b4ffaec5a7690d680198d59f57 Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Sat, 26 Jun 2021 22:24:12 +0200
Subject: [PATCH 08/11] Fix crashes in rasterization code using setjmp
Subject: [PATCH 08/12] Fix crashes in rasterization code using setjmp
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

View File

@ -1,7 +1,7 @@
From f15877ee90f492397687f667127daada5e169d98 Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Sun, 24 Apr 2022 23:00:27 +0200
Subject: [PATCH 09/11] Find fontconfig via pkg-config for correct handling of
Subject: [PATCH 09/12] Find fontconfig via pkg-config for correct handling of
its dependencies
CMake's own find module unforunately does not consider fontconfig's deps so

View File

@ -1,7 +1,7 @@
From 66ccefd5a9d47ce11cb8cdcb0a507f8f2bce9a4b Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Sun, 24 Apr 2022 23:49:36 +0200
Subject: [PATCH 10/11] Fix dependency of xcb-image on xcb-util
Subject: [PATCH 10/12] Fix dependency of xcb-image on xcb-util
Considering this linker error, xcb-image apparently depends on xcb-util:
```

View File

@ -1,7 +1,7 @@
From 3945a806c0b87d64ef13e6fb1d72a9f82b5f95e6 Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Tue, 26 Apr 2022 20:16:31 +0200
Subject: [PATCH 11/11] Allow using properties of PkgConfig targets for glib2
Subject: [PATCH 11/12] Allow using properties of PkgConfig targets for glib2
to handle deps of static glib2
Change-Id: I37d20256d17ae9cc0775e32aa479f1e433ece908

View File

@ -0,0 +1,53 @@
From 5b2195625792826d73cb378f5f1da9178bcbf3fe Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Sun, 1 May 2022 23:28:26 +0200
Subject: [PATCH 12/12] Allow using properties of PkgConfig targets for Wayland
to handle deps of static libs
Change-Id: I2a4acf0acaf5a363d551384bb4c33c48a3792f27
---
.../find-modules/FindWayland.cmake | 21 +++++++++++++++++++
1 file changed, 21 insertions(+)
diff --git a/cmake/3rdparty/extra-cmake-modules/find-modules/FindWayland.cmake b/cmake/3rdparty/extra-cmake-modules/find-modules/FindWayland.cmake
index 233cc88d02..875c71377c 100644
--- a/cmake/3rdparty/extra-cmake-modules/find-modules/FindWayland.cmake
+++ b/cmake/3rdparty/extra-cmake-modules/find-modules/FindWayland.cmake
@@ -75,6 +75,13 @@
# THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
#=============================================================================
+option(WAYLAND_USE_PKG_CONFIG "Use properties from PkgConfig targets" OFF)
+if(WAYLAND_USE_PKG_CONFIG)
+ find_package(PkgConfig QUIET)
+ pkg_check_modules(PC_WAYLAND_Client QUIET wayland-client IMPORTED_TARGET)
+ pkg_check_modules(PC_WAYLAND_Server QUIET wayland-server IMPORTED_TARGET)
+endif()
+
include(${CMAKE_CURRENT_LIST_DIR}/ECMFindModuleHelpersStub.cmake)
ecm_find_package_version_check(Wayland)
@@ -136,6 +143,20 @@ find_package_handle_standard_args(Wayland
HANDLE_COMPONENTS
)
+# pull dependencies via package config
+if(WAYLAND_USE_PKG_CONFIG)
+ foreach(TARGET_NAME Client Server)
+ if(TARGET "Wayland::${TARGET_NAME}")
+ foreach(PROP_NAME INTERFACE_LINK_OPTIONS INTERFACE_LINK_LIBRARIES
+ INTERFACE_COMPILE_OPTIONS INTERFACE_COMPILE_DEFINITIONS
+ INTERFACE_INCLUDE_DIRECTORIES)
+ get_target_property(PROP_VAL "PkgConfig::PC_WAYLAND_${TARGET_NAME}" "${PROP_NAME}")
+ set_target_properties("Wayland::${TARGET_NAME}" PROPERTIES "${PROP_NAME}" "${PROP_VAL}")
+ endforeach()
+ endif()
+ endforeach()
+endif()
+
include(FeatureSummary)
set_package_properties(Wayland PROPERTIES
URL "http://wayland.freedesktop.org"
--
2.36.0

View File

@ -41,19 +41,21 @@ source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/subm
'0008-Fix-crashes-in-rasterization-code-using-setjmp.patch'
'0009-Find-fontconfig-via-pkg-config-for-correct-handling-.patch'
'0010-Fix-dependency-of-xcb-image-on-xcb-util.patch'
'0011-Allow-using-properties-of-PkgConfig-targets-for-glib.patch')
'0011-Allow-using-properties-of-PkgConfig-targets-for-glib.patch'
'0012-Allow-using-properties-of-PkgConfig-targets-for-Wayl.patch')
sha256sums=('b865aae43357f792b3b0a162899d9bf6a1393a55c4e5e4ede5316b157b1a0f99'
'c570a73b499f2b7c6d24da37bcfbaef900d5cde131c1d78ef871e8def0043395'
'2ccf9394c8d9eebbef1ce21bd854b995240084defafc9f1ff72a5cb6859f4da3'
'4fa0d685cee2b918e7bbfe9e870a707eca6dcd74a53a3c95c032d9bd91fa21bf'
'8f520ef33be9cf2d9b1b9f99deae3608770837ba587039c7bd534bded4a919dd'
'482d48e8f0462e85155d1d02a64e7372b6d852a45d74e677f33d3726d01d3ab4'
'30ab970e33d7ceaec711ec20aeeb2d9d4c84615cfca92e657d3fb72f83e1e6a5'
'414413e6882746457259e7d2c2d332566fa818b0fb8396c0344b2931d106c7c3'
'6d48fa790e14af053eb2dd0146688bc7334bb9123b7575d4229e2a030f0f5a75'
'909e94ac3566475a858302f92bcc2c5297721ec49f1598bf1708389761c15f05'
'dc4dfcb55e1de9e9f7d2d16fca3d743f03f35418989e908b39a533b22375c099'
'50a2d5ee429e9fc9994175a5cb8f205ad4b252e35e800d3508c1d49382adcf85')
'3bd925d113a0ae1d3db5e6e001fb745ec0625d3212686aeaf9a0b121a48afc51'
'f68fa8937d59579ef60d769f7ca0b308216ab360552aae6fd63e86d6140ff04f'
'c0ce8ffcbc56e502604346d71b81d5fc8bdf625525b6330ba9ab64e10f2d7d5a'
'4af1a6c2f75cd979ff9ed07c4e78da638668523a54370884978934ac1bbaffd7'
'44dd65f1fac710cfa1e3fc36606026b8f2d5513ec346fc177231ab98a1cc06fa'
'393bc8ad824198a9f94d46bb4553f1f4b644ff156da522d1be387518dcf69f8b'
'0fc110150906fc6af37ad9549e92258923f0c6922dc3fca163fb200eb54df940'
'5a88e320849fe4625687a8e3e2239f59635b02852d2e0c42f7f532a7cb459889'
'85495ac317f403f8b406e5d85afd106cacc855190b351f6ee97a14598024c9d1'
'179d7e3bf2c25a5f098a9fb5ed22f659dd094588a5a418989e11a2afb165428b'
'80a5839cc2b60d3cd68e6abb365997c70770b8aa19fbbc8b80f82bac562e2c11'
'ce926322642daaae84094801da24b10fb832d5b9ac46c3fc1d591d2a111bcc36')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'

View File

@ -0,0 +1 @@
../mingw-w64/0012-Allow-using-properties-of-PkgConfig-targets-for-Wayl.patch

View File

@ -12,7 +12,7 @@
pkgname=static-compat-qt6-base
_qtver=6.3.0
pkgver=${_qtver/-/}
pkgrel=2
pkgrel=3
arch=(x86_64)
url='https://www.qt.io'
license=(GPL3 LGPL3 FDL custom)
@ -40,19 +40,21 @@ source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/subm
'0008-Fix-crashes-in-rasterization-code-using-setjmp.patch'
'0009-Find-fontconfig-via-pkg-config-for-correct-handling-.patch'
'0010-Fix-dependency-of-xcb-image-on-xcb-util.patch'
'0011-Allow-using-properties-of-PkgConfig-targets-for-glib.patch')
'0011-Allow-using-properties-of-PkgConfig-targets-for-glib.patch'
'0012-Allow-using-properties-of-PkgConfig-targets-for-Wayl.patch')
sha256sums=('b865aae43357f792b3b0a162899d9bf6a1393a55c4e5e4ede5316b157b1a0f99'
'c570a73b499f2b7c6d24da37bcfbaef900d5cde131c1d78ef871e8def0043395'
'2ccf9394c8d9eebbef1ce21bd854b995240084defafc9f1ff72a5cb6859f4da3'
'4fa0d685cee2b918e7bbfe9e870a707eca6dcd74a53a3c95c032d9bd91fa21bf'
'8f520ef33be9cf2d9b1b9f99deae3608770837ba587039c7bd534bded4a919dd'
'482d48e8f0462e85155d1d02a64e7372b6d852a45d74e677f33d3726d01d3ab4'
'30ab970e33d7ceaec711ec20aeeb2d9d4c84615cfca92e657d3fb72f83e1e6a5'
'414413e6882746457259e7d2c2d332566fa818b0fb8396c0344b2931d106c7c3'
'6d48fa790e14af053eb2dd0146688bc7334bb9123b7575d4229e2a030f0f5a75'
'909e94ac3566475a858302f92bcc2c5297721ec49f1598bf1708389761c15f05'
'dc4dfcb55e1de9e9f7d2d16fca3d743f03f35418989e908b39a533b22375c099'
'50a2d5ee429e9fc9994175a5cb8f205ad4b252e35e800d3508c1d49382adcf85')
'3bd925d113a0ae1d3db5e6e001fb745ec0625d3212686aeaf9a0b121a48afc51'
'f68fa8937d59579ef60d769f7ca0b308216ab360552aae6fd63e86d6140ff04f'
'c0ce8ffcbc56e502604346d71b81d5fc8bdf625525b6330ba9ab64e10f2d7d5a'
'4af1a6c2f75cd979ff9ed07c4e78da638668523a54370884978934ac1bbaffd7'
'44dd65f1fac710cfa1e3fc36606026b8f2d5513ec346fc177231ab98a1cc06fa'
'393bc8ad824198a9f94d46bb4553f1f4b644ff156da522d1be387518dcf69f8b'
'0fc110150906fc6af37ad9549e92258923f0c6922dc3fca163fb200eb54df940'
'5a88e320849fe4625687a8e3e2239f59635b02852d2e0c42f7f532a7cb459889'
'85495ac317f403f8b406e5d85afd106cacc855190b351f6ee97a14598024c9d1'
'179d7e3bf2c25a5f098a9fb5ed22f659dd094588a5a418989e11a2afb165428b'
'80a5839cc2b60d3cd68e6abb365997c70770b8aa19fbbc8b80f82bac562e2c11'
'ce926322642daaae84094801da24b10fb832d5b9ac46c3fc1d591d2a111bcc36')
prepare () {
cd $_pkgfqn
@ -100,6 +102,8 @@ build() {
-DQT_FEATURE_dynamicgl=OFF \
-DQT_FEATURE_opengl_dynamic=OFF \
-DGLIB2_USE_PKG_CONFIG=ON \
-DWAYLAND_USE_PKG_CONFIG=ON \
-DCMAKE_DISABLE_FIND_PACKAGE_harfbuzz=TRUE \
-DCMAKE_INSTALL_OLDINCLUDEDIR=$static_compat_prefix/include \
-DGSSAPI_INCLUDE_DIRS=$static_compat_prefix/include \
-DICU_INCLUDE_DIR=$static_compat_prefix/include \

View File

@ -30,6 +30,8 @@ build() {
$ccache_args \
-DCMAKE_SKIP_INSTALL_RPATH=ON \
-DGLIB2_USE_PKG_CONFIG=ON \
-DWAYLAND_USE_PKG_CONFIG=ON \
-DCMAKE_DISABLE_FIND_PACKAGE_harfbuzz=TRUE \
-DQT_FEATURE_static_runtime=ON \
-DFEATURE_pkg_config=ON
VERBOSE=1 cmake --build build

View File

@ -31,6 +31,8 @@ build() {
$ccache_args \
-DCMAKE_SKIP_INSTALL_RPATH=ON \
-DGLIB2_USE_PKG_CONFIG=ON \
-DWAYLAND_USE_PKG_CONFIG=ON \
-DCMAKE_DISABLE_FIND_PACKAGE_harfbuzz=TRUE \
-DQT_FEATURE_static_runtime=ON \
-DFEATURE_pkg_config=ON
VERBOSE=1 cmake --build build

View File

@ -31,6 +31,8 @@ build() {
$ccache_args \
-DCMAKE_SKIP_INSTALL_RPATH=ON \
-DGLIB2_USE_PKG_CONFIG=ON \
-DWAYLAND_USE_PKG_CONFIG=ON \
-DCMAKE_DISABLE_FIND_PACKAGE_harfbuzz=TRUE \
-DQT_FEATURE_static_runtime=ON \
-DFEATURE_pkg_config=ON
VERBOSE=1 cmake --build build

View File

@ -30,6 +30,8 @@ build() {
$ccache_args \
-DCMAKE_SKIP_INSTALL_RPATH=ON \
-DGLIB2_USE_PKG_CONFIG=ON \
-DWAYLAND_USE_PKG_CONFIG=ON \
-DCMAKE_DISABLE_FIND_PACKAGE_harfbuzz=TRUE \
-DQT_FEATURE_static_runtime=ON \
-DFEATURE_pkg_config=ON
VERBOSE=1 cmake --build build

View File

@ -33,6 +33,8 @@ build() {
$ccache_args \
-DCMAKE_SKIP_INSTALL_RPATH=ON \
-DGLIB2_USE_PKG_CONFIG=ON \
-DWAYLAND_USE_PKG_CONFIG=ON \
-DCMAKE_DISABLE_FIND_PACKAGE_harfbuzz=TRUE \
-DQT_FEATURE_static_runtime=ON \
-DFEATURE_pkg_config=ON
VERBOSE=1 cmake --build build

View File

@ -31,6 +31,8 @@ build() {
$ccache_args \
-DCMAKE_SKIP_INSTALL_RPATH=ON \
-DGLIB2_USE_PKG_CONFIG=ON \
-DWAYLAND_USE_PKG_CONFIG=ON \
-DCMAKE_DISABLE_FIND_PACKAGE_harfbuzz=TRUE \
-DQT_FEATURE_static_runtime=ON \
-DFEATURE_pkg_config=ON
VERBOSE=1 cmake --build build

View File

@ -31,6 +31,8 @@ build() {
$ccache_args \
-DCMAKE_SKIP_INSTALL_RPATH=ON \
-DGLIB2_USE_PKG_CONFIG=ON \
-DWAYLAND_USE_PKG_CONFIG=ON \
-DCMAKE_DISABLE_FIND_PACKAGE_harfbuzz=TRUE \
-DQT_FEATURE_static_runtime=ON \
-DFEATURE_pkg_config=ON
VERBOSE=1 cmake --build build

View File

@ -30,6 +30,8 @@ build() {
$ccache_args \
-DCMAKE_SKIP_INSTALL_RPATH=ON \
-DGLIB2_USE_PKG_CONFIG=ON \
-DWAYLAND_USE_PKG_CONFIG=ON \
-DCMAKE_DISABLE_FIND_PACKAGE_harfbuzz=TRUE \
-DQT_FEATURE_static_runtime=ON \
-DFEATURE_pkg_config=ON
VERBOSE=1 cmake --build build

View File

@ -31,6 +31,8 @@ build() {
$ccache_args \
-DCMAKE_SKIP_INSTALL_RPATH=ON \
-DGLIB2_USE_PKG_CONFIG=ON \
-DWAYLAND_USE_PKG_CONFIG=ON \
-DCMAKE_DISABLE_FIND_PACKAGE_harfbuzz=TRUE \
-DQT_FEATURE_static_runtime=ON \
-DFEATURE_pkg_config=ON \
-DFEATURE_quick3d_assimp=OFF

View File

@ -30,6 +30,8 @@ build() {
$ccache_args \
-DCMAKE_SKIP_INSTALL_RPATH=ON \
-DGLIB2_USE_PKG_CONFIG=ON \
-DWAYLAND_USE_PKG_CONFIG=ON \
-DCMAKE_DISABLE_FIND_PACKAGE_harfbuzz=TRUE \
-DQT_FEATURE_static_runtime=ON \
-DFEATURE_pkg_config=ON
VERBOSE=1 cmake --build build

View File

@ -30,6 +30,8 @@ build() {
$ccache_args \
-DCMAKE_SKIP_INSTALL_RPATH=ON \
-DGLIB2_USE_PKG_CONFIG=ON \
-DWAYLAND_USE_PKG_CONFIG=ON \
-DCMAKE_DISABLE_FIND_PACKAGE_harfbuzz=TRUE \
-DQT_FEATURE_static_runtime=ON \
-DFEATURE_pkg_config=ON
VERBOSE=1 cmake --build build

View File

@ -51,6 +51,8 @@ build() {
$ccache_args \
-DCMAKE_SKIP_INSTALL_RPATH=ON \
-DGLIB2_USE_PKG_CONFIG=ON \
-DWAYLAND_USE_PKG_CONFIG=ON \
-DCMAKE_DISABLE_FIND_PACKAGE_harfbuzz=TRUE \
-DQT_FEATURE_static_runtime=ON \
-DFEATURE_pkg_config=ON \
-DLLVM_DIR="$PWD/prefix/lib/cmake/llvm" \

View File

@ -30,6 +30,8 @@ build() {
$ccache_args \
-DCMAKE_SKIP_INSTALL_RPATH=ON \
-DGLIB2_USE_PKG_CONFIG=ON \
-DWAYLAND_USE_PKG_CONFIG=ON \
-DCMAKE_DISABLE_FIND_PACKAGE_harfbuzz=TRUE \
-DQT_FEATURE_static_runtime=ON \
-DFEATURE_pkg_config=ON
VERBOSE=1 cmake --build build

View File

@ -30,6 +30,8 @@ build() {
$ccache_args \
-DCMAKE_SKIP_INSTALL_RPATH=ON \
-DGLIB2_USE_PKG_CONFIG=ON \
-DWAYLAND_USE_PKG_CONFIG=ON \
-DCMAKE_DISABLE_FIND_PACKAGE_harfbuzz=TRUE \
-DQT_FEATURE_static_runtime=ON \
-DFEATURE_pkg_config=ON
VERBOSE=1 cmake --build build

View File

@ -6,7 +6,7 @@
pkgname=static-compat-qt6-wayland
_qtver=6.3.0
pkgver=${_qtver/-/}
pkgrel=1
pkgrel=2
arch=(x86_64)
url='https://www.qt.io'
license=(GPL3 LGPL3 FDL custom)
@ -30,6 +30,8 @@ build() {
$ccache_args \
-DCMAKE_SKIP_INSTALL_RPATH=ON \
-DGLIB2_USE_PKG_CONFIG=ON \
-DWAYLAND_USE_PKG_CONFIG=ON \
-DCMAKE_DISABLE_FIND_PACKAGE_harfbuzz=TRUE \
-DQT_FEATURE_static_runtime=ON \
-DFEATURE_pkg_config=ON
VERBOSE=1 cmake --build build

View File

@ -2,7 +2,7 @@
\
_qtver=6.3.0
pkgver=${_qtver/-/}
pkgrel=1
pkgrel=2
arch=(x86_64)
url='https://www.qt.io'
license=(GPL3 LGPL3 FDL custom)

View File

@ -33,7 +33,7 @@ pkgrel=1
arch=('i686' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
pkgdesc='Tray application for Syncthing'
license=('GPL')
depends=('static-compat-qtutilities' 'static-compat-qtforkawesome' 'static-compat-boost' 'static-compat-qt6-svg' 'static-compat-openssl')
depends=('static-compat-qtutilities' 'static-compat-qtforkawesome' 'static-compat-boost' 'static-compat-qt6-svg' 'static-compat-qt6-wayland' 'static-compat-openssl')
[[ $_webview_provider == none ]] && depends+=('static-compat-qt6-base')
[[ $_webview_provider == webkit ]] && depends+=('static-compat-qt6-webkit')
[[ $_webview_provider == webengine ]] && depends+=('static-compat-qt6-webengine')
@ -41,7 +41,7 @@ depends=('static-compat-qtutilities' 'static-compat-qtforkawesome' 'static-compa
[[ $_js_provider == qml ]] && depends+=('static-compat-qt6-declarative')
[[ $_enable_kio_plugin ]] && optdepends+=('static-compat-kio: KIO plugin for Syncthing actions in Dolphin')
[[ $_enable_plasmoid ]] && optdepends+=('static-compat-plasma-workspace: Plasmoid for Plasma 6 desktop')
makedepends=('static-compat-cmake' 'ninja' 'static-compat-qt6-tools' 'clang')
makedepends=('static-compat-cmake' 'ninja' 'static-compat-qt6-tools' 'static-compat-qt6-translations' 'breeze-icons' 'numix-icon-theme-git' 'clang')
[[ $_enable_libsyncthing == ON ]] && makedepends+=('git' 'go')
checkdepends=('static-compat-cppunit' 'syncthing' 'iproute2')
[[ $_enable_kio_plugin ]] && makedepends+=('static-compat-kio')
@ -91,15 +91,23 @@ build() {
[[ $_enable_kio_plugin ]] || additional_args+=' -DNO_FILE_ITEM_ACTION_PLUGIN=ON'
[[ $_enable_plasmoid ]] || additional_args+=' -DNO_PLASMOID=ON'
static-compat-cmake \
-G Ninja \
static-compat-cmake -G Ninja \
$ccache_args \
-DCMAKE_SKIP_INSTALL_RPATH=ON \
-DQT_PACKAGE_PREFIX:STRING='Qt6' \
-DBUILTIN_TRANSLATIONS:BOOL=ON \
-DBUILTIN_TRANSLATIONS_OF_QT:BOOL=ON \
-DWEBVIEW_PROVIDER="${_webview_provider}" \
-DJS_PROVIDER="${_js_provider}" \
-DSYSTEMD_SUPPORT=ON \
-DBUILTIN_ICON_THEMES:STRING='breeze;breeze-dark;Numix' \
-DIMAGE_FORMAT_SUPPORT:STRING='Gif;ICO;Jpeg' \
-DSVG_SUPPORT:BOOL=ON \
-DSVG_ICON_SUPPORT:BOOL=ON \
-DBoost_USE_STATIC_RUNTIME:BOOL=ON \
-DGLIB2_USE_PKG_CONFIG:BOOL=ON \
-DWAYLAND_USE_PKG_CONFIG:BOOL=ON \
-DCMAKE_DISABLE_FIND_PACKAGE_harfbuzz=TRUE \
-DNO_LIBSYNCTHING:BOOL="${_disable_libsyncthing}" \
-DUSE_LIBSYNCTHING:BOOL="${_enable_libsyncthing}" \
$additional_args \