gogs: Rebase patches, set GOGS_CUSTOM to /var/lib/gogs/custom

This commit is contained in:
Martchus 2017-10-06 16:53:30 +02:00
parent 331d053a75
commit bcb8d23ed7
3 changed files with 32 additions and 18 deletions

View File

@ -1,17 +1,31 @@
From 4c68726e20939338d196bdd6b0cc4e6cf69ce642 Mon Sep 17 00:00:00 2001
From 73ef207e99b977f830e8a0d5fc98b8f8d25bb3f6 Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Sun, 19 Mar 2017 18:03:36 +0100
Subject: [PATCH 1/2] Adjust config for Arch Linux package
---
conf/app.ini | 18 +++++++++---------
1 file changed, 9 insertions(+), 9 deletions(-)
conf/app.ini | 31 +++++++++++++++++++------------
1 file changed, 19 insertions(+), 12 deletions(-)
diff --git a/conf/app.ini b/conf/app.ini
index fc43868e..b170dd5f 100644
index fc43868e9..bc78b8d8c 100644
--- a/conf/app.ini
+++ b/conf/app.ini
@@ -5,7 +5,7 @@
@@ -1,11 +1,18 @@
-# !!! NEVER EVER MODIFY THIS FILE !!!
-# !!! PLEASE MAKE CHANGES ON CORRESPONDING CUSTOM CONFIG FILE !!!
-# !!! IF YOU ARE PACKAGING PROVIDER, PLEASE MAKE OWN COPY OF IT !!!
+# Feel free to modify this file!
+# In case a new version of this file is availabe, pacman will notify automatically when
+# updating and creates the new version as app.ini.pacnew. You can use diff or a similar
+# tool to see the changes between your configuration and the new default configuration.
+
+# There is also a copy of this file under /usr/share/gogs/conf/app.ini in case
+# you need to go back.
+
+# It is also possible to remove all default values and just specify what you want
+# to change because /usr/share/gogs/conf/app.ini also serves as fallback.
; App name that shows on every page title
APP_NAME = Gogs
; The name of the system user that runs Gogs
@ -20,7 +34,7 @@ index fc43868e..b170dd5f 100644
; Either "dev", "prod" or "test"
RUN_MODE = dev
@@ -54,16 +54,16 @@ DISABLE_ROUTER_LOG = false
@@ -54,16 +61,16 @@ DISABLE_ROUTER_LOG = false
; not forget to export the private key):
; $ openssl pkcs12 -in cert.pfx -out cert.pem -nokeys
; $ openssl pkcs12 -in cert.pfx -out key.pem -nocerts -nodes
@ -41,7 +55,7 @@ index fc43868e..b170dd5f 100644
; Application level GZIP support
ENABLE_GZIP = false
; Landing page for non-logged users, can be "home" or "explore"
@@ -71,7 +71,7 @@ LANDING_PAGE = home
@@ -71,7 +78,7 @@ LANDING_PAGE = home
[repository]
; Root path for storing repositories's data, default is "~/<username>/gogs-repositories"
@ -50,7 +64,7 @@ index fc43868e..b170dd5f 100644
; The script type server supports, sometimes could be "sh"
SCRIPT_TYPE = bash
; Default ANSI charset for an unrecognized charset
@@ -111,7 +111,7 @@ PREVIEWABLE_FILE_MODES = markdown
@@ -111,7 +118,7 @@ PREVIEWABLE_FILE_MODES = markdown
; Enable repository file uploads.
ENABLED = true
; Path to temporarily store uploads (default path gets cleaned by Gogs in every start)
@ -59,7 +73,7 @@ index fc43868e..b170dd5f 100644
; File types that are allowed to be uploaded, e.g. image/jpeg|image/png. Leave empty means allow any file type
ALLOWED_TYPES =
; Maximum size of each file in MB
@@ -170,7 +170,7 @@ PASSWD =
@@ -170,7 +177,7 @@ PASSWD =
; For "postgres" only, either "disable", "require" or "verify-full"
SSL_MODE = disable
; For "sqlite3" and "tidb", use absolute path when you start as service
@ -68,7 +82,7 @@ index fc43868e..b170dd5f 100644
[admin]
; Disable regular (non-admin) users to create organizations
@@ -315,7 +315,7 @@ FORMAT =
@@ -315,7 +322,7 @@ FORMAT =
; General settings of loggers
[log]
@ -78,5 +92,5 @@ index fc43868e..b170dd5f 100644
; Use comma to separate multiple modes, e.g. "console, file"
MODE = console
--
2.13.1
2.14.2

View File

@ -1,4 +1,4 @@
From dee8353d947958b5d545f18b4304ad5685eabe2d Mon Sep 17 00:00:00 2001
From 6c229c932878e189e3a785c337a1c5d1cdbea2c3 Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Sun, 19 Mar 2017 18:04:48 +0100
Subject: [PATCH 2/2] Adjust service file for Arch Linux package
@ -8,7 +8,7 @@ Subject: [PATCH 2/2] Adjust service file for Arch Linux package
1 file changed, 5 insertions(+), 5 deletions(-)
diff --git a/scripts/systemd/gogs.service b/scripts/systemd/gogs.service
index 9f105bf8..99ca11e0 100644
index 9f105bf8e..07ffa1f66 100644
--- a/scripts/systemd/gogs.service
+++ b/scripts/systemd/gogs.service
@@ -12,12 +12,12 @@ After=mariadb.service mysqld.service postgresql.service memcached.service redis.
@ -25,10 +25,10 @@ index 9f105bf8..99ca11e0 100644
+ExecStart=/usr/bin/gogs web --config /etc/gogs/app.ini
Restart=always
-Environment=USER=git HOME=/home/git
+Environment=USER=gogs HOME=/var/lib/gogs
+Environment=USER=gogs HOME=/var/lib/gogs GOGS_CUSTOM=/var/lib/gogs/custom
[Install]
WantedBy=multi-user.target
--
2.13.1
2.14.2

View File

@ -8,7 +8,7 @@ _gourl=github.com/gogits/$_pkgname
pkgname=$_pkgname
pkgver=0.11.29
pkgrel=2
pkgrel=3
epoch=1
pkgdesc='Self Hosted Git Service written in Go'
arch=('i686' 'x86_64' 'armv6h' 'armv7h')
@ -30,8 +30,8 @@ source=("$_pkgname-$pkgver::https://github.com/$_orga/$_pkgname/archive/v${pkgve
'0001-Adjust-config-for-Arch-Linux-package.patch'
'0002-Adjust-service-file-for-Arch-Linux-package.patch')
sha512sums=('094dd6b5010128b8a68c3b4a2be389593380be527dd1f1c37882cbd7762ae31ff8da824d047acecb9ef31233ab3c576bc5030c90763adfa32d01b5830d12c04b'
'a3632ed26abb634711c0c51defcf7288053845dfebcf27712de49319cfe80c5f7f7ef725c1a20413b1550a866f106818b5f2fd041c5b2a9158d77eae11897ef4'
'fbb75efd69740638cbb2ce2f0fde3710a466c1128c6afddfd54028b04bb69e7e1f983aba60bbba378c35a854ef1bc7d6fd066acf3846aa48d424784dc15beb4d')
'8aad23ec5b600a56aee4fd8db8e998d973865dd2e6432ca88e014c024a88ed5d7baa1a65b8ae752364d1e94a2d42795f5ced71b3f11dc2c57eb84ed110f2e3c1'
'01e19a45212a066589fbedbda9a0f2ac803269b855afed422fdcefb455f8e0da993ac11f0d36028858e4516d2d017e4c29f66dcc7b2260dd24022d1501e230a3')
_goroot='/usr/lib/go'
prepare() {