Fix Qt 5 plugin template

This commit is contained in:
Martchus 2016-09-17 16:23:20 +02:00
parent 2be7067ebd
commit e75141e702
14 changed files with 91 additions and 59 deletions

View File

@ -6,7 +6,7 @@ if(NOT TARGET Qt5::$$CMAKE_PLUGIN_NAME)
!!IF !isEmpty(CMAKE_RELEASE_TYPE)
!!IF !isEmpty(CMAKE_STATIC_TYPE)
_populate_$${CMAKE_MODULE_NAME}_plugin_properties($$CMAKE_PLUGIN_NAME RELEASE \"$${CMAKE_PLUGIN_LOCATION_RELEASE_STATIC}\")
!!ELSE
!!ELSE
_populate_$${CMAKE_MODULE_NAME}_plugin_properties($$CMAKE_PLUGIN_NAME RELEASE \"$${CMAKE_PLUGIN_LOCATION_RELEASE}\")
!!ENDIF
!!ENDIF

View File

@ -1,5 +1,5 @@
--- mkspecs/features/data/cmake/Qt5BasicConfig.cmake.in.orig 2016-08-14 20:44:32.000000000 +0200
+++ mkspecs/features/data/cmake/Qt5BasicConfig.cmake.in 2016-08-19 16:04:30.000000000 +0200
--- mkspecs/features/data/cmake/Qt5BasicConfig.cmake.in.orig 2016-08-14 20:44:32.515151700 +0200
+++ mkspecs/features/data/cmake/Qt5BasicConfig.cmake.in 2016-08-19 16:04:30.074766100 +0200
@@ -59,19 +59,30 @@
set_property(TARGET Qt5::$${CMAKE_MODULE_NAME} APPEND PROPERTY IMPORTED_CONFIGURATIONS ${Configuration})
@ -291,8 +291,8 @@
!!IF !isEmpty(CMAKE_MODULE_EXTRAS)
include(\"${CMAKE_CURRENT_LIST_DIR}/Qt5$${CMAKE_MODULE_NAME}ConfigExtras.cmake\")
--- mkspecs/features/data/cmake/Qt5PluginTarget.cmake.in.orig 2016-08-19 16:04:30.000000000 +0200
+++ mkspecs/features/data/cmake/Qt5PluginTarget.cmake.in 2016-09-14 18:39:18.286693791 +0200
--- mkspecs/features/data/cmake/Qt5PluginTarget.cmake.in.orig 2016-08-19 16:04:30.075761600 +0200
+++ mkspecs/features/data/cmake/Qt5PluginTarget.cmake.in 2016-09-17 16:00:01.818295000 +0200
@@ -1,11 +1,22 @@
-
-add_library(Qt5::$$CMAKE_PLUGIN_NAME MODULE IMPORTED)
@ -305,7 +305,7 @@
-_populate_$${CMAKE_MODULE_NAME}_plugin_properties($$CMAKE_PLUGIN_NAME RELEASE \"$${CMAKE_PLUGIN_LOCATION_RELEASE}\")
+!!IF !isEmpty(CMAKE_STATIC_TYPE)
+ _populate_$${CMAKE_MODULE_NAME}_plugin_properties($$CMAKE_PLUGIN_NAME RELEASE \"$${CMAKE_PLUGIN_LOCATION_RELEASE_STATIC}\")
+ !!ELSE
+!!ELSE
+ _populate_$${CMAKE_MODULE_NAME}_plugin_properties($$CMAKE_PLUGIN_NAME RELEASE \"$${CMAKE_PLUGIN_LOCATION_RELEASE}\")
+!!ENDIF
!!ENDIF
@ -321,8 +321,8 @@
-list(APPEND Qt5$${CMAKE_MODULE_NAME}_PLUGINS Qt5::$$CMAKE_PLUGIN_NAME)
+ list(APPEND Qt5$${CMAKE_MODULE_NAME}_PLUGINS Qt5::$$CMAKE_PLUGIN_NAME)
+endif()
--- mkspecs/features/create_cmake.prf.orig 2016-08-14 20:44:32.000000000 +0200
+++ mkspecs/features/create_cmake.prf 2016-08-19 16:04:30.000000000 +0200
--- mkspecs/features/create_cmake.prf.orig 2016-08-14 20:44:32.513342200 +0200
+++ mkspecs/features/create_cmake.prf 2016-08-19 16:04:30.073546600 +0200
@@ -135,17 +135,19 @@
CMAKE_PLUGIN_NAME = $$PLUGIN_CLASS_NAME

View File

@ -1,5 +1,5 @@
--- mkspecs/features/spec_pre.prf.orig 2016-08-14 20:44:32.000000000 +0200
+++ mkspecs/features/spec_pre.prf 2016-08-14 20:44:32.000000000 +0200
--- mkspecs/features/spec_pre.prf.orig 2016-08-14 20:44:32.515796400 +0200
+++ mkspecs/features/spec_pre.prf 2016-08-14 20:44:32.515434700 +0200
@@ -14,9 +14,9 @@
QMAKE_EXT_H_MOC = .cpp
QMAKE_EXT_JS = .js

View File

@ -1,5 +1,5 @@
--- src/3rdparty/harfbuzz_dependency.pri.orig 2016-08-14 20:44:32.000000000 +0200
+++ src/3rdparty/harfbuzz_dependency.pri 2016-08-14 20:44:32.000000000 +0200
--- src/3rdparty/harfbuzz_dependency.pri.orig 2016-08-14 20:44:32.519965300 +0200
+++ src/3rdparty/harfbuzz_dependency.pri 2016-08-14 20:44:32.519700600 +0200
@@ -2,5 +2,6 @@
INCLUDEPATH += $$PWD/harfbuzz-ng/include
LIBS_PRIVATE += -L$$QT_BUILD_TREE/lib -lqtharfbuzzng$$qtPlatformTargetSuffix()
@ -8,8 +8,8 @@
+ CONFIG += link_pkgconfig
+ PKGCONFIG += harfbuzz
}
--- src/3rdparty/pcre_dependency.pri.orig 2016-08-14 20:44:32.000000000 +0200
+++ src/3rdparty/pcre_dependency.pri 2016-08-14 20:44:32.000000000 +0200
--- src/3rdparty/pcre_dependency.pri.orig 2016-08-14 20:44:32.521037500 +0200
+++ src/3rdparty/pcre_dependency.pri 2016-08-14 20:44:32.520762700 +0200
@@ -3,5 +3,6 @@
INCLUDEPATH += $$PWD/pcre
LIBS_PRIVATE += -L$$QT_BUILD_TREE/lib -lqtpcre$$qtPlatformTargetSuffix()
@ -18,8 +18,8 @@
+ contains(QT_CONFIG, static): LIBS_PRIVATE += -Bstatic -lpcre16 -Wl,-Bdynamic
+ else: LIBS_PRIVATE += -lpcre16
}
--- src/3rdparty/zlib_dependency.pri.orig 2016-08-14 20:44:32.000000000 +0200
+++ src/3rdparty/zlib_dependency.pri 2016-08-14 20:44:32.000000000 +0200
--- src/3rdparty/zlib_dependency.pri.orig 2016-08-14 20:44:32.522086000 +0200
+++ src/3rdparty/zlib_dependency.pri 2016-08-14 20:44:32.521824500 +0200
@@ -1,7 +1,9 @@
# zlib dependency satisfied by bundled 3rd party zlib or system zlib
contains(QT_CONFIG, system-zlib) {

View File

@ -1,5 +1,5 @@
--- src/3rdparty/harfbuzz_dependency.pri.orig 2016-08-14 20:44:32.000000000 +0200
+++ src/3rdparty/harfbuzz_dependency.pri 2016-08-14 20:44:32.000000000 +0200
--- src/3rdparty/harfbuzz_dependency.pri.orig 2016-08-14 20:44:32.519965300 +0200
+++ src/3rdparty/harfbuzz_dependency.pri 2016-08-14 20:44:32.519700600 +0200
@@ -2,5 +2,6 @@
INCLUDEPATH += $$PWD/harfbuzz-ng/include
LIBS_PRIVATE += -L$$QT_BUILD_TREE/lib -lqtharfbuzzng$$qtPlatformTargetSuffix()

View File

@ -70,7 +70,7 @@ isNoOpenGL() {
pkgname=mingw-w64-qt5-base-angle
pkgver=5.7.0
pkgrel=7
pkgrel=8
pkgdesc="A cross-platform application and UI framework (mingw-w64)"
# The static variant doesn't contain any executables which need to be executed on the build machine
isStatic && arch=('any') || arch=('i686' 'x86_64')
@ -129,7 +129,7 @@ md5sums=('184f9460b40752d71b15b827260580c2'
'83139869355c2d46921adb25e47cf0fa'
'b9565219e9252a17fc1b8fb9ee30662c'
'20de722808e8a3fb684b0212bef8de46'
'e999f23d02758c465a8dbf65a2409114'
'a60bd6bb231acfe9132f391a26b37e71'
'41ec67d9e5e70e0d6d93b42aebd0e12a'
'61c0f9d0095c5a6dec8d14e9ec35a608'
'16a7d505b503bb1087fc00fad819f64b')
@ -287,11 +287,18 @@ build() {
for _arch in ${_architectures}; do
# Phonon is disabled for now because we lack the directx headers
# FIXME: check whether this is still the case
# The odd paths for the -hostbindir argument are on purpose
# The qtchooser tool assumes that the tools 'qmake', 'moc' and others
# are all available in the same folder with these exact file names
# To prevent conflicts with the mingw-w64-qt4 package we have
# to put these tools in a dedicated folder
# The last device option allows using ccache though the use of
# pre-compile header
# (sloppiness must be set to pch_defines,time_macros in ccache config)
local qt_configure_args="\
-xplatform win32-g++ \
-optimized-qmake \
@ -331,7 +338,8 @@ build() {
-plugindir /usr/${_arch}/lib/qt/plugins \
-sysconfdir /usr/${_arch}/etc \
-translationdir /usr/${_arch}/share/qt/translations \
-device-option CROSS_COMPILE=${_arch}-"
-device-option CROSS_COMPILE=${_arch}- \
-device-option CROSS_COMPILE_CFLAGS=-fpch-preprocess"
# Fix include directory of freetype2 and dbus
qt_configure_args+=" $(${_arch}-pkg-config --cflags-only-I freetype2 dbus-1)"

View File

@ -1,5 +1,5 @@
--- mkspecs/features/data/cmake/Qt5BasicConfig.cmake.in.orig 2016-08-14 20:44:32.000000000 +0200
+++ mkspecs/features/data/cmake/Qt5BasicConfig.cmake.in 2016-08-19 16:04:30.000000000 +0200
--- mkspecs/features/data/cmake/Qt5BasicConfig.cmake.in.orig 2016-08-14 20:44:32.515151700 +0200
+++ mkspecs/features/data/cmake/Qt5BasicConfig.cmake.in 2016-08-19 16:04:30.074766100 +0200
@@ -59,19 +59,30 @@
set_property(TARGET Qt5::$${CMAKE_MODULE_NAME} APPEND PROPERTY IMPORTED_CONFIGURATIONS ${Configuration})
@ -291,8 +291,8 @@
!!IF !isEmpty(CMAKE_MODULE_EXTRAS)
include(\"${CMAKE_CURRENT_LIST_DIR}/Qt5$${CMAKE_MODULE_NAME}ConfigExtras.cmake\")
--- mkspecs/features/data/cmake/Qt5PluginTarget.cmake.in.orig 2016-08-19 16:04:30.000000000 +0200
+++ mkspecs/features/data/cmake/Qt5PluginTarget.cmake.in 2016-09-14 18:39:18.286693791 +0200
--- mkspecs/features/data/cmake/Qt5PluginTarget.cmake.in.orig 2016-08-19 16:04:30.075761600 +0200
+++ mkspecs/features/data/cmake/Qt5PluginTarget.cmake.in 2016-09-17 16:00:01.818295000 +0200
@@ -1,11 +1,22 @@
-
-add_library(Qt5::$$CMAKE_PLUGIN_NAME MODULE IMPORTED)
@ -305,7 +305,7 @@
-_populate_$${CMAKE_MODULE_NAME}_plugin_properties($$CMAKE_PLUGIN_NAME RELEASE \"$${CMAKE_PLUGIN_LOCATION_RELEASE}\")
+!!IF !isEmpty(CMAKE_STATIC_TYPE)
+ _populate_$${CMAKE_MODULE_NAME}_plugin_properties($$CMAKE_PLUGIN_NAME RELEASE \"$${CMAKE_PLUGIN_LOCATION_RELEASE_STATIC}\")
+ !!ELSE
+!!ELSE
+ _populate_$${CMAKE_MODULE_NAME}_plugin_properties($$CMAKE_PLUGIN_NAME RELEASE \"$${CMAKE_PLUGIN_LOCATION_RELEASE}\")
+!!ENDIF
!!ENDIF
@ -321,8 +321,8 @@
-list(APPEND Qt5$${CMAKE_MODULE_NAME}_PLUGINS Qt5::$$CMAKE_PLUGIN_NAME)
+ list(APPEND Qt5$${CMAKE_MODULE_NAME}_PLUGINS Qt5::$$CMAKE_PLUGIN_NAME)
+endif()
--- mkspecs/features/create_cmake.prf.orig 2016-08-14 20:44:32.000000000 +0200
+++ mkspecs/features/create_cmake.prf 2016-08-19 16:04:30.000000000 +0200
--- mkspecs/features/create_cmake.prf.orig 2016-08-14 20:44:32.513342200 +0200
+++ mkspecs/features/create_cmake.prf 2016-08-19 16:04:30.073546600 +0200
@@ -135,17 +135,19 @@
CMAKE_PLUGIN_NAME = $$PLUGIN_CLASS_NAME

View File

@ -70,7 +70,7 @@ isNoOpenGL() {
pkgname=mingw-w64-qt5-base-dynamic
pkgver=5.7.0
pkgrel=7
pkgrel=8
pkgdesc="A cross-platform application and UI framework (mingw-w64)"
# The static variant doesn't contain any executables which need to be executed on the build machine
isStatic && arch=('any') || arch=('i686' 'x86_64')
@ -129,7 +129,7 @@ md5sums=('184f9460b40752d71b15b827260580c2'
'83139869355c2d46921adb25e47cf0fa'
'b9565219e9252a17fc1b8fb9ee30662c'
'20de722808e8a3fb684b0212bef8de46'
'e999f23d02758c465a8dbf65a2409114'
'a60bd6bb231acfe9132f391a26b37e71'
'41ec67d9e5e70e0d6d93b42aebd0e12a'
'61c0f9d0095c5a6dec8d14e9ec35a608'
'16a7d505b503bb1087fc00fad819f64b')
@ -287,11 +287,18 @@ build() {
for _arch in ${_architectures}; do
# Phonon is disabled for now because we lack the directx headers
# FIXME: check whether this is still the case
# The odd paths for the -hostbindir argument are on purpose
# The qtchooser tool assumes that the tools 'qmake', 'moc' and others
# are all available in the same folder with these exact file names
# To prevent conflicts with the mingw-w64-qt4 package we have
# to put these tools in a dedicated folder
# The last device option allows using ccache though the use of
# pre-compile header
# (sloppiness must be set to pch_defines,time_macros in ccache config)
local qt_configure_args="\
-xplatform win32-g++ \
-optimized-qmake \
@ -331,7 +338,8 @@ build() {
-plugindir /usr/${_arch}/lib/qt/plugins \
-sysconfdir /usr/${_arch}/etc \
-translationdir /usr/${_arch}/share/qt/translations \
-device-option CROSS_COMPILE=${_arch}-"
-device-option CROSS_COMPILE=${_arch}- \
-device-option CROSS_COMPILE_CFLAGS=-fpch-preprocess"
# Fix include directory of freetype2 and dbus
qt_configure_args+=" $(${_arch}-pkg-config --cflags-only-I freetype2 dbus-1)"

View File

@ -1,5 +1,5 @@
--- mkspecs/features/data/cmake/Qt5BasicConfig.cmake.in.orig 2016-08-14 20:44:32.000000000 +0200
+++ mkspecs/features/data/cmake/Qt5BasicConfig.cmake.in 2016-08-19 16:04:30.000000000 +0200
--- mkspecs/features/data/cmake/Qt5BasicConfig.cmake.in.orig 2016-08-14 20:44:32.515151700 +0200
+++ mkspecs/features/data/cmake/Qt5BasicConfig.cmake.in 2016-08-19 16:04:30.074766100 +0200
@@ -59,19 +59,30 @@
set_property(TARGET Qt5::$${CMAKE_MODULE_NAME} APPEND PROPERTY IMPORTED_CONFIGURATIONS ${Configuration})
@ -291,8 +291,8 @@
!!IF !isEmpty(CMAKE_MODULE_EXTRAS)
include(\"${CMAKE_CURRENT_LIST_DIR}/Qt5$${CMAKE_MODULE_NAME}ConfigExtras.cmake\")
--- mkspecs/features/data/cmake/Qt5PluginTarget.cmake.in.orig 2016-08-19 16:04:30.000000000 +0200
+++ mkspecs/features/data/cmake/Qt5PluginTarget.cmake.in 2016-09-14 18:39:18.286693791 +0200
--- mkspecs/features/data/cmake/Qt5PluginTarget.cmake.in.orig 2016-08-19 16:04:30.075761600 +0200
+++ mkspecs/features/data/cmake/Qt5PluginTarget.cmake.in 2016-09-17 16:00:01.818295000 +0200
@@ -1,11 +1,22 @@
-
-add_library(Qt5::$$CMAKE_PLUGIN_NAME MODULE IMPORTED)
@ -305,7 +305,7 @@
-_populate_$${CMAKE_MODULE_NAME}_plugin_properties($$CMAKE_PLUGIN_NAME RELEASE \"$${CMAKE_PLUGIN_LOCATION_RELEASE}\")
+!!IF !isEmpty(CMAKE_STATIC_TYPE)
+ _populate_$${CMAKE_MODULE_NAME}_plugin_properties($$CMAKE_PLUGIN_NAME RELEASE \"$${CMAKE_PLUGIN_LOCATION_RELEASE_STATIC}\")
+ !!ELSE
+!!ELSE
+ _populate_$${CMAKE_MODULE_NAME}_plugin_properties($$CMAKE_PLUGIN_NAME RELEASE \"$${CMAKE_PLUGIN_LOCATION_RELEASE}\")
+!!ENDIF
!!ENDIF
@ -321,8 +321,8 @@
-list(APPEND Qt5$${CMAKE_MODULE_NAME}_PLUGINS Qt5::$$CMAKE_PLUGIN_NAME)
+ list(APPEND Qt5$${CMAKE_MODULE_NAME}_PLUGINS Qt5::$$CMAKE_PLUGIN_NAME)
+endif()
--- mkspecs/features/create_cmake.prf.orig 2016-08-14 20:44:32.000000000 +0200
+++ mkspecs/features/create_cmake.prf 2016-08-19 16:04:30.000000000 +0200
--- mkspecs/features/create_cmake.prf.orig 2016-08-14 20:44:32.513342200 +0200
+++ mkspecs/features/create_cmake.prf 2016-08-19 16:04:30.073546600 +0200
@@ -135,17 +135,19 @@
CMAKE_PLUGIN_NAME = $$PLUGIN_CLASS_NAME

View File

@ -70,7 +70,7 @@ isNoOpenGL() {
pkgname=mingw-w64-qt5-base-static
pkgver=5.7.0
pkgrel=7
pkgrel=8
pkgdesc="A cross-platform application and UI framework (mingw-w64)"
# The static variant doesn't contain any executables which need to be executed on the build machine
isStatic && arch=('any') || arch=('i686' 'x86_64')
@ -129,7 +129,7 @@ md5sums=('184f9460b40752d71b15b827260580c2'
'83139869355c2d46921adb25e47cf0fa'
'b9565219e9252a17fc1b8fb9ee30662c'
'20de722808e8a3fb684b0212bef8de46'
'e999f23d02758c465a8dbf65a2409114'
'a60bd6bb231acfe9132f391a26b37e71'
'41ec67d9e5e70e0d6d93b42aebd0e12a'
'61c0f9d0095c5a6dec8d14e9ec35a608'
'16a7d505b503bb1087fc00fad819f64b')
@ -287,11 +287,18 @@ build() {
for _arch in ${_architectures}; do
# Phonon is disabled for now because we lack the directx headers
# FIXME: check whether this is still the case
# The odd paths for the -hostbindir argument are on purpose
# The qtchooser tool assumes that the tools 'qmake', 'moc' and others
# are all available in the same folder with these exact file names
# To prevent conflicts with the mingw-w64-qt4 package we have
# to put these tools in a dedicated folder
# The last device option allows using ccache though the use of
# pre-compile header
# (sloppiness must be set to pch_defines,time_macros in ccache config)
local qt_configure_args="\
-xplatform win32-g++ \
-optimized-qmake \
@ -331,7 +338,8 @@ build() {
-plugindir /usr/${_arch}/lib/qt/plugins \
-sysconfdir /usr/${_arch}/etc \
-translationdir /usr/${_arch}/share/qt/translations \
-device-option CROSS_COMPILE=${_arch}-"
-device-option CROSS_COMPILE=${_arch}- \
-device-option CROSS_COMPILE_CFLAGS=-fpch-preprocess"
# Fix include directory of freetype2 and dbus
qt_configure_args+=" $(${_arch}-pkg-config --cflags-only-I freetype2 dbus-1)"

View File

@ -1,5 +1,5 @@
--- mkspecs/features/data/cmake/Qt5BasicConfig.cmake.in.orig 2016-08-14 20:44:32.000000000 +0200
+++ mkspecs/features/data/cmake/Qt5BasicConfig.cmake.in 2016-08-19 16:04:30.000000000 +0200
--- mkspecs/features/data/cmake/Qt5BasicConfig.cmake.in.orig 2016-08-14 20:44:32.515151700 +0200
+++ mkspecs/features/data/cmake/Qt5BasicConfig.cmake.in 2016-08-19 16:04:30.074766100 +0200
@@ -59,19 +59,30 @@
set_property(TARGET Qt5::$${CMAKE_MODULE_NAME} APPEND PROPERTY IMPORTED_CONFIGURATIONS ${Configuration})
@ -291,8 +291,8 @@
!!IF !isEmpty(CMAKE_MODULE_EXTRAS)
include(\"${CMAKE_CURRENT_LIST_DIR}/Qt5$${CMAKE_MODULE_NAME}ConfigExtras.cmake\")
--- mkspecs/features/data/cmake/Qt5PluginTarget.cmake.in.orig 2016-08-19 16:04:30.000000000 +0200
+++ mkspecs/features/data/cmake/Qt5PluginTarget.cmake.in 2016-09-14 18:39:18.286693791 +0200
--- mkspecs/features/data/cmake/Qt5PluginTarget.cmake.in.orig 2016-08-19 16:04:30.075761600 +0200
+++ mkspecs/features/data/cmake/Qt5PluginTarget.cmake.in 2016-09-17 16:00:01.818295000 +0200
@@ -1,11 +1,22 @@
-
-add_library(Qt5::$$CMAKE_PLUGIN_NAME MODULE IMPORTED)
@ -305,7 +305,7 @@
-_populate_$${CMAKE_MODULE_NAME}_plugin_properties($$CMAKE_PLUGIN_NAME RELEASE \"$${CMAKE_PLUGIN_LOCATION_RELEASE}\")
+!!IF !isEmpty(CMAKE_STATIC_TYPE)
+ _populate_$${CMAKE_MODULE_NAME}_plugin_properties($$CMAKE_PLUGIN_NAME RELEASE \"$${CMAKE_PLUGIN_LOCATION_RELEASE_STATIC}\")
+ !!ELSE
+!!ELSE
+ _populate_$${CMAKE_MODULE_NAME}_plugin_properties($$CMAKE_PLUGIN_NAME RELEASE \"$${CMAKE_PLUGIN_LOCATION_RELEASE}\")
+!!ENDIF
!!ENDIF
@ -321,8 +321,8 @@
-list(APPEND Qt5$${CMAKE_MODULE_NAME}_PLUGINS Qt5::$$CMAKE_PLUGIN_NAME)
+ list(APPEND Qt5$${CMAKE_MODULE_NAME}_PLUGINS Qt5::$$CMAKE_PLUGIN_NAME)
+endif()
--- mkspecs/features/create_cmake.prf.orig 2016-08-14 20:44:32.000000000 +0200
+++ mkspecs/features/create_cmake.prf 2016-08-19 16:04:30.000000000 +0200
--- mkspecs/features/create_cmake.prf.orig 2016-08-14 20:44:32.513342200 +0200
+++ mkspecs/features/create_cmake.prf 2016-08-19 16:04:30.073546600 +0200
@@ -135,17 +135,19 @@
CMAKE_PLUGIN_NAME = $$PLUGIN_CLASS_NAME

View File

@ -70,7 +70,7 @@ isNoOpenGL() {
pkgname=mingw-w64-qt5-base
pkgver=5.7.0
pkgrel=7
pkgrel=8
pkgdesc="A cross-platform application and UI framework (mingw-w64)"
# The static variant doesn't contain any executables which need to be executed on the build machine
isStatic && arch=('any') || arch=('i686' 'x86_64')
@ -129,7 +129,7 @@ md5sums=('184f9460b40752d71b15b827260580c2'
'83139869355c2d46921adb25e47cf0fa'
'b9565219e9252a17fc1b8fb9ee30662c'
'20de722808e8a3fb684b0212bef8de46'
'e999f23d02758c465a8dbf65a2409114'
'a60bd6bb231acfe9132f391a26b37e71'
'41ec67d9e5e70e0d6d93b42aebd0e12a'
'61c0f9d0095c5a6dec8d14e9ec35a608'
'16a7d505b503bb1087fc00fad819f64b')
@ -287,11 +287,18 @@ build() {
for _arch in ${_architectures}; do
# Phonon is disabled for now because we lack the directx headers
# FIXME: check whether this is still the case
# The odd paths for the -hostbindir argument are on purpose
# The qtchooser tool assumes that the tools 'qmake', 'moc' and others
# are all available in the same folder with these exact file names
# To prevent conflicts with the mingw-w64-qt4 package we have
# to put these tools in a dedicated folder
# The last device option allows using ccache though the use of
# pre-compile header
# (sloppiness must be set to pch_defines,time_macros in ccache config)
local qt_configure_args="\
-xplatform win32-g++ \
-optimized-qmake \
@ -331,7 +338,8 @@ build() {
-plugindir /usr/${_arch}/lib/qt/plugins \
-sysconfdir /usr/${_arch}/etc \
-translationdir /usr/${_arch}/share/qt/translations \
-device-option CROSS_COMPILE=${_arch}-"
-device-option CROSS_COMPILE=${_arch}- \
-device-option CROSS_COMPILE_CFLAGS=-fpch-preprocess"
# Fix include directory of freetype2 and dbus
qt_configure_args+=" $(${_arch}-pkg-config --cflags-only-I freetype2 dbus-1)"

View File

@ -1,5 +1,5 @@
--- mkspecs/features/data/cmake/Qt5BasicConfig.cmake.in.orig 2016-08-14 20:44:32.000000000 +0200
+++ mkspecs/features/data/cmake/Qt5BasicConfig.cmake.in 2016-08-19 16:04:30.000000000 +0200
--- mkspecs/features/data/cmake/Qt5BasicConfig.cmake.in.orig 2016-08-14 20:44:32.515151700 +0200
+++ mkspecs/features/data/cmake/Qt5BasicConfig.cmake.in 2016-08-19 16:04:30.074766100 +0200
@@ -59,19 +59,30 @@
set_property(TARGET Qt5::$${CMAKE_MODULE_NAME} APPEND PROPERTY IMPORTED_CONFIGURATIONS ${Configuration})
@ -291,8 +291,8 @@
!!IF !isEmpty(CMAKE_MODULE_EXTRAS)
include(\"${CMAKE_CURRENT_LIST_DIR}/Qt5$${CMAKE_MODULE_NAME}ConfigExtras.cmake\")
--- mkspecs/features/data/cmake/Qt5PluginTarget.cmake.in.orig 2016-08-19 16:04:30.000000000 +0200
+++ mkspecs/features/data/cmake/Qt5PluginTarget.cmake.in 2016-09-14 18:39:18.286693791 +0200
--- mkspecs/features/data/cmake/Qt5PluginTarget.cmake.in.orig 2016-08-19 16:04:30.075761600 +0200
+++ mkspecs/features/data/cmake/Qt5PluginTarget.cmake.in 2016-09-17 16:00:01.818295000 +0200
@@ -1,11 +1,22 @@
-
-add_library(Qt5::$$CMAKE_PLUGIN_NAME MODULE IMPORTED)
@ -305,7 +305,7 @@
-_populate_$${CMAKE_MODULE_NAME}_plugin_properties($$CMAKE_PLUGIN_NAME RELEASE \"$${CMAKE_PLUGIN_LOCATION_RELEASE}\")
+!!IF !isEmpty(CMAKE_STATIC_TYPE)
+ _populate_$${CMAKE_MODULE_NAME}_plugin_properties($$CMAKE_PLUGIN_NAME RELEASE \"$${CMAKE_PLUGIN_LOCATION_RELEASE_STATIC}\")
+ !!ELSE
+!!ELSE
+ _populate_$${CMAKE_MODULE_NAME}_plugin_properties($$CMAKE_PLUGIN_NAME RELEASE \"$${CMAKE_PLUGIN_LOCATION_RELEASE}\")
+!!ENDIF
!!ENDIF
@ -321,8 +321,8 @@
-list(APPEND Qt5$${CMAKE_MODULE_NAME}_PLUGINS Qt5::$$CMAKE_PLUGIN_NAME)
+ list(APPEND Qt5$${CMAKE_MODULE_NAME}_PLUGINS Qt5::$$CMAKE_PLUGIN_NAME)
+endif()
--- mkspecs/features/create_cmake.prf.orig 2016-08-14 20:44:32.000000000 +0200
+++ mkspecs/features/create_cmake.prf 2016-08-19 16:04:30.000000000 +0200
--- mkspecs/features/create_cmake.prf.orig 2016-08-14 20:44:32.513342200 +0200
+++ mkspecs/features/create_cmake.prf 2016-08-19 16:04:30.073546600 +0200
@@ -135,17 +135,19 @@
CMAKE_PLUGIN_NAME = $$PLUGIN_CLASS_NAME

View File

@ -11,7 +11,7 @@
_qt_module=qtdeclarative
pkgname=mingw-w64-qt5-declarative
pkgver=5.7.0
pkgrel=3
pkgrel=4
arch=('i686' 'x86_64')
pkgdesc="Classes for QML and JavaScript languages (mingw-w64)"
depends=('mingw-w64-qt5-base')