PKGBUILDs/gcc/mingw-w64
Martchus 65e78ad95d Fix `__cxa_thread_atexit`-related build errors
Add patch to mingw-w64-gcc after updating to 14.1.1 to fix build errors
like:

```
<built-in>: error: conflicting declaration of C function ‘int __cxxabiv1::__cxa_thread_atexit(void (*)(), void*, void*)’
In file included from /home/devel/.cache/aurman/mingw-w64-paraview/src/ParaView-v5.12.0/build-x86_64-w64-mingw32/VTK/Common/Core/vtkCxxABIConfigure.h:10,
                 from /home/devel/.cache/aurman/mingw-w64-paraview/src/ParaView-v5.12.0/VTK/Common/Core/vtkTypeName.h:7,
                 from /home/devel/.cache/aurman/mingw-w64-paraview/src/ParaView-v5.12.0/VTK/Common/DataModel/vtkCellGrid.h:28:
/usr/x86_64-w64-mingw32/include/c++/14.1.1/cxxabi.h:140:3: note: previous declaration ‘int __cxxabiv1::__cxa_thread_atexit(void (*)(void*), void*, void*)’
  140 |   __cxa_thread_atexit(void (_GLIBCXX_CDTOR_CALLABI *)(void*), void*, void *) _GLIBCXX_NOTHROW;
```
2024-05-14 20:40:22 +02:00
..
0001-missing-__thiscall-attribute-on-builtin-declaration-of-__cxa_thread_atexit.patch Fix `__cxa_thread_atexit`-related build errors 2024-05-14 20:40:22 +02:00
PKGBUILD Fix `__cxa_thread_atexit`-related build errors 2024-05-14 20:40:22 +02:00