PKGBUILDs/qt6-tools/mingw-w64/0001-Enable-only-SQL-plugin...

33 lines
1.2 KiB
Diff

From 76f061a4445e77f49688b694a1f9f448c8589cd4 Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Wed, 9 Jun 2021 17:25:27 +0200
Subject: [PATCH] Enable only SQL plugins which are known to work
Change-Id: I0abc44db77cecbd323edc936529fb557e1664de8
---
src/assistant/assistant/CMakeLists.txt | 8 ++++++++
1 file changed, 8 insertions(+)
diff --git a/src/assistant/assistant/CMakeLists.txt b/src/assistant/assistant/CMakeLists.txt
index 10df7f777..3a2b677c5 100644
--- a/src/assistant/assistant/CMakeLists.txt
+++ b/src/assistant/assistant/CMakeLists.txt
@@ -154,6 +154,14 @@ qt_internal_extend_target(assistant CONDITION UNIX
stdinlistener.cpp stdinlistener.h
)
+if(MINGW)
+ # enable only SQL plugins which are known to work
+ # note: The static plugins for MySQL/PostgreSQL don't work because these libs come with their
+ # own pthread implementation which has conflicting symbols with the normal pthread library
+ # leading to linker errors.
+ qt_import_plugins(assistant INCLUDE_BY_TYPE sqldrivers Qt6::QSQLiteDriverPlugin Qt6::QODBCDriverPlugin)
+endif()
+
if(APPLE)
set_target_properties(assistant PROPERTIES
MACOSX_BUNDLE_INFO_PLIST "${CMAKE_CURRENT_SOURCE_DIR}/Info_mac.plist"
--
2.45.1