PKGBUILDs/qt6-base/mingw-w64/0005-Fix-libjpeg-workaround...

30 lines
1.1 KiB
Diff

From a17fb43c9257fe1e7a1c57f7c968103ed4ee4c7b Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Mon, 2 Nov 2020 13:47:45 +0100
Subject: [PATCH 05/13] Fix libjpeg workaround for conflict with rpcndr.h
Otherwise it won't compile against mingw-w64-libjpeg-turbo. This version of
libjpeg seems to take care of the conflict already as long as jconfig.h is
included before jmorecfg.h.
Change-Id: I011b7735485689c9797cffe2646c8c3d15d0645e
---
src/plugins/imageformats/jpeg/qjpeghandler.cpp | 1 +
1 file changed, 1 insertion(+)
diff --git a/src/plugins/imageformats/jpeg/qjpeghandler.cpp b/src/plugins/imageformats/jpeg/qjpeghandler.cpp
index 0d72ba01d0..a706fb4cea 100644
--- a/src/plugins/imageformats/jpeg/qjpeghandler.cpp
+++ b/src/plugins/imageformats/jpeg/qjpeghandler.cpp
@@ -26,6 +26,7 @@
// including jpeglib.h seems to be a little messy
extern "C" {
#define XMD_H // shut JPEGlib up
+#include <jconfig.h> // ensure jconfig.h is included before jmorecfg.h
#include <jpeglib.h>
#ifdef const
# undef const // remove crazy C hackery in jconfig.h
--
2.43.0