PKGBUILDs/qt5-webkit/mingw-w64/0010-Include-intrin.h-for-d...

26 lines
647 B
Diff

From bfcd0b75a13d6ff4b277382ab4264919b27a08e5 Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Sun, 25 Sep 2016 22:21:54 +0200
Subject: [PATCH 10/11] Include intrin.h for declaration of _mm_mfence
---
Source/WTF/wtf/Atomics.h | 2 ++
1 file changed, 2 insertions(+)
diff --git a/Source/WTF/wtf/Atomics.h b/Source/WTF/wtf/Atomics.h
index 8f950c7..142c0db 100644
--- a/Source/WTF/wtf/Atomics.h
+++ b/Source/WTF/wtf/Atomics.h
@@ -68,6 +68,8 @@
#elif !COMPILER(GCC)
extern "C" void _ReadWriteBarrier(void);
#pragma intrinsic(_ReadWriteBarrier)
+#else
+#include <intrin.h>
#endif
#include <windows.h>
#elif OS(QNX)
--
2.10.2