PKGBUILDs/angleproject/mingw-w64/0007-Remove-copy_scripts-ta...

154 lines
4.6 KiB
Diff

From 1ea025fac01f94d61d254309418ef470c36cbd4c Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Sun, 6 Nov 2016 17:57:18 +0100
Subject: [PATCH 7/8] Remove copy_scripts target
Executing .bat scripts on Linux is a no-go
---
BUILD.gn | 17 ---------------
src/angle.gyp | 61 ------------------------------------------------------
src/libGLESv2.gypi | 7 -------
3 files changed, 85 deletions(-)
diff --git a/BUILD.gn b/BUILD.gn
index 3ade282..8842d96 100644
--- a/BUILD.gn
+++ b/BUILD.gn
@@ -60,17 +60,6 @@ config("extra_warnings") {
}
}
-if (is_win) {
- copy("copy_compiler_dll") {
- sources = [
- "$windows_sdk_path/Redist/D3D/$target_cpu/d3dcompiler_47.dll",
- ]
- outputs = [
- "$root_out_dir/d3dcompiler_47.dll",
- ]
- }
-}
-
angle_undefine_configs = [ "//build/config/compiler:default_include_dirs" ]
static_library("translator") {
@@ -421,12 +410,6 @@ static_library("libANGLE") {
":libANGLE_config",
":internal_config",
]
-
- if (is_win) {
- data_deps = [
- ":copy_compiler_dll",
- ]
- }
}
config("shared_library_public_config") {
diff --git a/src/angle.gyp b/src/angle.gyp
index 578f0f3..083c760 100644
--- a/src/angle.gyp
+++ b/src/angle.gyp
@@ -169,27 +169,6 @@
],
},
},
-
- {
- 'target_name': 'copy_scripts',
- 'type': 'none',
- 'includes': [ '../build/common_defines.gypi', ],
- 'hard_dependency': 1,
- 'copies':
- [
- {
- 'destination': '<(angle_gen_path)',
- 'files': [ 'copy_compiler_dll.bat', '<(angle_id_script_base)' ],
- },
- ],
- 'conditions':
- [
- ['angle_build_winrt==1',
- {
- 'type' : 'shared_library',
- }],
- ],
- },
],
'conditions':
[
@@ -201,7 +180,6 @@
'target_name': 'commit_id',
'type': 'none',
'includes': [ '../build/common_defines.gypi', ],
- 'dependencies': [ 'copy_scripts', ],
'hard_dependency': 1,
'actions':
[
@@ -267,44 +245,5 @@
}
]
}],
- ['OS=="win"',
- {
- 'targets':
- [
- {
- 'target_name': 'copy_compiler_dll',
- 'type': 'none',
- 'dependencies': [ 'copy_scripts', ],
- 'includes': [ '../build/common_defines.gypi', ],
- 'conditions':
- [
- ['angle_build_winrt==0',
- {
- 'actions':
- [
- {
- 'action_name': 'copy_dll',
- 'message': 'Copying D3D Compiler DLL...',
- 'msvs_cygwin_shell': 0,
- 'inputs': [ 'copy_compiler_dll.bat' ],
- 'outputs': [ '<(PRODUCT_DIR)/d3dcompiler_47.dll' ],
- 'action':
- [
- "<(angle_gen_path)/copy_compiler_dll.bat",
- "$(PlatformName)",
- "<(windows_sdk_path)",
- "<(PRODUCT_DIR)"
- ],
- },
- ], #actions
- }],
- ['angle_build_winrt==1',
- {
- 'type' : 'shared_library',
- }],
- ]
- },
- ], # targets
- }],
] # conditions
}
diff --git a/src/libGLESv2.gypi b/src/libGLESv2.gypi
index 1267cc2..56c3e99 100644
--- a/src/libGLESv2.gypi
+++ b/src/libGLESv2.gypi
@@ -1020,13 +1020,6 @@
'ANGLE_ENABLE_NULL',
],
}],
- ['angle_build_winrt==0 and OS=="win"',
- {
- 'dependencies':
- [
- 'copy_compiler_dll'
- ],
- }],
['angle_build_winrt==1',
{
'msvs_requires_importlibrary' : 'true',
--
2.10.2