PKGBUILDs/qt5-base/mingw-w64/0010-Fix-linking-against-st...

30 lines
1.4 KiB
Diff

From c1019300eed7fabb7c2c73d5510e5a83e06a89b2 Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Fri, 3 Feb 2017 20:51:19 +0100
Subject: [PATCH 10/32] Fix linking against static freetype2
---
src/gui/configure.json | 6 ++++--
1 file changed, 4 insertions(+), 2 deletions(-)
diff --git a/src/gui/configure.json b/src/gui/configure.json
index bc3eae90872..d9b540ce428 100644
--- a/src/gui/configure.json
+++ b/src/gui/configure.json
@@ -238,8 +238,10 @@
},
"headers": "ft2build.h",
"sources": [
- { "type": "pkgConfig", "args": "freetype2" },
- { "type": "freetype", "libs": "-lfreetype", "condition": "!config.wasm" },
+ { "type": "pkgConfig", "args": "--libs freetype2", "condition": "features.shared" },
+ { "libs": "-lfreetype -lharfbuzz -lfreetype -lbrotlidec -lbrotlicommon -lglib-2.0 -lintl -lws2_32 -lole32 -lwinmm -lshlwapi -lpcre2-8 -lintl -lpcre2-8 -lintl -liconv -lgraphite2 -lbz2", "condition": "!features.shared && !config.wasm" },
+ { "libs": "-Wl,-Bdynamic -lfreetype -Wl,-Bstatic", "condition": "!features.shared && !config.wasm" },
+ { "libs": "-lfreetype", "condition": "features.shared && !config.wasm" },
{ "libs": "-s USE_FREETYPE=1", "condition": "config.wasm" },
{ "libs": "-lfreetype" }
],
--
2.44.0