PKGBUILDs/qt5-webkit/mingw-w64/0003-Use-system-ANGLE-rathe...

130 lines
4.7 KiB
Diff

From 1c26334f02f106babba2f0659f676d6c3af2dded Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Sun, 25 Sep 2016 21:57:57 +0200
Subject: [PATCH 03/10] Use system ANGLE rather than bundled version
---
Source/WebCore/Target.pri | 2 +-
Source/WebCore/WebCore.pri | 1 +
Source/WebKit/WebKit1.pro | 5 ++++-
Source/WebKit2/Target.pri | 5 ++++-
Source/api.pri | 1 -
Tools/qmake/mkspecs/features/webkit_modules.prf | 2 +-
Tools/qmake/mkspecs/modules/angle.prf | 3 ---
WebKit.pro | 6 ------
8 files changed, 11 insertions(+), 14 deletions(-)
diff --git a/Source/WebCore/Target.pri b/Source/WebCore/Target.pri
index e525aa1..26837c7 100644
--- a/Source/WebCore/Target.pri
+++ b/Source/WebCore/Target.pri
@@ -4194,7 +4194,7 @@ use?(3D_GRAPHICS) {
platform/graphics/texmap/coordinated/CoordinatedTile.cpp \
platform/graphics/texmap/coordinated/UpdateAtlas.cpp
- INCLUDEPATH += $$PWD/platform/graphics/gpu
+ INCLUDEPATH += $$PWD/platform/graphics/gpu /usr/i686-w64-mingw32/sys-root/mingw/include/GLSLANG
contains(QT_CONFIG, opengl) {
contains(QT_CONFIG, opengles2) {
diff --git a/Source/WebCore/WebCore.pri b/Source/WebCore/WebCore.pri
index 37cde57..022f8da 100644
--- a/Source/WebCore/WebCore.pri
+++ b/Source/WebCore/WebCore.pri
@@ -214,6 +214,7 @@ use?(3D_GRAPHICS) {
CONFIG(debug, debug|release):contains(QT_CONFIG, angle) {
LIBS += $$QMAKE_LIBS_OPENGL_ES2_DEBUG
} else {
+ INCLUDEPATH += /usr/i686-w64-mingw32/sys-root/mingw/include/GLSLANG
LIBS += $$QMAKE_LIBS_OPENGL_ES2
}
} else {
diff --git a/Source/WebKit/WebKit1.pro b/Source/WebKit/WebKit1.pro
index 6dbb907..6f18db2 100644
--- a/Source/WebKit/WebKit1.pro
+++ b/Source/WebKit/WebKit1.pro
@@ -96,7 +96,10 @@ HEADERS += \
INCLUDEPATH += \
$$PWD/qt/WebCoreSupport
-use?(3D_GRAPHICS): WEBKIT += angle
+use?(3D_GRAPHICS) {
+ WEBKIT += angle
+ INCLUDEPATH += /usr/i686-w64-mingw32/sys-root/mingw/include/GLSLANG
+}
have?(qtpositioning):enable?(GEOLOCATION) {
HEADERS += \
diff --git a/Source/WebKit2/Target.pri b/Source/WebKit2/Target.pri
index a9179d9..ac020a4 100644
--- a/Source/WebKit2/Target.pri
+++ b/Source/WebKit2/Target.pri
@@ -949,7 +949,10 @@ enable?(TOUCH_EVENTS) {
have?(qtpositioning):enable?(GEOLOCATION): QT += positioning
-use?(3D_GRAPHICS): WEBKIT += angle
+use?(3D_GRAPHICS) {
+ WEBKIT += angle
+ INCLUDEPATH += /usr/i686-w64-mingw32/sys-root/mingw/include/GLSLANG
+}
use?(PLUGIN_BACKEND_XLIB) {
DEFINES += XP_UNIX
diff --git a/Source/api.pri b/Source/api.pri
index de04652..f972f67 100644
--- a/Source/api.pri
+++ b/Source/api.pri
@@ -24,7 +24,6 @@ build?(webkit1): {
}
build?(webkit2): QMAKE_INTERNAL_INCLUDED_FILES *= WebKit2/Target.pri
-use?(3D_GRAPHICS): WEBKIT += angle
use?(leveldb):!use?(system_leveldb) WEBKIT += leveldb
MODULE = webkit
diff --git a/Tools/qmake/mkspecs/features/webkit_modules.prf b/Tools/qmake/mkspecs/features/webkit_modules.prf
index 7040cbb..8c13175 100644
--- a/Tools/qmake/mkspecs/features/webkit_modules.prf
+++ b/Tools/qmake/mkspecs/features/webkit_modules.prf
@@ -7,7 +7,7 @@
# Reorder libraries so that the link and include order is correct,
# and make sure the case matches the original case.
-libraries = WebKit1 WebKit2 WebCore ANGLE leveldb JavaScriptCore WTF
+libraries = WebKit1 WebKit2 WebCore leveldb JavaScriptCore WTF
for(library, libraries) {
contains(WEBKIT, $$lower($$library)) {
WEBKIT -= $$lower($$library)
diff --git a/Tools/qmake/mkspecs/modules/angle.prf b/Tools/qmake/mkspecs/modules/angle.prf
index 18631a7..3b04dea 100644
--- a/Tools/qmake/mkspecs/modules/angle.prf
+++ b/Tools/qmake/mkspecs/modules/angle.prf
@@ -4,6 +4,3 @@
# See 'Tools/qmake/README' for an overview of the build system
# -------------------------------------------------------------------
-WEBKIT.angle.root_source_dir = $${ROOT_WEBKIT_DIR}/Source/ThirdParty/ANGLE
-
-include($${WEBKIT.angle.root_source_dir}/ANGLE.pri)
diff --git a/WebKit.pro b/WebKit.pro
index 11b59e5..e9709a2 100644
--- a/WebKit.pro
+++ b/WebKit.pro
@@ -18,12 +18,6 @@ JavaScriptCore.file = Source/JavaScriptCore/JavaScriptCore.pro
JavaScriptCore.makefile = Makefile.JavaScriptCore
SUBDIRS += JavaScriptCore
-use?(3D_GRAPHICS) {
- ANGLE.file = Source/ThirdParty/ANGLE/ANGLE.pro
- ANGLE.makefile = Makefile.ANGLE
- SUBDIRS += ANGLE
-}
-
use?(leveldb):!use?(system_leveldb) {
leveldb.file = Source/ThirdParty/leveldb/leveldb.pro
leveldb.makefile = Makefile.leveldb
--
2.10.0