PKGBUILDs/qt5-declarative/mingw-w64-static/0002-Prevent-exporting-QML-...

38 lines
1.2 KiB
Diff

From 1aca21342b43a16c9c1cc6af0514e9dc2b28917a Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Sat, 4 Feb 2017 01:59:59 +0100
Subject: [PATCH 2/2] Prevent exporting QML parser symbols on static build
---
src/qml/parser/qqmljsglobal_p.h | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/src/qml/parser/qqmljsglobal_p.h b/src/qml/parser/qqmljsglobal_p.h
index bf8155c6ec..2bfa230bcc 100644
--- a/src/qml/parser/qqmljsglobal_p.h
+++ b/src/qml/parser/qqmljsglobal_p.h
@@ -54,9 +54,9 @@
#ifdef QT_CREATOR
-# ifdef QDECLARATIVEJS_BUILD_DIR
+# if defined(QDECLARATIVEJS_BUILD_DIR) && !defined(QT_STATIC)
# define QML_PARSER_EXPORT Q_DECL_EXPORT
-# elif QML_BUILD_STATIC_LIB
+# elif defined(QML_BUILD_STATIC_LIB) || defined(QT_STATIC)
# define QML_PARSER_EXPORT
# else
# define QML_PARSER_EXPORT Q_DECL_IMPORT
@@ -64,7 +64,7 @@
#else // !QT_CREATOR
# ifndef QT_STATIC
-# if defined(QT_BUILD_QMLDEVTOOLS_LIB) || defined(QT_QMLDEVTOOLS_LIB)
+# if defined(QT_BUILD_QMLDEVTOOLS_LIB) || defined(QT_QMLDEVTOOLS_LIB) || defined(QT_STATIC)
// QmlDevTools is a static library
# define QML_PARSER_EXPORT
# elif defined(QT_BUILD_QML_LIB)
--
2.26.2