PKGBUILDs/qt5-base/mingw-w64-angle/0017-Enable-rpath-for-build...

36 lines
1.3 KiB
Diff

From 0e79722e8c8162f87b2b765932d3507de2f20a88 Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Sun, 18 Sep 2016 17:59:27 +0200
Subject: [PATCH 17/30] Enable rpath for build tools
- Required because library various tools depend on (libQt5Bootstrap.so) resides
in folder /usr/${_arch}/lib
- Can't use regular lib dir because it would conflict with the native package
---
mkspecs/features/qt_app.prf | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/mkspecs/features/qt_app.prf b/mkspecs/features/qt_app.prf
index cb84ae0da8..8d9471ed0a 100644
--- a/mkspecs/features/qt_app.prf
+++ b/mkspecs/features/qt_app.prf
@@ -20,6 +20,7 @@ isEmpty(QMAKE_INFO_PLIST): CONFIG -= app_bundle
QMAKE_LFLAGS += $$QMAKE_LFLAGS_GCSECTIONS
host_build: QT -= gui # no host tool will ever use gui
+host_build: QMAKE_RPATHDIR += $$[QT_INSTALL_LIBS/dev] # force rpath
host_build:force_bootstrap {
!build_pass:qtConfig(release_tools): CONFIG += release
contains(QT, core(-private)?|xml) {
@@ -30,7 +31,6 @@ host_build:force_bootstrap {
} else {
!build_pass:qtConfig(debug_and_release): CONFIG += release
target.path = $$[QT_INSTALL_BINS]
- CONFIG += relative_qt_rpath # Qt's tools and apps should be relocatable
}
INSTALLS += target
--
2.12.1