PKGBUILDs/postgresql/mingw-w64/0001-Use-.dll.a-as-extensio...

104 lines
3.7 KiB
Diff

From ffc33301366f141f16519fc4999944c93d1e4a61 Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Sun, 7 Mar 2021 18:22:06 +0100
Subject: [PATCH 1/2] Use .dll.a as extension for import libraries
---
src/Makefile.shlib | 2 +-
src/backend/Makefile | 24 ++++++++++++------------
2 files changed, 13 insertions(+), 13 deletions(-)
diff --git a/src/Makefile.shlib b/src/Makefile.shlib
index 29a7f6d38c..106139e929 100644
--- a/src/Makefile.shlib
+++ b/src/Makefile.shlib
@@ -85,7 +85,7 @@ else
# Naming convention for dynamically loadable modules
shlib = $(NAME)$(DLSUFFIX)
endif
-stlib = lib$(NAME).a
+stlib = lib$(NAME).dll.a
ifndef soname
# additional flags for backend modules
diff --git a/src/backend/Makefile b/src/backend/Makefile
index 9706a95848..21d43c072b 100644
--- a/src/backend/Makefile
+++ b/src/backend/Makefile
@@ -72,11 +72,11 @@ endif
ifeq ($(PORTNAME), cygwin)
postgres: $(OBJS)
- $(CC) $(CFLAGS) $(call expand_subsys,$^) $(LDFLAGS) $(LDFLAGS_EX) $(export_dynamic) -Wl,--stack,$(WIN32_STACK_RLIMIT) -Wl,--export-all-symbols -Wl,--out-implib=libpostgres.a $(LIBS) -o $@
+ $(CC) $(CFLAGS) $(call expand_subsys,$^) $(LDFLAGS) $(LDFLAGS_EX) $(export_dynamic) -Wl,--stack,$(WIN32_STACK_RLIMIT) -Wl,--export-all-symbols -Wl,--out-implib=libpostgres.dll.a $(LIBS) -o $@
-# libpostgres.a is actually built in the preceding rule, but we need this to
+# libpostgres.dll.a is actually built in the preceding rule, but we need this to
# ensure it's newer than postgres; see notes in src/backend/parser/Makefile
-libpostgres.a: postgres
+libpostgres.dll.a: postgres
touch $@
endif # cygwin
@@ -85,11 +85,11 @@ ifeq ($(PORTNAME), win32)
LIBS += -lsecur32
postgres: $(OBJS) $(WIN32RES)
- $(CC) $(CFLAGS) $(call expand_subsys,$(OBJS)) $(WIN32RES) $(LDFLAGS) $(LDFLAGS_EX) -Wl,--stack=$(WIN32_STACK_RLIMIT) -Wl,--export-all-symbols -Wl,--out-implib=libpostgres.a $(LIBS) -o $@$(X)
+ $(CC) $(CFLAGS) $(call expand_subsys,$(OBJS)) $(WIN32RES) $(LDFLAGS) $(LDFLAGS_EX) -Wl,--stack=$(WIN32_STACK_RLIMIT) -Wl,--export-all-symbols -Wl,--out-implib=libpostgres.dll.a $(LIBS) -o $@$(X)
-# libpostgres.a is actually built in the preceding rule, but we need this to
+# libpostgres.dll.a is actually built in the preceding rule, but we need this to
# ensure it's newer than postgres; see notes in src/backend/parser/Makefile
-libpostgres.a: postgres
+libpostgres.dll.a: postgres
touch $@
endif # win32
@@ -198,12 +198,12 @@ distprep:
install: all installdirs install-bin
ifeq ($(PORTNAME), cygwin)
ifeq ($(MAKE_DLL), true)
- $(INSTALL_DATA) libpostgres.a '$(DESTDIR)$(libdir)/libpostgres.a'
+ $(INSTALL_DATA) libpostgres.dll.a '$(DESTDIR)$(libdir)/libpostgres.dll.a'
endif
endif
ifeq ($(PORTNAME), win32)
ifeq ($(MAKE_DLL), true)
- $(INSTALL_DATA) libpostgres.a '$(DESTDIR)$(libdir)/libpostgres.a'
+ $(INSTALL_DATA) libpostgres.dll.a '$(DESTDIR)$(libdir)/libpostgres.dll.a'
endif
endif
$(MAKE) -C catalog install-data
@@ -263,12 +263,12 @@ ifeq ($(MAKE_EXPORTS), true)
endif
ifeq ($(PORTNAME), cygwin)
ifeq ($(MAKE_DLL), true)
- rm -f '$(DESTDIR)$(libdir)/libpostgres.a'
+ rm -f '$(DESTDIR)$(libdir)/libpostgres.dll.a'
endif
endif
ifeq ($(PORTNAME), win32)
ifeq ($(MAKE_DLL), true)
- rm -f '$(DESTDIR)$(libdir)/libpostgres.a'
+ rm -f '$(DESTDIR)$(libdir)/libpostgres.dll.a'
endif
endif
$(MAKE) -C catalog uninstall-data
@@ -287,10 +287,10 @@ endif
clean:
rm -f $(LOCALOBJS) postgres$(X) $(POSTGRES_IMP)
ifeq ($(PORTNAME), cygwin)
- rm -f postgres.dll libpostgres.a
+ rm -f postgres.dll libpostgres.dll.a
endif
ifeq ($(PORTNAME), win32)
- rm -f postgres.dll libpostgres.a $(WIN32RES)
+ rm -f postgres.dll libpostgres.dll.a $(WIN32RES)
endif
distclean: clean
--
2.30.1