PKGBUILDs/qt5-base/mingw-w64-static/0025-Use-correct-pkg-config...

27 lines
751 B
Diff

From 2c846ab2a45c159905715e98338246f86e98e5a8 Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Sun, 18 Sep 2016 18:50:21 +0200
Subject: [PATCH 25/34] Use correct pkg-config --static flag
---
configure.pri | 3 +++
1 file changed, 3 insertions(+)
diff --git a/configure.pri b/configure.pri
index c3ce522e4f..59a9b1e88a 100644
--- a/configure.pri
+++ b/configure.pri
@@ -311,6 +311,9 @@ defineTest(qtConfTest_detectPkgConfig) {
qtLog("Found pkg-config from path: $$pkgConfig")
}
}
+ !isEmpty(pkgConfig):qtConfig(static) {
+ pkgConfig = "$$pkgConfig --static"
+ }
$$qtConfEvaluate("features.cross_compile") {
# cross compiling, check that pkg-config is set up sanely
--
2.18.0