PKGBUILDs/qt5-base/mingw-w64/qt5-fix-QSemaphore-problem....

10 lines
378 B
Diff

@@ -4456,7 +4456,7 @@
if compileTest unix/ipc_posix "ipc_posix" ; then
QCONFIG_FLAGS="$QCONFIG_FLAGS QT_POSIX_IPC"
else
- if [ "$XPLATFORM_ANDROID" = "no" ] ; then
+ if [ "$XPLATFORM_ANDROID" = "no"] && ["$XPLATFORM_MINGW" = "no" ] ; then
QCONFIG_FLAGS="$QCONFIG_FLAGS QT_NO_SYSTEMSEMAPHORE QT_NO_SHAREDMEMORY"
fi
fi