PKGBUILDs/qt5-base/mingw-w64-dynamic/0034-Don-t-use-the-statx-sy...

28 lines
1.0 KiB
Diff

From 06c69dbc4aa16012b8ab05b586fb2e261405a037 Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Sat, 9 Dec 2017 00:36:56 +0100
Subject: [PATCH 34/34] Don't use the statx syscall
Otherwise Qt can not be built in a systemd
container
---
src/corelib/io/qfilesystemengine_unix.cpp | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/corelib/io/qfilesystemengine_unix.cpp b/src/corelib/io/qfilesystemengine_unix.cpp
index 77d154c6b4..6036bae4f1 100644
--- a/src/corelib/io/qfilesystemengine_unix.cpp
+++ b/src/corelib/io/qfilesystemengine_unix.cpp
@@ -95,7 +95,7 @@ static int renameat2(int oldfd, const char *oldpath, int newfd, const char *newp
{ return syscall(SYS_renameat2, oldfd, oldpath, newfd, newpath, flags); }
# endif
-# if !QT_CONFIG(statx) && defined(SYS_statx) && QT_HAS_INCLUDE(<linux/stat.h>)
+# if 0
# include <linux/stat.h>
static int statx(int dirfd, const char *pathname, int flag, unsigned mask, struct statx *statxbuf)
{ return syscall(SYS_statx, dirfd, pathname, flag, mask, statxbuf); }
--
2.15.1